• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 178
  • Last Modified:

Non PNP Modem setup in Win95

I have a Aceropen 36.6 jumpered modem (set to default of COM4 - irq 3 - Add. 2E8 ) that I can't get working in Win95.

The modem installs OK but defaults to Com 2 (error - can't open port) and if changed to com4 then error - port already open!  

I've installed and set ports in system manager with com 2 installed, not installed, com 4 installed, not installed, tried no ports and reboot (installs com 1 (mouse) and 2, but not 4) and manually installed 4 with correct irq and add.  

I alway keep getting the port already open error!
1 Solution
setit up to COM3. IRQ 3. make sure IRQ 3 it is not used by anyother program. usually IRQ4 and COM1 will be used. Remove the Coms in System properties.Reboot; and then reinstall , in the Add/remove hardware let it see what if find and install the COM that will find.and then reboot.
Please see the information at the following URL.


it can also simplify things greatly if you disable any unused COM ports in both the motherboard BIOS setup and in windows by checking the box "disable in this hardware profile".  The likihood of conflicts is greatly reduced.

hardlockAuthor Commented:
Went and read it.   Ah.....so if a com port is installed in windows, you can't assign a modem to it?  I don't get it.  I understand all about conflicts of irqs, etc. but I show 2 serial ports available in bios, one I'm using for serial mouse (com 1) and I would assume I'd need com2 for the modem since 1 & 3 share an irq and 2 & 4 share the other. Could use more info on this.
Managed Security Services Webinar - March 15

Selecting the right managed security services platform to grow your business can be a huge undertaking. Join WatchGuard and Frost & Sullivan in an upcoming webinar as we dive into the key elements of selecting a vendor platform and partnership to fuel a successful MSSP business.

The com ports on most modems are built-in.  They have their own COM ports so you don't want to assign one from the motherboard to handle it.  In short, if you want your internal modem to be at COM2, you must disable all other COM2 ports including those of the motherboard.  I suggest you disable the COM port in the BIOS that is not used for the mouse, and then install the modem at COM2.

Have you had any luck with this yet?
If not, I suggest you try to determine if the modem will operate in Dos before getting into all the headaches that Windows can produce.  Once configured properly and recognized by Dos, Windows will find & install it correctly.

Since this modem can be jumpered to COM4, IRQ3, is the correct serial port address (03E8) reported by the BIOS at bootup?
(Most computers have a screen showing installed devices just after memory counts up.)

If BIOS doesn't see it, There is no need to go any further.  I would try other settings until you know that it is recognized.  
When the COM address is reported correctly, test the modem by dialing with the following command from a Dos prompt:

ECHO ATDT 123456 >COM4

The above should apply if the modem is truly a jumper-configurable device.  This won't work if it requires software drivers to initialize the modem.  In that case you'll need the driver.
Let me know how it goes.

hardlockAuthor Commented:
finally got it working.  Everytime I try to install a modem I seem to have the same problems.  If the port is installed, the modem says it's already open.  If it's not, then it says it can't open it.  Eventually something "clicks" and Windows finds the modem and installs it and the right port.  This time, after deleteing the modem and trying to reinstall it, I'd get the message that no new modems found.  Only after I rejumpered to different settings did it come up right.  Thanks all for your help.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now