Solved

Windows 98 with no mouse

Posted on 1998-12-22
9
156 Views
Last Modified: 2013-12-29
Our Kontron KOI industrial panel PCs have touchscreens. I'm upgrading to Windows 98 and they have started complaining about not having mice connected when they are started up. How do I stop them complaining?

There is not enough room in their terminal chambers to connect a mouse and hide it away.(And it would have to be hidden there as they are used in a very wet environment)

Cheers
TW
0
Comment
Question by:tedwood
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 6

Expert Comment

by:bartsmit
ID: 1649621
There is a "do not show this message again" option on the no mouse connected dialog box. Have you checked this? Then the dialog would not stop win98 booting from then on.

Or is the problem that the touchscreens don't work with win98?
In that case you'll need an (updated) driver from the touchscreen manufacturer.
0
 

Author Comment

by:tedwood
ID: 1649622
bartsmit wrote:

>There is a "do not show this message again" option on the no >mouse connected dialog box. Have you checked
>this? Then the dialog would not stop win98 booting from then on

Sadly, when this message comes up the touchscreen driver has not yet loaded so I have no way of ticking this box. And plugging in a mouse at this point does not work.

Cheers
TW
0
 
LVL 6

Expert Comment

by:bartsmit
ID: 1649623
You should be able to hit tab until you get a faint highlight over the "do not show this message again" text and then hit the spacebar to enable the associated tick box.

You can then hit enter to dismiss the dialog (for ever) or tab over to the OK button and hit space again.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 2

Expert Comment

by:rlippert
ID: 1649624
I haven't tested this but it might work:
Try installing a mouse and having windows detect it (or maybe just install manually even if you don't have one connected) and then go to the hardware properties for the device under device manager and check "disabled."  Like I said - don't know if this will work...
0
 
LVL 4

Expert Comment

by:istal112898
ID: 1649625
check the BIOS setup that COM1 be ENABLE. and Not Disable. Make sure the COM1 is connected to the Motherboard. they might be connecting to SERIAL COM2. instead of 1 and therefore it doesnt recognize it. You might want to try that. to check the cable of the card are where they are supposed to be and not loosen up. if it is a PS2, make sure in the Bios setup is enable an option for PS/2 Support. also check cable of the card.
the last solution will be to change the Card and connect it to the Motherboard.
see if it works.
0
 

Expert Comment

by:HotAirPilot
ID: 1649626
In order to help I first have to know how the touch screens operate.   Do they have use a com port (serial or parallel) or are they connected as an "other device."  You can remove com ports (both serial and p[arallel) and mice.  But you don't want to mess with them if the touch screen uses one of their resources to do its magic.

You may also have to tweek the windows registry to get the whole thing working properly.  But the first thing to do is to make sure you don't compromise your touch screens.


0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 1649627
To tedwood, mouse is a very tricky point of microsoft'strategy since win95, and most significant in win98, microsoft intended everybody installing win98 should buy a microsoft mouse especially their newly designed 'intelli-mouse with wheel'. If you don't hv a ms-mouse, yr windows will get a lot of troubles.
Thus,during first installation of win98, get a microsoft-compatible serial mouse (and not a PS/2 mouse because your touch-screen is using the internal pointing device and is sharing the use of PS/2, causing PS/2 mouse to work improper). Connect the serial mouse to your available com port (1 or 2). Then start installing win98, your serial mouse will be detected automatically. After installation, you can then unplug the mouse and yr computer run normal by yr touch screen.

As you hv installed win98 without a serial-mouse attached,then connect the ms-serial mouse to com port. switch on computer, after mouse detected. Unplug the mouse to free the com port for the next time you turn on computer.      Pslh
0
 
LVL 23

Expert Comment

by:Tim Holman
ID: 1649628
Disable the mouse in the hardware profile ?
That should be all you have to do !
0
 
LVL 25

Accepted Solution

by:
dew_associates earned 100 total points
ID: 1649629
Tedwood, boot to the Bios setup. Disable PS/2 mouse support in the bios. If there's nothing on the Com1 serial port, disable that as well. Now Windows can't see it and will run without it.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

No single Antivirus application (despite claims by manufacturers) will catch or protect you from all Virus / Malware or Spyware threats. That doesn't stop you from further protecting yourself however - and this article is to show you how.
A small collection of useful tips and tricks for Windows 10 users that I decided to write as a result of recent questions that were asked and answered at Experts Exchange. Two short video tutorials included. Enjoy..
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

622 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question