Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

File TCP/IP Preferences could not be.....

Posted on 1998-12-22
6
Medium Priority
?
571 Views
Last Modified: 2013-12-27
I have a (L)user that keeps messing with his MAC computer.  I had everything working the other day and kjnow it's gone to heck !!  He is my only Mac (L)user.  Everyone else use Win95 desktops connected to an NT server.  When i went to re-configure the TCP/IP connections on his computer i got the following error.

The file "TCP/IP Preferences" could not be opened because it is locked or being used by another application.

I've re-booted this machine twice and everytime i go to mess with the TCP/IP setting i get that message.  can someone please help me out ??

tommy
0
Comment
Question by:ttrogden
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 3

Expert Comment

by:KevSpencer
ID: 1542135
Hi, tlrogden.

I tested out a thought on my Mac. My best suspicion is that your user has indeed locked the TCP/IP preferences file, located in the Preferences folder, inside the System Folder. To check it, locate that icon, click it once to select it, and choose Get Info from the File menu. There, you'll see (among other things) a checkbox named "Locked". If the checkbox is checked, you've found your culprit. Uncheck the box to allow edits to the TCP/IP settings via the TCP/IP control panel. When I did this on my Mac, I experienced the exact message you described.

If this did not clear it up or the preferences file is not locked, it is possible that somehow the TCP/IP preferences file is damaged. Hopefully you have the user's IP address settings written down. Drag the TCP/IP Preferences file and the AppleShare Prep preferences file to the Trash and restart. Immediately after the chime, hold down the Apple, Option, P and R keys until the Mac chimes once, then continue holding the keys down until it chimes once more. This clears out the Mac's PRAM (the CMOS-like setting for many things, including network settings).

From there, open the AppleTalk control panel, set the computer back to Ethernet, then open the TCP/IP control panel and reestablish the network settings. Good luck.  --KS
0
 
LVL 5

Expert Comment

by:paulvaneykelen
ID: 1542136
The problem is not the TCP/IP control panels, but one of the other Control Panels. I can't remember which one it is though.

The best thing to do is write down the TCP/IP information.
Drag the pref folder to the desktop and restart
Make the changes to the TCP/IP control panel.

The problem may be caused by the general control panel and system folder security check box.
0
 

Expert Comment

by:dambruso
ID: 1542137
If you are logging on to an NT network, there is a good bet that the server is restricting access the registry.  It dosen't like the user to change anything in the system folder.
0
New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

 
LVL 30

Expert Comment

by:weed
ID: 1542138
Chock up another one for good old NT...Neanderthal Technology...*cheers*..hehe
0
 
LVL 2

Accepted Solution

by:
sgodun earned 400 total points
ID: 1542139
VERY simple answer here, folks -- you're all digging too deep. The "TCP/IP Preferences file is corrupt.
ttrogden -- Pointless slander about "Mac (L)users" aside, here's what you need to do. First, make note of the Mac's IP address (assuming it's manually entered and not via a DHCP server as any decent network would be). Next, open the user's hard drive. Locate and open his System Folder. Locate and open his Preferences folder (within the System Folder). Locate the file "TCP/IP Preferences" and toss it into the trash. Close all windows. Restart the Mac (via the SPECIAL menu). When the Finder reappears, empty the trash. Open the TCP/IP control panel and reenter the IP information. That should cure your problems.

And next time, try asking NICELY. Many of us are well aware of the, uh, "mindset" of Windows users and don't need such blatant reminders. Thanks.

0
 
LVL 1

Author Comment

by:ttrogden
ID: 1542140
BTW - the knock was on the guy not the os - hes just as bad on a Win95 machine - he's a guy that knows just enough to really mess things up !!
tommyt

0

Featured Post

Ask an Anonymous Question!

Don't feel intimidated by what you don't know. Ask your question anonymously. It's easy! Learn more and upgrade.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Apple's line of laptop computers has made significant strides forward in the last few years. The biggest change being the switch to Intel processors in 2005. One thing about Apple hardware, especially that from a few years ago, is the tendency for i…
What's a UDID? If you're involved in developing, testing, or even reviewing an iOS application that's in beta, then at some point you may need to know the UDID for any iOS devices that you'll be testing on. What's the UDID? It stands for Unique Dev…
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…
Are you ready to place your question in front of subject-matter experts for more timely responses? With the release of Priority Question, Premium Members, Team Accounts and Qualified Experts can now identify the emergent level of their issue, signal…

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question