Solved

Browsers not connecting automatically!

Posted on 1998-12-23
22
325 Views
Last Modified: 2008-02-01
When I start Netscape or IE4 they do not try and connect to the net and I get the page not found error message.  Can only connect and browse via dial up networking and then launching appropriate web browser.  Please help!!!!
0
Comment
Question by:superfi
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 4
  • +5
22 Comments
 
LVL 12

Expert Comment

by:Otta
ID: 1818870
This is an "option" which you have chosen, within Netscape.
Just click on 'Options', within Netscape,
and change the value.
0
 
LVL 10

Expert Comment

by:MasseyM
ID: 1818871
For IE: View / Internet Options / Connection Tab / And make sure you have the conenct with modem selected.
0
 
LVL 2

Expert Comment

by:kayton
ID: 1818872
You can always connect to the Net manually by using dial-up networking.  Make a shortcut to it on your desktop and/or start menu.
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
LVL 11

Expert Comment

by:kmartin7
ID: 1818873
>This is an "option" which you have chosen, within Netscape.

"Options" does not exist in NC4.5, (at least that I can find) and I don't think it exists on any NS 4.0x, does it?
0
 
LVL 3

Expert Comment

by:rosefire
ID: 1818874
Go to My Computer > Control Panel > Internet and select the "connections" tab.  Verify that the values are right.  If so run the connection wizard and answer the questions.

RoseFire
0
 
LVL 11

Expert Comment

by:kmartin7
ID: 1818875
RoseFire.

This will only work for IE.  I am having the same problem with NC 4.5 on only one of my 3 e-mail accounts (one personal, one for orders, and another for webmaster).  At first, all 3 profiles automatically launched the dial-ip connection dialog.  Now, 1 of them does not.  It is driving me crazy, because I have not been able to correct the problem.  For NC 4.5, the answer has to be somewhere in the Communicator profiles, as I launch the same Communicator for all 3, I just choose a different profile for each.
0
 
LVL 7

Expert Comment

by:bjt3
ID: 1818876
I'm on NT right now, so can't fully check this out. However, if it's really profile dependent then one of the first places to look is in your prefs.js.  See c:\program files\netscape\users\<youname>\prefs.js.  In this file, as near as I can tell, look for a key called DialOnDemand and see what it's set to.  Be sure to check to see if (and what) it's set to in the profiles that do work.  If I get a chance, I'll try experimenting with this from a Win95 system.

(The next place to look is the registry.  I'd start with HKEY_CURRENT_USER\Remote Access.  I'd try prefs.js first, though.)
0
 
LVL 3

Expert Comment

by:rosefire
ID: 1818877
kmarin7, I think you are right about the "options"

However, affter loading Windows 98 many times I found it always seems to trash the windows setting that launches dial up networking automatically for NS.  It may be that there are multiple settings involved in this case but I know that the setting there makes a difference.  I strongly suspect that the connection wizard has nothing to do with it, but that is the procedure I have followed many times after installing netscape. Perhaps the setting  is affected in two places.

By the way, Masseym, sorry for posting a duplicate to your answer, I don't know how I missed it. I know the box we both noted has to be checked.

Perhaps in this system  the problem  has something to do with windows handling of the default browser/mailer/etc.

Also I would just like to point  out  the Internet Settings for
+ Internet Explorer should check to see whether it is the default browser (programs tab)
+ show internet explorer on the desktop (advanced tab)

Microsoft cleverly spread the IE settings all over the place to make not using IE hard.

There is a registry entry for the automatic launching, perhaps someone knows it.

From the command line or a batch file you can also type:
rundll32.exe rnaui.dll.RnaDial [connection name]
Not that this helps much more than putting a shortcut on the desktop.
RoseFire
0
 
LVL 11

Expert Comment

by:kmartin7
ID: 1818878
bjt3:
After thoroughly checking Netscape for settings, user prefs.js was the first place I looked. I haven't thought about checking the registry, but there should be an easier method for the average joe to be able to change this.  I'll check the registry next.

RoseFire:
Funny thing.  Last night I got into an *argument* with a fellow worker about Microsoft spreading around the IE settings.  My argument agrees with your statement, but my co-worker is a huge Microsoft supporter, and in his eyes, Microsoft would do nothing to that effect *purposely*.

Kurt
0
 

Accepted Solution

by:
spaceepic earned 100 total points
ID: 1818879
See the following link for information on automatic dialup setup:

http://www.annoyances.org/win95/win95ann5.html#18
0
 
LVL 7

Expert Comment

by:bjt3
ID: 1818880
The proposed answer is interesting.  If it works, please leave a comment here saying so. It will also be interesting to understand why it affects only one of your profiles.

"...but there should be an easier method for the average joe to be able to change this" - I agree, but I also don't expect any changes soon.
0
 
LVL 11

Expert Comment

by:kmartin7
ID: 1818881
Although I didn't ask this question, I have the same problem.  I downloaded the file mentioned in the proposed answer, and it still doesn't work.  I have checked the Registry, to no avail.  It has to be something in the profile...

Kurt
0
 

Expert Comment

by:spaceepic
ID: 1818882
In reference to the proposed answer, I was able to resolve this "automatic dialup" issue with Netscape using the procedure from the URL, and its associated Registry fix.  I will add that I also ensured that Client for Microsoft Networks was loaded so that Windows would remember my login password for the Dialup Networking connectoid (although I did have to delete my PWL files and allow Windows to recreate them for this "password-save" to work properly).

For IE4, use the "Internet" applet in the Control Panel to properly reference the correct Dialup-Networking connection name.
It could be that it is pointing to the wrong name.
0
 

Expert Comment

by:spaceepic
ID: 1818883
(Note:  This is the text that is near the bottom of the URL for the proposed solution. I implemented Solution #2.)  


Enabling Autodial with Dial-Up Networking
Last Modified: 8/31/96
If you've bought the Plus! pack or have installed Internet Explorer, the autodial feature was automatically installed for Internet Explorer. However, without blowing $45 on Microsoft's patchwork software, here's how to install this functionality for use with Netscape (or whatever browser you've most recently used):


Solution #1:
Download and install Dunce, which also has the ability to redial when disconected, and can launch any program when a connection has been established - freeware.

Solution #2:
Download and install the AutoDial Registry Patch (49 kb).
If you don't have the file URL.DLL in your Windows\System directory, copy the one included in the ZIP file to that location.
Double-click on the AutoDial.REG file to apply the patch to your Registry.
- submitted by Liane Goodrich

Note: To change the connection used with the autodial feature (solution #2), open the Registry Editor (REGEDIT.EXE), open the HKEY_CURRENT_USER\ RemoteAccess\ branch, and change the value of the InternetProfile key.
- note submitted by Rich Raine

Note: This probably will only work for 32-bit applications.
- note submitted by John Gilman

Note: If you're having trouble getting it to dial properly, see When I run my internet application to invoke the dialer automatically, it doesn't always work.

0
 
LVL 2

Expert Comment

by:kmrussell
ID: 1818884
It is something very simple. It was related to MasseyM's and "Rosefire's" comment. Forget the registry !

First make sure the setting is correct in "Control Panel"..."Internet"...Make sure it is on "Connect to the Internet using a modem" and that the dial-up connection is selected in "settings".

Now make a connection to the internet (without the browser).
After you are connected, open the browser. Then immediately close the browser and then close the connection.

Now open the browser and it should initiate a connection.
0
 
LVL 7

Expert Comment

by:bjt3
ID: 1818885
So, why did this apply to only one of several Netscape profiles ?

I think it's great that you've resolved the problem.  I've very curious as to what was the actual cause and how it resulted in what you saw.
0
 
LVL 2

Expert Comment

by:kmrussell
ID: 1818886
I am not the "question asker".
0
 
LVL 2

Expert Comment

by:kmrussell
ID: 1818887
I am offering a solution to reset the dial-up connection auto-dial feature. If 1 profile is not working, it is the same concept as a different program on the system not able to auto-dial and another program having that capability.

KR
0
 
LVL 7

Expert Comment

by:bjt3
ID: 1818888
My query about the profiles was an open question intended to relate to this particular answer. It would be interesting to know if this solution fits the multiprofile-but-not-all-work problem.
0
 
LVL 11

Expert Comment

by:kmartin7
ID: 1818889
I am the one having the problem with it not auto-dialing on 1 profile, but I didn't ask the original question.  I have tried everything, to no avail.  I looked at ini and config files, looked at the registry, tried the patch, and nothing has corrected the problem.  Funny thing, my mother called me with the same problem on her computer.  The first thing I thought about looking at was what software we had in common.  I then realized that I gave my parents a copy of a Netscape 4.5 CCK version my company's browser.  I then tested it on another computer, and eventually came up with the same problem.  My problem is a bug in the Netscape CCK 4.5 browser.

Now, since superfi originally asked this question and has not posted a comment since, This is probably a dead question...

Kurt
0
 
LVL 12

Expert Comment

by:Otta
ID: 1818890
> This is probably a dead question...

which means that the proposed-answer by "spaceepic"
will be auto-accepted, in a few days.
0
 
LVL 2

Expert Comment

by:kmrussell
ID: 1818891
Your probably right, serperfi has not made one comment yet
0

Featured Post

[Webinar] Learn How Hackers Steal Your Credentials

Do You Know How Hackers Steal Your Credentials? Join us and Skyport Systems to learn how hackers steal your credentials and why Active Directory must be secure to stop them. Thursday, July 13, 2017 10:00 A.M. PDT

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Bada platform is becoming more and more famous this days and people talking about same. Some friends included those who have bada OS mobile asked me "what is bada?"and "what its features?". That encouraged me to research and write this article. [st…
In threads here at EE, each comment has a unique Identifier (ID). It is easy to get the full path for an ID via the right-click context menu. However, we often want to post a short link within a thread rather than the full link. This article shows a…
Google currently has a new report that is in beta and coming soon to Webmaster Tool accounts. This Micro Tutorial will highlight new features for Google Webmaster Tools.
This Micro Tutorial will demonstrate how nuggets on the Web are formatted by using Chrome Developer Tools. These tools would not only view the site's CSS but it can also modify it and save the CSS to use on your own site.

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question