Solved

Win98, VMM386.VXD

Posted on 1998-12-27
11
821 Views
Last Modified: 2013-12-28
sometimes when I reboot my system it comes
up with this error message:
unable to load VMM386.VXD
so I have to reboot again, usually it goes
away by itself after rebooting 2 or 3 times.
if you guys know the answer to this problem
beside reinstalling win98 let me know.

thanks
0
Comment
Question by:codex007
11 Comments
 
LVL 2

Expert Comment

by:rlippert
Comment Utility
VMM386.vxd is a special file that is like a kernel for windows that is compiled during installation but something must have happened to screw it up.  So your only real recourse is to reinstall win98 so it will rebuild the vmm386.vxd and hopefully fix your system.  Reinstalling is not such a big deal because you can simply install right over your existing installation and it should only take about 20 minutes or so.
0
 
LVL 4

Expert Comment

by:istal112898
Comment Utility
you do not need to Reinstall WIN98.
go to start,run, then type SFC and extract the files from disk installation,
this files name I would suggest, vmm386.vxd,Vmm32.Vxd.
you might need to do this 1 by one and rebooting each time.
 see if it helps.
0
 
LVL 17

Expert Comment

by:mikecr
Comment Utility
Did you install any software or hardware lately? Was this an upgrade over Windows 95? Do you have a scanner or HP printer installed on your computer? If can answer yes to the first or last question, we need to talk. Reinstalling and extracting from disk is not going to fix your problem if this is so. Let me know.

Mike
0
 
LVL 4

Expert Comment

by:istal112898
Comment Utility
CodeX007 try the suggestions one by one and see if they do not fix it. then explain more.
0
 

Author Comment

by:codex007
Comment Utility
Thanks ISTAL it seems to be fine now.
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 25

Accepted Solution

by:
dew_associates earned 100 total points
Comment Utility
Codex007, Windows 98 does not require vmm386.vxd and don't bother looking for it on the install CD. vmm32.vxd is or should be on your system, but vmm386.vxd should not. It sounds as though you are calling it either in one of your startup files or within the registry, and this is where the correction needs to be made.

First, check you config.sys and autoexec.bat files and make sure it is not being called there. If so, remove it.

Next, click Start, Run and type in SYSEDIT and then click OK. Starting with the first system file, which should be your autoexec.bat and moving through protocol.ini, use the search feature and try and find vmm386.vxd. If you find an entry, note where you found it and the add a semi-colon ";" in front of the line, then save the file. Now reboot the system and check it.

If this doesn't bring the file to the surface, reboot the system and as windows begins, touch the F8 key and choose "Step by Step" and the boot process and try and identify where this file is being called.

Let us know after you have moved through this part of the process.

Dennis
0
 
LVL 4

Expert Comment

by:istal112898
Comment Utility
so my solution worked. please reject the answer and let me post my solution. Thanks
Dew_associates you should have read before posting your answer that my suggestion worked.
CODEX007 let me post it as answer. Thanks
0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
Istal, if code007 wishes to award you the points, I have no difficulty in that, but please don't make comments in my regard unless you know what your talking about. My answer was posted at 10:36AM PST. The E&E server posted the answer at 11:27AM PST. As for your suggestion, your suggestion as it pertains to fixing vmm386.vxd is nonsense, as Windows 98 neither uses, builds or rebuilds this file. This file is a MSDOS file and "is not" used by Windows 98 in any manner. What worked was the reloading of windows 98 to correct a previous "bad" update. A similar memory manager, vmm32.vxd, us used by Windows 98. Lastly, vmm386.vxd is a virtual device driver and is not even remotely close to a kernel environment.
Dennis
0
 
LVL 4

Expert Comment

by:istal112898
Comment Utility
I suggested him to restore the file just so he got convinced that it did not exist.Also, told him to restore VMM32.VXD. which was my suggestion.Yours Answer is not talking about restoring.
Ok, I understand that you said that time it got posted was delayed by the server from E-E when you post an answer it gets the time that it was posted at the moment. There is no mistake on that. A comment can reappear if you use the RELOAD from the NETSCAPE. and It will put comments posted as if they were delayed. and repeat them.
Sorry But I do not agree in the Time of the SERVER when it got posted. 50 minutes is not what it takes.
and YEs I know what I am talking about. :).

Codex007, please if my solution worked,let me post it as an answer so when somebody else look for it see that they needed restore the file that I referred. This question will go to the PAQ.  Thanks.

0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
Istal: I have no intention of arguing with you, but I might suggest that you study Windows 98 a little more before telling the world you know what your talking about. Your comment that Codex007 try and "restore the file just so he got convinced that it did not exist" is ridiculous! You can purchase the Windows 98 add-on to the MCSE program for about $70.00 US! Study it and then tell us what you know!
0
 
LVL 4

Expert Comment

by:istal112898
Comment Utility
I still stand in my comment. and my suggestion of restoring VMM32.VXD speak by itself.


0

Featured Post

How does your email signature look on mobiles?

Do your employees use mobile devices to reply to emails? With mobile becoming increasingly important to the business world, it is in your best interest to make sure that your email signature looks great across all types of devices.

Join & Write a Comment

The use of stolen credentials is a hot commodity this year allowing threat actors to move laterally within the network in order to avoid breach detection.
Our Group Policy work started with Small Business Server in 2000. Microsoft gave us an excellent OU and GPO model in subsequent SBS editions that utilized WMI filters, OU linking, and VBS scripts. These are some of experiences plus our spending a lo…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now