[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 187
  • Last Modified:

Fail to use Network Monitor.

I always got failure while using Network Monitor V4.00.351. The error message is "The MAC driver does not support promiscious mode.". Please advise why?

Hardware: IBM Thinkpad model 380XD
          PCMCIA TokenRing NIC with the newest NIC driver  downloaded from IBM
Software: Win98/WinNT4.0+SP4 and "Microsoft Network Monitor Agent" installed in advance
          TCP/IP & NetBEUI enabled
Ways have tried:
          Enable/Disable the "Allow Full Duplex" of NIC  setting but helpless
0
zhangqj
Asked:
zhangqj
1 Solution
 
zhangqjAuthor Commented:
Edited text of question
0
 
aioudineCommented:
You can't use NM with regular NIC driver,
becose regular drivers is able to capture only
packets send directly to this mashine + broadcasts

You must find and use special kind of driver,
which able to work in promiscious mode
(in this mode driver able to capture all packets,
even they send to another mashine)

Unfortunately, not all NIC have promiscous mode driver ;-(

So, to bve in short: find promiscous mode driver,
or replace NIC to one which have required driver
0
 
zhangqjAuthor Commented:
I don't think aioudine's response has answered my question, the problem is still there. Anyway, Thanks!
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
heathprovostCommented:
I am afraid that zhangqi is absolutely right.  Almost ALL readily available drivers for Win95/NT are NOT capable of promiscous mode operation.  Most of the time an application that does packet sniffing and such comes with a driver/drivers for certain brands of NICs and that is just how it is.  I personally have seen promiscous mode drivers for some 3com/Intel NICs but only for ethernet and they dont work with Network monitor, They are hardcoded to work with a program called NetManage with does some of the same stuff.  Hope this helps
0
 
bbaoIT ConsultantCommented:
I think you maybe have checked M$KB Q135288,

Network Monitor Msg: Driver Does Not Support Promiscuous Mode
http://support.microsoft.com/support/kb/articles/q135/2/88.asp

which mentioned a similar symptom with NetFlex-2 network card. In fact, the problem is relative with packet collision detection, not full duplex mode. So, make sure your TokenRing card has properly configured for collision detection.

Moreover, the following KB Q140712 is also useful for your case, although it is for Madge's:

How to Enable Promiscuous Mode for Madge Token Ring Adapter:
http://support.microsoft.com/support/kb/articles/q140/7/12.asp
0
 
zhangqjAuthor Commented:
Thanks bbao!
I can now use NM in WinNT4.0 but its Filter should be set as point to point, if I set any to any, the problem is the same.
One more, NM cann't be used in Win98 yet, I know this beyond current discussion area, I actually have post the question in Win98 discussion area.
Thanks to all kind friends!
0
 
bbaoIT ConsultantCommented:
You are welcome Chinese friend!
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

Tackle projects and never again get stuck behind a technical roadblock.
Join Now