?
Solved

VMM32.VXD MISSING or UNABLE TO LOAD

Posted on 1998-12-29
15
Medium Priority
?
304 Views
Last Modified: 2013-12-29
null
0
Comment
Question by:gastric
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 5
  • 3
  • +2
15 Comments
 
LVL 6

Expert Comment

by:sgenther
ID: 1731061
PSS ID Number: Q167889
Article last modified on 12-15-1997
 
95
 
WINDOWS
 

======================================================================
---------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Windows 95 OEM Service Release version 2.1
---------------------------------------------------------------------
 
SYMPTOMS
========
 
When you set up OEM Service Release version 2.1 (OSR2.1) over OEM Service
Release 2 (OSR2) and restart your computer, you may receive an error
message stating that the Vmm32.vxd file is missing or damaged, or you may
not be able to boot Windows.
 
CAUSE
=====
 
These errors can occur if either of the following conditions exists:
 
 - The Vmm32.vxd file was not rebuilt properly or was damaged, resulting
   in an error message stating that "Vmm32.vxd is missing or corrupt."
 
 - The addition of Universal Serial Bus (USB) support is causing a
   conflict with the system and Windows 95 is unable to boot normally.
 
RESOLUTION
==========
 
To resolve this issue, use the appropriate method:
 
Vmm32.vxd Missing or Damaged
----------------------------
 
If you receive an error message stating that the Vmm32.vxd file is missing
or damaged, the rebuilding of the Vmm32.vxd file was unsuccessful,
preventing Windows from booting properly and processing the RunOnce
section of the registry.
 
You must uninstall OSR2.1 using the OSR2.1 real-mode uninstall tool
(Rem.pss) on the installation disk. To use the uninstall tool, follow
these steps:
 
1. Restart your computer.
 
2. Press the F8 key when you see the "Starting Windows 95" message, and
   then choose Safe Mode Command Prompt Only from the Startup menu.
 
3. Copy the Rem.pss file to the root folder of the boot drive as
   Remusb.bat (do not copy it to Rem.bat; "Rem" is a reserved command
   and it will not function).
 
4. Type "remusb" (without quotation marks) to restore the original files
   that were renamed with an .o20 extension.
 
5. To complete the uninstall process, restart your computer and use the
   Add/Remove Programs tool in Control Panel to remove the program
   "WDM/USB Supplement."
 
   NOTE: This program may not be listed in the Add/Remove Programs tool.
   If it is not listed, skip this step.
 
6. Delete the Remusb.bat file from the root folder of the boot drive.
 
NOTE: The Rem.pss file has only been tested when the first reboot does not
succeed. Failure to boot at any other time may not be resolved by the
Rem.pss file process.
 
Windows 95 Cannot Boot Because of a Conflict
--------------------------------------------
 
If Windows 95 cannot boot because of a conflict, use the following steps:
 
1. Restart your computer.
 
2. Press the F8 key when you see the "Starting Windows 95" message, and
   then choose Safe Mode from the Startup menu.
 
3. Rename the Detroit.bat file to Autoexec.bat. The Detroit.bat file is
   your original Autoexec.bat file that was renamed by OSR2.1 Setup.
 
4. Troubleshoot using standard Safe-mode troubleshooting.
 
For information about how to troubleshoot Windows using Safe mode, see the
following article in the Microsoft Knowledge Base:
 
   ARTICLE-ID: Q156126
   TITLE     : Troubleshooting Windows 95 Using Safe Mode
 
Additional query words: 95
======================================================================
Keywords          : osr2 win95 kbsetup
Version           : 95
Platform          : WINDOWS
=============================================================================
Copyright Microsoft Corporation 1997.


0
 
LVL 4

Expert Comment

by:istal112898
ID: 1731062
I am going to watch for the moment. :)
0
 

Author Comment

by:gastric
ID: 1731063
While the first reply was interesting, it did not solve my problem. The USB on the motherboard is recognized, and I did install the USB Support Kit, although it was made specifically for Win95c, not Win95b. The other files that are mentioned are not present on my PC, so that does not appear to pertain to me. A dreaded Win98 upgrade appears the most likely path at this point. I have a backup of the hard drive, so if anyone wants to propose something radical, I'm game for trying it.
0
Optimum High-Definition Video Viewing and Control

The ATEN VM0404HA 4x4 4K HDMI Matrix Switch supports 4K resolutions of UHD (3840 x 2160) and DCI (4096 x 2160) with refresh rates of 30 Hz (4:4:4) and 60 Hz (4:2:0). It is ideal for applications where the routing of 4K digital signals is required.

 
LVL 4

Expert Comment

by:istal112898
ID: 1731064
If you have the WINDOWS 95 files copy to the hardrive, reboot, then choose safe mode,
make sure you have WINZIP 7 before from WWW.WINZIP.COM. then, Go to Explorer and go to the WIN95 folder and open up the cabs files, the one you are looking for is called VMM32.VXD. I am not using WIN95 so I cant tell you exactly where it is. I believe it is in a file called PrecopyX.cab (x stand for 1 and 2). then, copy it to the root of C:, then. reboot the system. then Press F8, choose DOS PROMPT ONLY. now that we are in C:
do this at the prompt knowing the VMM32.VXD is on the root.
C:\COPY VMM32.VXD C:\WINDOWS\SYSTEM.  after copying there. Reboot the system
and know your problem should be solved
 IF you want I can email it to you. It would be WIN98 VMM32.VXD , which would work well since it is an update. let me know.
0
 
LVL 6

Expert Comment

by:reiters
ID: 1731065
I think all *.vxd files are dynamically created and you won't find them onthe CD.  also, you can't use someone elses cause the file is made at install time for you specific hardware.  I may be wrong, but be carefull.  If you have a scanner on your machine, then reject the answer and let me help you with some other things.  I had the exact same problem and it was my scanner driver.  If i am wrong, then i am sorry, but I think you should try it.
0
 
LVL 4

Expert Comment

by:istal112898
ID: 1731066
Reiters, you are wrong in that VXD are created Dinamically if you go to the CD you will find it. look for it. If I have I will find My cd and tell you exactly where it is Gastric.
0
 

Author Comment

by:gastric
ID: 1731067
You are both correct. The file is present on my Win95b CD packed in CAB4. However, the file properties are 411k 08/96 vs 696k 07/98. The file is recreated when installing various drivers and hardware, I saw it get recompiled when I installed the USB Support Kit earlier. I did extract it from the CD, backed up my existing VMM32, and copied the CD version to the system. When rebooting my PC caught fire, quickly spreading to my clothing, and now write this from my laptop in the hospital. Joking, actually it gave a TON of errors that VMM32 was calling various VXDs that should have been in the \WINDOWS\SYSTEM\VMM32 directory, but weren't. This is the difference between the original and the recently compiled one. Strike Two! Additionally, the damn Win98 upgrade crashes or locks, likely due to this VMM32 deal. Whoa is me!
0
 
LVL 6

Expert Comment

by:reiters
ID: 1731068
you did save a copy of the 696K one right?

do you have a scanner?
0
 

Author Comment

by:gastric
ID: 1731069
Saved a copy of the existing VMM32. The PC has had a scanner installed for the past 4 months. The only hardware difference is the CPU, RAM, Motherboard, and Video card. I will try the UMAX fix from their website just to test it out.
0
 
LVL 6

Expert Comment

by:reiters
ID: 1731070
the problem is the scanner driver doesn't like USB driver.  Your old motherboard either didn't have USB or you didn't have the drivers loaded.  If you go to: http://web.dreamsoft.com/jjcesari/vmm32vxd/home.htm, you will find what you need.

If you have the dtc318X scsi card then the fix WILL work.  I have done the fix on 6 computers.

all you have to do is load the drivers from DTC website (http://www.domexusa.com/service_/driver__/dtc3181x.exe)and put a ";" in the [386] section of WIN.INI in front of umax driver.
0
 
LVL 6

Expert Comment

by:reiters
ID: 1731071
i forgot...you have to reload the scanner driver and use the manual setup option and tell it you have a adaptec scsi card.

and the card won't be labeled dtc 3181 but the chip on it will

0
 
LVL 6

Expert Comment

by:reiters
ID: 1731072
it is getting late an i am making too many mistakes.  The file to edit is system.ini not win.ini and it should be the very last thing you do cause it will rewrite it when you reinstall the driver.

One more note, another nice thing about the new driver is that the scsi card becomes a device that is recognized by windows and you can start chaining things off of it like a scsi zip drive.  I have done it and it will work.
0
 

Author Comment

by:gastric
ID: 1731073
You are probably right on the money. When first searching the Web for VMM32 probs, I came across a fix on the UMAX site, and although the system has a UMAX 1220S installed in, it was attached at the time, so I disregarded it for some reason. The SCSI card is made my DOMEX but the chip is labeled DTCT-436P. I will try this fix, and will give you bonus points if I have a full functional SCSI card in Windows after all this is done.
0
 

Accepted Solution

by:
vmiav earned 200 total points
ID: 1731074
Do you have USB ports on your new motherboard?

If you do, did you install the USB Suppliment to Windows B?

If you did, try uninstalling the USB Suppliment in safe mode from the add/remove programs in the Control Panel.  Then restart the computer.

0
 

Author Comment

by:gastric
ID: 1731075
OK everyone.  I've tried EVERYTHING I could think of, and everything you have all posted. Nothing really worked, other than I now have USB and a true SCSI card in my device manager. I even tried upgrading Win98 over Win95. It still gave the VMM error now and again, along with blue screens showing VMM offending other apps. I scrapped it, and loaded Win98 from scratch, and no probs. Oh well. I was hoping to not have to reload everything. Thanks everyone!
0

Featured Post

Want to be a Web Developer? Get Certified Today!

Enroll in the Certified Web Development Professional course package to learn HTML, Javascript, and PHP. Build a solid foundation to work toward your dream job!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article helps those who get the 0xc004d307 error when trying to rearm (reset the license) Office 2013 in a Virtual Desktop Infrastructure (VDI) and/or those trying to prep the master image for Microsoft Key Management (KMS) activation. (i.e.- C…
In this modest contribution, I want to share with the IT community (especially system administrators, IT Support Engineers and IT Help Desks) about Windows crashes/hangs and how to deal with these particular problems.
As developers, we are not limited to the functions provided by the VBA language. In addition, we can call the functions that are part of the Windows operating system. These functions are part of the Windows API (Application Programming Interface). U…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

801 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question