Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 733
  • Last Modified:

How do I remove the timeout from a telnet session into my solaris box?

When I telnet into my solaris box, if I just leave the telnet session idle for a while, it will disconnect. How can I remove that timeout? It takes too much time to reconnect, and I have to administer the server all day long. I think it's something on the solaris box, but it might be something else, I don't know.
0
taotree
Asked:
taotree
1 Solution
 
HalldorGCommented:
Depends on your shell, check the manpage for the shell you
are using
0
 
taotreeAuthor Commented:
I just searched through the man page on csh and it doesn't talk anything about timeout. I thought it would be something with either ttymon or login, or getty, or something like that having a timeout, but I can't seem to figure out how to change it.
0
 
ozoCommented:
how do you telnet in?
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
taotreeAuthor Commented:
I am running linux on my workstation and I collocate a Solaris 2.51 box at an ISP accessible over the Internet. I just run:
telnet domain.name
to telnet in to the server. Currently my connection to the Internet is a DSL line--it would time out whether it was via modem dialup to the internet or the DSL line I just got in.
0
 
HalldorGCommented:
csh has parameter called Autologout set it to 0 and it will
not log you out.  The default value is 60 secs
0
 
taotreeAuthor Commented:
Okay... I tried doing:
set Autologout=0
set autologout=0
setenv AUTOLOGOUT 0

It still didn't work. It still timed out. Any other ideas?
0
 
forrestcCommented:
Maybe the best way to approach this is to have you figure out what is getting set.  Type the following commands:

   set
   setenv

Each should (depending on your shell) give you a list of the environment variables which are set.

If you find an appropriate value, you can type:

   unset <value>

or, more specifically:

   unset autologout

If this doesn't work, let us know what shell you are using.   If you're not sure, type the following command:

   egrep '^yourusername:' /etc/passwd

You should get a line like:

forrestc:x:119:40:Forrest W. Christian:/home/forrestc:/bin/tcsh

The /bin/tcsh in this example is my shell.

0
 
taotreeAuthor Commented:
Thank you very much for your help. I already mentioned I think that I was using the tcsh shell on Solaris. We have since, though, moved to Linux and there doesn't seem to be an auto time out now on the shells (bash) so I no longer need to get it figured out.

Thanks anyway!
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now