Solved

Multiple hard drives

Posted on 1998-12-30
19
267 Views
Last Modified: 2010-04-27
I’ve just bought a new Win95 based PC. As well as the hard drive that came with the machine, I have installed another hard drive that I had previously connected to an old 486 running WFW 3.11. This second drive was divided into 4 partitions which were known as D:, E:, F:, and G: on the old machine.

I set the CMOS to auto detect the old drive once I had installed it on the new machine. It did this successfully. When windows came up, it recognised the following drives.
C: - hard drive that came with new machine.
D: - 1st partition of old drive.
E: - CD ROM drive.
F: - 3rd partition of old drive.
G:- 4th partition of old drive.

No sign of the second partition of the old drive.
I used the settings in Control Panel to reassign the drive letter of the CD ROM drive to R: and rebooted the machine.

This time it has come up with drives C:, D:, E:, F:, and R:. This time I have lost the 4th partition of the old drive. I tried playing around with the drive letters in Control Panel but the options are greyed out.

How can I get WIN98 to recognise the four partitions on the old drive?
0
Comment
Question by:the_boomerang
  • 5
  • 5
  • 2
  • +7
19 Comments
 
LVL 10

Expert Comment

by:rbr
Comment Utility
What partitions are displayed when you use fdisk?
0
 
LVL 8

Expert Comment

by:netmage
Comment Utility
Do you have a config.sys and autoexec.bat which has lines relating to your CDRom.

If so, place a REM comment infront of these and see if windows still sees the cdrom.

It sounds like this device driver is reserving the drive letter for a cd file system even though win98 is using its method to find the cd.
0
 
LVL 22

Expert Comment

by:Adam Leinss
Comment Utility
Try putting lastdrive=z into your config.sys


0
 
LVL 12

Expert Comment

by:Otta
Comment Utility
What's the output from:

  FDISK /STATUS > X.X

which is written into the file named 'X.X' ??
0
 
LVL 3

Expert Comment

by:trath
Comment Utility
The problem is that your CDROM is setting on that partitons drive letter. Here are the steps to fix it..

1. Start
2. Settings
3. Control Panel
4. Click the system icon
5. Click the device manager tab
6. Find the icon that says CDROM
7. Expand it then click on the cdrom icon
8. Go to the tab tha says setting and you will see the setting for the CDROM drive letter. change it to H or I then reboot your computer..

It will be fixed then...
0
 
LVL 12

Expert Comment

by:Otta
Comment Utility
>>I used the settings in Control Panel
>>to reassign the drive letter of the CD ROM drive to
>>R: and rebooted the machine.
>>This time it has come up with drives C:, D:, E:, F:, and
>>R:. This time I have lost the 4th partition of the old drive.
> The problem is that your CDROM is setting on that partitons drive letter.

I don't think so -- when the CD-ROM is 'R:',
there should be a 'G:'.
0
 

Author Comment

by:the_boomerang
Comment Utility
I tried this and it didn't work. I now have C:, D:, E:, F:, and H:.

The Fdisk status command shows

                             Fixed Disk Drive Status
  Disk   Drv   Mbytes   Free   Usage
    1           6197            100%
          C:    6197
    2           2014       2    100%
          D:     496

Both config.sys and autoexec.bat are empty.
0
 
LVL 3

Expert Comment

by:cumbo
Comment Utility
Run Fdisk again, choose option 5, select drive 2, then choose option 4 for a clearer view of drive 2's partitions.

Could be that one of the partitions is hidden. Partion Magic will
tell you if a partition is hidden.

Cumbo
0
 
LVL 1

Expert Comment

by:syzygy
Comment Utility
I sthe new HDD master and the Old one Slave on the Primary IDE controller?
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 

Author Comment

by:the_boomerang
Comment Utility
Cumbo,
I did this, the output is
                          Display Partition Information

    Current fixed disk drive: 2

    Partition  Status   Type    Volume Label  Mbytes   System   Usage
     D: 1         A    PRI DOS   DISK2PART01    496   FAT16       25%
        2              EXT DOS                 1516               75%



    Total disk space is  2014 Mbytes (1 Mbyte = 1048576 bytes)

Syzygy,
I'm not sure what you mean by new and old.
The drive that came with the machine is the primary. The pre-partitioned drive that I moved from my old machine is the secondary.

Thanks
J.


0
 
LVL 5

Expert Comment

by:Jason_S
Comment Utility
Fdisk /status will show you logical drives.  Looks like your logical drives are hidden in some way.  You can try the above again, and show Logical drive information and see if that shows you anything.

Boot into Safe mode, go into Device Manager, and remove everything under CDROM. Also remove all device drivers in Config.sys, and Autoexec.bat pertaining to the CD-ROM, and reboot. 95 will find, and install all drivers.
0
 
LVL 1

Expert Comment

by:jepe
Comment Utility
There is one thing that catches my eye.
Looking at the partition information of your second HD is see that your D: partition is marked as the active partition, but I believe your booting from C:. You just pulled over your old HD in your new system and forgot to disable the active partition.
This will not help your problem, but you should fix it.

Have you tried to disconnect your CD-ROM drive and looked what happens than?
0
 
LVL 5

Expert Comment

by:Jason_S
Comment Utility
jepe:  You can have two Active partitions on the system.  (common when moving hard disks around) The system will still boot from the C: partition.  I don't know a way to change this setting besides re-Fdisking the drive anyway.  Do you?

the_boomerang:  I believe your logical drives (2nd, 3rd, 4th partitions on the old drive) are handled by some sort of disk manager utility.  I recomend copying all information off of the second hard drive to the 6Gig, and re-FDISK, and Format the 2Gig drive. (this will erase everything on the 2Gig)  If an option, and you need help with this, let me/us know.
0
 

Author Comment

by:the_boomerang
Comment Utility
Maybe I should have said this before. My CD is a CD-R connected via a SCSI card. I have a scanner connected to the same card.

Anyway, I did what Jason_S said and booted into safe mode (Explorer only showed C and D drives) and removed all references to the CD including the SCSI card and therefore the scanner.

Upon rebooting, windows recognised the SCSI card and attempted to install drivers from it from the WIN98 CD. Tricky as it didn't know the CD existed. I got it to point to the floppy that came with the card so it wasn't an issue.

Despite having done this, device manager kept telling me that there was a problem with the SCSI driver and I should reistall them but it only ever re-installed what was there in the first place so it didn't help. I ended up removing everything in device manager as before, pfysically removing the card from the machine, performing a clean boot, shutting down the machine, re-inserting the card and letting windows detect it that way.

Throughout all this, it never recognised the missing G: drive. This took me about a week so I'm not that keen on trying it again.

--------------------
Displaying partition information in FDISK reveals
                         Display Partition Information

   Current fixed disk drive: 2

   Partition  Status   Type    Volume Label  Mbytes   System   Usage
    D: 1         A    PRI DOS   DISK2PART01    496   FAT16       25%
       2              EXT DOS                 1516               75%



   Total disk space is  2014 Mbytes (1 Mbyte = 1048576 bytes)

----------------

I had thought of copying everything to C: and reformatting but that's letting the computer win and forcing us to do things its way :-).

This has gone on for too long now and I will probably admit defeat.

If somebody can talk me through it with FDISK, I will give them the points.

Thank-you all.
J.
0
 
LVL 5

Expert Comment

by:Jason_S
Comment Utility
Do you have all of the other data on the other three partitions backed up somewhere?  If not, lets keep digging.

Do you get the following when in Fdisk option 4?

    The Extended DOS Partition contains Logical DOS Drives.
    Do you want to display the logical drive information (Y/N)......?[Y]

If not, then the drive is NOT partitioned with a standard partitioning utility.

Try connecting the 2Gig drive as master, and the 6Gig as slave.  Then boot to the 2Gig in "Safe mode command prompt only".  Can you see the other partitions?  If so, copy all data off to either C: (at this point), or what would be D: (6Gig drive).
Then we will talk about Fdisk.
0
 

Author Comment

by:the_boomerang
Comment Utility
I have all of the important data backed up. All I had on the missing partition was Windows 3.1, MS Office and some printer and CD utilities. Nothing that I need for my new machine. I just want the space.

I don't get any of the above in Fdisk option 4. The drive was partitioned under Windows 3.1. I can't remember what I used.

I don't really want to muck about setting jumpers on my drive so that one is the master and the other the slave.

J.
0
 
LVL 5

Expert Comment

by:Jason_S
Comment Utility
By the looks of it, the logical drives may be handled by a disk utility, or compression utility.  If this is the case, the drive can be erased, and started clean again.

Using FDISK, choose option 5, then the second hard disk (2Gig) drive.  Then option 3, then 3 again.  Delete the drives as shown until gone.  Escape out to the main screen again, and choose option 3, then 2.  Then answer Yes to delete Extended partition.  Then escape to main menu again, and choose option 3, then 1.  Then remove what would be the D: drive.  Then escape out to the main menu, and create the partitions as you like.  When done, escape out to the prompt, and reboot.  Then format the new partition(s).

I feel this will work for you.  If not, let me know which step is giving you a problem, and I will help further.  We may need to use a disk utility to wipe the drive clean if this fails.

BTW:  It sounds like your jumpers on the drive are configured correctly.
0
 

Author Comment

by:the_boomerang
Comment Utility
The first step didn't work - there was nothing to delete. But I carried on with all the others and it worked perfectly after that.

You're a wonder Jasn_s, how do I give you the points?
0
 
LVL 5

Accepted Solution

by:
Jason_S earned 100 total points
Comment Utility
Glad to hear its working now.  : )

Simply accept this answer, and were all done.
0

Featured Post

Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

Join & Write a Comment

This paper addresses the security of Sennheiser DECT Contact Center and Office (CC&O) headsets. It describes the DECT security chain comprised of “Pairing”, “Per Call Authentication” and “Encryption”, which are all part of the standard DECT protocol.
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now