Solved

about x-windows in RH5.1

Posted on 1999-01-04
3
343 Views
Last Modified: 2013-12-15
I setup a x_windows in Redhat 5.1 on my HP Vectra VE,and the  video is matrox MGA-100 AGP,but my x_windows only work in low mode,this is my  startx out ,why?



XFree86 Version 3.3.2 / X Window System
(protocol Version 11, revision 0, vendor release 6300)
Release Date: March 2 1998
      If the server is older than 6-12 months, or if your card is newer
      than the above date, look for a newer version before reporting
      problems.  (see http://www.XFree86.Org/FAQ)
Operating System: Linux 2.0.32 i586 [ELF]
Configured drivers:
  SVGA: server for SVGA graphics adaptors (Patchlevel 0):
      NV1, STG2000, RIVA128, ET4000, ET4000W32, ET4000W32i,
      ET4000W32i_rev_b, ET4000W32i_rev_c, ET4000W32p, ET4000W32p_rev_a,
      ET4000W32p_rev_b, ET4000W32p_rev_c, ET4000W32p_rev_d, ET6000, ET6100,
      et3000, pvga1, wd90c00, wd90c10, wd90c30, wd90c24, wd90c31, wd90c33,
      gvga, ati, sis86c201, sis86c202, sis86c205, tvga8200lx, tvga8800cs,
      tvga8900b, tvga8900c, tvga8900cl, tvga8900d, tvga9000, tvga9000i,
      tvga9100b, tvga9200cxr, tgui9400cxi, tgui9420, tgui9420dgi,
      tgui9430dgi, tgui9440agi, cyber9320, tgui9660, tgui9680, tgui9682,
      tgui9685, cyber9382, cyber9385, cyber9388, cyber9397, cyber9520,
      3dimage975, 3dimage985, clgd5420, clgd5422, clgd5424, clgd5426,
      clgd5428, clgd5429, clgd5430, clgd5434, clgd5436, clgd5446, clgd5480,
      clgd5462, clgd5464, clgd5465, clgd6205, clgd6215, clgd6225, clgd6235,
      clgd7541, clgd7542, clgd7543, clgd7548, clgd7555, ncr77c22, ncr77c22e,
      cpq_avga, mga2064w, mga1064sg, mga2164w, mga2164w AGP, oti067, oti077,
      oti087, oti037c, al2101, ali2228, ali2301, ali2302, ali2308, ali2401,
      cl6410, cl6412, cl6420, cl6440, video7, ark1000vl, ark1000pv,
      ark2000pv, ark2000mt, mx, realtek, AP6422, AT24, AT3D, s3_virge,
      s3_svga, ct65520, ct65525, ct65530, ct65535, ct65540, ct65545,
      ct65546, ct65548, ct65550, ct65554, ct65555, ct68554, ct64200,
      ct64300, generic
(using VT number 7)

XF86Config: /etc/XF86Config
(**) stands for supplied, (--) stands for probed/default values
(**) XKB: keymap: "xfree86(us)" (overrides other XKB settings)
(**) Mouse: type: PS/2, device: /dev/mouse, buttons: 3
(**) SVGA: Graphics device ID: "MATROX"
(**) SVGA: Monitor ID: "HP"
(--) SVGA: Mode "800x600" needs hsync freq of 55.84 kHz. Deleted.
(--) SVGA: Mode "1024x768" needs hsync freq of 56.48 kHz. Deleted.
(--) SVGA: Mode "800x600" needs hsync freq of 64.02 kHz. Deleted.
(--) SVGA: Mode "1024x768" needs hsync freq of 62.50 kHz. Deleted.
(--) SVGA: Mode "1152x864" needs hsync freq of 62.42 kHz. Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 64.25 kHz. Deleted.
(--) SVGA: Mode "1024x768" needs hsync freq of 70.24 kHz. Deleted.
(--) SVGA: Mode "1152x864" needs hsync freq of 70.88 kHz. Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 74.59 kHz. Deleted.
(--) SVGA: Mode "1600x1200" needs hsync freq of 75.00 kHz. Deleted.
(--) SVGA: Mode "1152x864" needs hsync freq of 76.01 kHz. Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 78.86 kHz. Deleted.
(--) SVGA: Mode "1024x768" needs hsync freq of 80.21 kHz. Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 81.13 kHz. Deleted.
(--) SVGA: Mode "1600x1200" needs hsync freq of 87.50 kHz. Deleted.
(--) SVGA: Mode "1152x864" needs hsync freq of 89.62 kHz. Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 91.15 kHz. Deleted.
(--) SVGA: Mode "1600x1200" needs hsync freq of 93.75 kHz. Deleted.
(--) SVGA: Mode "1600x1200" needs hsync freq of 105.77 kHz. Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 107.16 kHz. Deleted.
(--) SVGA: Mode "1800X1440" needs hsync freq of 96.15 kHz. Deleted.
(--) SVGA: Mode "1800X1440" needs hsync freq of 104.52 kHz. Deleted.
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75dpi/:unscaled,/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/75dpi/"
(--) SVGA: PCI: Matrox Unknown chipset (0x1001) rev 2, Memory @ 0xe5000000, 0xef000000, MMIO @ 0xefafc000
(--) SVGA: chipset:  generic
(--) SVGA: videoram: 64k
(**) SVGA: clocks:  25.18
(**) SVGA: Using 8 bpp, Depth 8, Color weight: 666
(--) SVGA: Using builtin driver modes
(--) SVGA: Builtin Mode: 320x200
(--) SVGA: Virtual resolution set to 320x204
(--) SVGA: SpeedUp code selection modified because virtualX != 1024
System: `/usr/X11R6/lib/X11/xkb/xkbcomp -w 1 -R/usr/X11R6/lib/X11/xkb -xkm -m us -em1 "The XKEYBOARD keymap compiler (xkbcomp) reports:" -emp "> " -eml "Errors from xkbcomp are not fatal to the X server" keymap/xfree86 compiled/xfree86.xkm'
Fvwm-95: in function Read: <<ERROR>> file '.fvwm95rc' not found in $HOME or /usr/X11R6/lib/X11/fvwm95
Fvwm-95: in function Read: trying to read system rc file
X connection to :0.0 broken (explicit kill or server shutdown).
X connection to :0.0 broken (explicit kill or server shutdown).
xinit:  connection to X server lost.

waiting for X server to shut down FreeFontPath: FPE "/usr/X11R6/lib/X11/fonts/misc/" refcount is 2, should be 1; fixing.


0
Comment
Question by:redsun
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 51

Expert Comment

by:ahoffmann
ID: 1632073
AFAIK XFree86 3.3.2 did not support Matrox MGA-100.
Check at http://www.xfree.org or at http://www.suse.de for XFree86 3.3.3,
then setup your /etc/XF86Config.
0
 
LVL 7

Expert Comment

by:HalldorG
ID: 1632074
I'm using the Matrox card here with a driver from suze
works fine with 1024x1280 16 bit colordepht
on a HP Kayak.  Using a base of RH 5.1
0
 
LVL 1

Accepted Solution

by:
KURGAN earned 100 total points
ID: 1632075
You must download the latest XFree86 version from www.XFree86.org if you want your card runs. Its a problem of the AGP architecture.

I´ve just installed the Xfree 3.3.2 you must look in www.XFree86.org and they
   have a RELNOTES file with the graphics
    card supported and the files required for its instalation.
   You will have to unload several files:
     preinst.sh
     postinst.sh
     extract
     several X332* files. They will depend of you graphic card.
   I suggest you to read the help files before the instalation. Perhaps you graphic
   card doesnt
    be supported in this release either.

   good look.
0

Featured Post

Learn by Doing. Anytime. Anywhere.

Do you like to learn by doing?
Our labs and exercises give you the chance to do just that: Learn by performing actions on real environments.

Hands-on, scenario-based labs give you experience on real environments provided by us so you don't have to worry about breaking anything.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I am a long time windows user and for me it is normal to have spaces in directory and file names. Changing to Linux I found myself frustrated when I moved my windows data over to my new Linux computer. The problem occurs when at the command line.…
In part one, we reviewed the prerequisites required for installing SQL Server vNext. In this part we will explore how to install Microsoft's SQL Server on Ubuntu 16.04.
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

689 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question