• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 164
  • Last Modified:

Database Form Expert - How to NOT use it

A while back I ran the database form expert.  Ever since then, everytime I start Delphi, the database form expert pops up.  This also happens when I select "New Application".  When I close it, it asks me "Are you sure...", and I confirm, and then the "New Application" process is cancelled.  In order to make a new application, I have to manually add a form, and it gets pretty annoying.  Does anyone know how to stop the DFE from popping up like this?  I am using Delphi 2.
0
scrapdog
Asked:
scrapdog
  • 2
  • 2
1 Solution
 
Ronald BusterOwnerCommented:
Look in the registry under current user\borland\delphi 2.0 one of the entries I guess experts contains a variable that created your problem remove the value and it will work normally again.

regards,

cono
0
 
scrapdogAuthor Commented:
I couldn't find "experts" anywhere...
0
 
gdebiasaCommented:
My guess is that you've accidentally made the Database Expert your "default" form, or told it to be your main form (which is why is appears on start up). Unfortuanly, I don't have a copy of Delphi 2 on my machine to guide you to the exact location for you to fix it.

In Delphi 3, it's in Tools Repository (find the appropriate form, then uncheck Main Form). It might be in a similar location in D2.

Glen
0
 
scrapdogAuthor Commented:
Thanks Glen, that did it.  Please answer to collect your points.
0
 
gdebiasaCommented:
Hey, it's fun to get one right once in a while. :)

Glad I could help.

Glen
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now