Mechcommander crashes

I installed Mechcommander adn got 1.8 patch
when i run it, it crashes and gives me this message



ASSERT (00000000 -  Frame Count wrong)
Address  : 0x00638D42
Location : No .PDB file found
File     : No .PDB file found

Stack
=====
0x0069DA9C Tree::render() +0x4C           H:\honorb\Object\tree.cpp(512)
0x0068F2EC ObjectQueueNode::render() +0xAC H:\honorb\Object\ObjQue.cpp(517)
0x0068EC45 ObjectQueue::render() +0x15    H:\honorb\Object\ObjQue.cpp(158)
0x006AF350 Camera::render() +0x170        H:\honorb\Camera\Camera.cpp(1801)
0x006B1295 CameraList::renderView() +0x55 H:\honorb\Camera\Camlist.cpp(505)
0x0072BDBB Scenario::render() +0x1B       H:\honorb\mission\Scenario.cpp(584)
0x006AD2DB viewWindow::display() +0x5B    H:\honorb\Camera\Camera.cpp(696)
0x00615FBB aHolderObject::display() +0x3B H:\honorb\gui\Asystem.cpp(6553)
0x006AD7D4 aMainWindow::display() +0x34   H:\honorb\Camera\Camera.cpp(865)
0x0061DFD7 UpdateDisplay() +0x177         H:\honorb\gui\updisp.cpp(397)
0x00614134 aSystem::run() +0x104          H:\honorb\gui\Asystem.cpp(5376)
0x00610BB1 RealWinMain() +0x311           H:\honorb\gui\Asystem.cpp(3073)
0x0075C1C4 WinMain() +0x54                H:\honorb\rmain.cpp(45)
0x0076024F WinMainCRTStartup() +0x13F    

Machine Details
===============
Executable name           : C:\PROGRAM FILES\FASAINTERACTIVE\MECHCMDR\MECHCMDR.EXE
Current time, date        : 20:10:16 Wedensday 1/6/1999
Executable time, date     : 17:32:42 Tuesday 6/30/1998
User name                 : Sexy
Machine name              : CTX200
Processor                 : AuthenticAMD Pentium MMX
Operating system          : Windows 95
Version                   : 4.00.1111
Time since booted         : 0h 59m 16s
Physical memory           : 66,613,248 bytes  (63 Meg)
Available physical memory : 0 bytes  (0 Meg)
Swapfile size             : 470,089,728 bytes  (448 Meg)
Swapfile available        : 439,169,024 bytes  (418 Meg)
Virtual memory            : 2,143,289,344 bytes  (2044 Meg)
Available virtual memory  : 2,083,520,512 bytes  (1987 Meg)
Memory load               : 73%

PCI bus
=======
3D Blaster Banshee PCI (Version 003) by Creative Technology, Dated 9- 3-1998

ISA bus
=======
Communications Port (COM2) (Version 1.0.00) by (Standard port types), Dated 8-24-1996
ES1868 Control Interface (Version 1.0.10) by ESS Technology, Inc., Dated 8- 1-1997
ES1868 Plug and Play AudioDrive (Version 1.0.10) by ESS Technology, Inc., Dated 8- 1-1997
Gameport Joystick (Version 1.0.10) by Microsoft, Dated 8-24-1996

DLL Version numbers
===================
amstream.dll  - Version 5.01.60.0408
quartz.dll    - Version 5.01.60.0408
devenum.dll   - Version 5.01.60.0408
dsound.dll    - Version 4.05.00.0165
dinput.dll    - Version 4.05.00.0155
Could not find 'd3dhalf.dll'
d3dim.dll     - Version 4.06.00.0318
ddraw.dll     - Version 4.06.00.0318
dplayx.dll    - Version 4.06.02.0363
dplay.dll     - Version 4.03.00.1096
ntdll.dll     - Version 4.00.950
rpcrt4.dll    - Version 4.71.1718
Ir50_32.dll   - Version R.5.04.15.2.39

Information returned by Game
============================

ScenarioTime: 002.19
ScenarioTurn: 21
MoverUpdateFreq: 000.00
TurretUpdateFreq: 000.00
WorldStateUpdateFreq: 000.00
WeaponFireUpdateFreq: 000.00
MissionAppName : MechCommander Release  Version: 1.0 Build RC2 P18 -- MIS0101


What does this mean? Can I fix it?
Any help would be appreciated.
Green010699Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
kinkajouConnect With a Mentor Commented:
My first intuition from the game dump you posted is that you are running out of memory. You get an ASSERT error and Available physical memory is 0 bytes and the Memory load is 73%. Have you tried freeing up system memory or adding more ram?


0
 
MindbenderCommented:
It says under 'DLL version numbers';
"could not find d3dhalf.dll"
Try reinstalling DX, and I know that Mech Commander isn't a 3D game. And are you running a K6-2? It says "AuthenticAMD Pentium MMX". If you have a K6-2 got to www.amd.com and get the W95 updates IF you have OSR2, OSR2.1 or OSR2.5. But I don't think you do.
Does the patch come with any readme's? Check em.

0
 
Green010699Author Commented:
Patch does not have any read me's on it.
Im running AMD-K (the first one) cant specify any more then that.

Reinstalling DirectX6 didnt help.
Do you think that file d3dhalf has something to do with problem?
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
msunderCommented:
I would look at your video card / DX settings in the game.
There might be some settings you can change.  Like try running it a 640 x 480 res.  If you cant get into the game at all try looking for a setup.exe or something in the mech commander folder.

Just curious what you might see.
0
 
SergCommented:
Here is the intresting part there are no video twitching options of any kind!
The most custamizing it alows you to do is set the brightness level, thats it.
0
 
Green010699Author Commented:
Adjusted points to 225
0
 
istekkieCommented:
Now, I will admit that I am not familiar with this game, so first off a quick check:  Is this running in DOS4GW?  If so, then it sounds like you are running low on memory. If you notice, it says that there is No physical memory available, it is all swapped. Try closing some programs before starting.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.