Solved

Network Login on Win 95

Posted on 1999-01-07
4
211 Views
Last Modified: 2013-12-28
On site, we have about 100 machines, but on a few of them we are having problems getting the network login screen to appear on bootup.

After bootup it goes straight into the desktop and it's not connected to the network. The only way is to go to shutdown and 'close and log on as another user' thingy. I've tried installing IE4 SP1 with the desktop update in hopes it would fix it but it hasn't.

It's a pretty vanilla Win 95 B install with MSOff97Pro, SR1, SR2A.

Any suggestions or registry hacks? I would prefer not to install anything.

Bush
0
Comment
Question by:bushhead
  • 2
4 Comments
 

Accepted Solution

by:
naharri earned 50 total points
ID: 1651151
PSS ID Number: Q141858
Article last modified on 07-06-1998
 
95
 
WINDOWS
 

======================================================================
---------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Windows 95
 - Microsoft Windows 98
---------------------------------------------------------------------
 
IMPORTANT: This article contains information about editing the registry.
Before you edit the registry, you should first make a backup copy of the
registry files (System.dat and User.dat). Both are hidden files in the
Windows folder.
 
SYMPTOMS
========
 
When you start Windows, you may not receive a Windows or a Network
Logon dialog box, or you may receive one of the following error messages:
 
 - No network provider accepted the given network path.
 
 - The operation being requested was not performed because the user has
   not logged on to the network. The specified service does not exist.
 
Or, the Change Passwords tab may be missing from the Passwords Properties
dialog box. Note that this symptom occurs only if the second cause listed
below is in effect.
 
CAUSE
=====
 
This behavior can occur if any of the following conditions are true:
 
 - The Primary Network Logon field is not set correctly.
 
 - The following entry appears in the HKEY_LOCAL_MACHINE\Software\
   Microsoft\Windows\CurrentVersion\Network\Real Mode Net registry
   key
 
      AutoLogon=<x>
 
   where <x> is a number.
 
 - You are logging on to a Novell NetWare network and the server you log
   on to is running multiple frame types.
 
 - You are logging on to a Microsoft or NetWare network and you have
   cached your network password.
 
 - The network adapter is improperly configured.
 
RESOLUTION
==========
 
Use the following troubleshooting steps to resolve the problem. Make sure
to restart Windows after each step.
 
Warnings
--------
 
You can edit the registry using System Policy Editor (Poledit.exe) or
Registry Editor (Regedit.exe). Check with your network administrator
before you make any changes to the registry.
 
For information about how to edit the registry, view the Changing
Keys And Values online Help topic in Registry Editor (Regedit.exe).
Note that you should make a backup copy of the registry files
(System.dat and User.dat) before you edit the registry.
 
Using Registry Editor incorrectly can cause serious problems that may
require you to reinstall Windows. Microsoft cannot guarantee that
problems resulting from the incorrect use of Registry Editor can be
solved. Use Registry Editor at your own risk.
 
System Policy Editor (Poledit.exe) is available in the Admin\Apptools\
Poledit folder on the Windows 95 CD-ROM. Use the Add/Remove Programs tool
in Control Panel to install System Policy Editor.
 
In Windows 98, System Policy Editor is available in the
Tools\Reskit\Netadmin\Poledit folder on the Windows 98 CD-ROM.
 
NOTE: System Policy Editor is not included in the floppy disk version
of Windows 95. You can download Policy.exe, a self-extracting
executable file containing Poledit.exe, from online services. Please
see the following article in the Microsoft Knowledge Base for
information about downloading Policy.exe:
 
   ARTICLE-ID: Q135315
   TITLE     : CD-ROM Extras for Microsoft Windows 95 Upgrade
 
Troubleshooting Steps
---------------------
 
1. In Control Panel, double-click Network. Click the appropriate setting
   in the Primary Network Logon box, and then click OK.
 
2. Delete the following entry in the HKEY_LOCAL_MACHINE\Software\
   Microsoft\Windows\CurrentVersion\Network\Real Mode Net registry key:
 
      AutoLogon=<x>
 
3. In Control Panel, double-click Network. Double-click the IPX/SPX-
   compatible protocol, click the Advanced tab, click Frame Type,
   change the value from Auto to the specific frame type running on the
   server you log in to, click OK, and then click OK again. If you do
   not know which frame type is running on the server you log in to,
   contact your network administrator.
 
4. Repeat step 3 as necessary, trying each frame type, to determine if
   selecting one of the frame types causes a Network Logon dialog box
   to appear at startup.
 
5. Disable the Automatic NetWare Login option with System Policy Editor
   (as described on page 515 of the Microsoft Windows 95 Resource Kit), or
   with Registry Editor by adding the following DWORD value:
 
      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NWNP32\
      NetworkProvider\DisableDefaultPasswords = 1
 
For information about troubleshooting problems related to enabling the
Maximum Sockets or Maximum Connections settings, please see the following
article in the Microsoft Knowledge Base:
 
   ARTICLE-ID: Q142489
   TITLE     : Problems After Modifying Maximum Connections or Sockets
               Value
 
MORE INFORMATION
================
 
If you use the right mouse button to click a NetWare server in Network
Neighborhood and then click Attach As on the menu that appears, you have
the option to save (or cache) your password. If you save the password, it
is stored in your password cache file. If the Primary Network Logon field
is not set to Client For NetWare Networks, you are not prompted to log on
to your preferred server.
 
For additional information, see the following article in the Microsoft
Knowledge Base:
 
   ARTICLE-ID: Q127933
   TITLE     : Err Msg: No Network Provider Accepted the Given Network
               Path

0
 
LVL 1

Expert Comment

by:msunder
ID: 1651152
Right click network neighborhood.
what is you network login selection?
Windows?
Logon to ms network?

That might be the problem area
0
 
LVL 2

Author Comment

by:bushhead
ID: 1651153
Great, FAST work. :)

Bush
0
 

Expert Comment

by:naharri
ID: 1651154
Thanks.  This document fixed a problem for me earlier this week.  I still had the printed copy on my desk.  Just lucky, I guess.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Several part series to implement Internet Explorer 11 Enterprise Mode
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now