Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 350
  • Last Modified:

CDplayer.exe does not work.

My cd-rom seems to not be able to read audio discs and play them in cdplayer.exe but will load programs off of cd's.  I don't know if my cd-rom is the problem or the cdplayer.exe program.  Can someone help?
0
mattalin
Asked:
mattalin
  • 8
  • 6
  • 2
  • +4
1 Solution
 
Bob StoneIT GuruCommented:
Most likely, you're missing the cable from the CDROM drive and the sound card.
0
 
mattalinAuthor Commented:
Sorry, I guess I should told you more information.  The cd-rom used to play cd's without any problems.  It has only been recently that it will not read the audio cd's.  As soon as I load it into the cd-rom drive the light blinks a few times and goes off.  Before, it would spin and cdplayer.exe would automatically open and the cd would begin to play.  Now, basically nothing.  However, when I load programs off of cd's it begins with no problems.
0
 
Bob StoneIT GuruCommented:
Reload cdplayer.exe or load/use the software that came with sound card. You can gat new cdplayer software at Creative Labs site.

The player that came with Win 95 is pretty lame anyhow.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
rmarottaCommented:
stone5150,
Please post suggestions as a comment.
As you should know, the "answer" to this question cannot be determined until we have more information about the problem.

mattalin,
Many things can cause the problem you have.
Here are a few:

Is your mixer volume control absent or muted?
Has the CD-ROM's audio cable become disconnected?
Is there a CD Audio device loaded in Control Panel's Multimedia?
Is auto-insert notification disabled in your CD-ROM settings?

There are other possibilities, and we will find the solution based on your responses.
Please check all the above, and ask for help with anything you are unclear about.

Regards,
Ralph
0
 
mattalinAuthor Commented:
I loaded a shareware program to see if it was cdplayer.exe but it did not work either.  I will try to see if the CD-ROM's audio cable became disconnected.  One thing I noticed when I went into Control Panel...Multimedia Properties...Line input Devices and "Line Input for" There is a message that reads "Status: Driver is enabled but inactive due to unknown problem." However, the Line Input for ENSONIQ SoundscapeVIVO Plug and Play is enabled and active.  Does this have anything to do the problem?  Sorry, I don't know the difference between the two.
0
 
rmarottaCommented:
Go to Control Panel, Multimedia.
     1) Is your soundcard listed in the Preferred Device box?

Click the Advanced tab, and then Media Control Devices.
     2) Is CD Audio Device listed there?

Go to Device Manager and click the "+" next to CDROM.
Highlight your CD-ROM and click Properties, and then Settings tab.
     3) Is Auto insert notification checked?

Ralph
0
 
mikecrCommented:
Have you tried cleaning the CDROM lately? This is a big offender of cd's not working properly.


Mike
0
 
mattalinAuthor Commented:
I have never cleaned my CDROM.  I will try that as well.
0
 
mattalinAuthor Commented:
Ralph-

Yes to questions 1) - 3)

Funny thing happened.  I made sure the cables were connected correctly (they were) and when I rebooted my computer the cdrom worked.  However, when I tried to play an audio cd no sound came out but it read the cd.  If it's not one thing, it's another...
0
 
rmarottaCommented:
mattalin,
If the drive reads data CDs okay, I don't think cleaning is going to fix this problem.

1) Can you try a "walkman"-type headphone in the jack at the front panel of the CDROM drive?

If you get audio there with an audio CD playing, we will know
either the soundcard or it's associated drivers is the problem.
If not, the trouble is in the CDROM.
Double-click the speaker icon, located in the systray, next to the clock at bottom-right of screen.

2) Is the CDROM volume control present?  Mute unchecked?

Let me know what you find.
Ralph

0
 
mattalinAuthor Commented:
Ralph-

I did get sound through my headphones with an audio CD playing.  The mute is unchecked as well but no sound through my main speakers (with headphones unplugged).

Matt
0
 
rmarottaCommented:
Has this drive ever worked playing audio CDs with this soundcard before?

0
 
mattalinAuthor Commented:
Yes, the CDROM used to play audio CDs before.  I bought this computer in Feb. '97 and this past Nov. is when I noticed problems.  I can't recall any specific incident that could have caused this problem either.
0
 
rmarottaCommented:
Are you getting "system sounds" (WAV or MIDI files) playing okay through the speakers?  Test them please.

If so, the problem sure looks like it has to be with the CD audio cable.

Let me know.
Ralph
0
 
LaphroaigCommented:
When you put in an Audio CD, does cdplayer actually show any signs of trying to play. It should appear on the task bar.

If not, then open up a directory (any will do), click view at the top, and then options. Click the file type tab and then highlight AudioCD. Click Edit, highlight 'Play' and then click Edit again. It should say application used "c:\windows\cdplayer.exe /play".
If it doesn't then make it so.
0
 
mattalinAuthor Commented:
Ralph:
I am able to hear WAV and MIDI files.  I changed out the CD audio cable after work tonight but nothing changed.  I can still hear audio if I plug in headphones.

Laphroaig:
I checked the CDAudio options and everything is as it should be.  The CD player is working b/c I can hear it through headphones but nothing else.

Matt

0
 
LaphroaigCommented:
So to summarise:-

*.wav and midi files play through the speakers as normal.

Audio CD's play through the headphone socket as normal.

When you put an Audio CD into the tray and close the tray, then cdplayer goes through the motions of playing the CD but no sound through the speakers is evident.

I can only agree with Ralphs earlier comment that there is a hardware problem in the connection between the CD Reader and the sound card.

Assuming that the CD Audio lead is connected correctly, have you or anyone else changed any jumper settings on the soundcard recently. Also, is the CD Reader IDE ribbon cable connected directly to an IDE controller card or to the motherboard, or is it connected to the soundcard IDE interface.
0
 
mattalinAuthor Commented:
Your summarization is correct.

I nor anyone else (to my knowledge) has ever changed the jumper settings.

The ribbon cable is connected directly to the motherboard.

0
 
rmarottaCommented:
Matt,

You said you changed out the audio cable.
Please be aware that there are many configurations of those cables existing.  An incorrect cable could result in disabling the sound.  I suggest you stay with the original, unless the new one is identical.

The only thing left to suggest before troubleshooting the hardware, is to re-install the Windows soundcard drivers.
Even though the soundcard works, there might be some corruption in the drivers that causes this problem.

Ralph
0
 
sapphire007Commented:
are your speakers on and plugged into the correct socket in the back of your computer?

plug the headset into the place where your speakers are and see if you get sound.

If you don't then your cable from the cd-rom to the sound card is either bad, plugged in backwards (red wire where black should be), or where you connected it into the sound-card is the wrong slot.

some connections for this small cable may have multiple plugs on the sound card.  Try the other plugs if you have multiple plugs.

good luck

sapphire007
0
 
zabmanCommented:
JEEZE there sure are a lot of comments, well, here's your answer!

1) double click on the "My Computer" Icon on your desktop.
2) Click on the "View" menu and click on "Folder Options"
3) Go to the "File Types" tab7) Stick in your favorite CD!

If this does not work, or if you have more questions, e-mail me
4) Find "AudioCD" in the device list
5) select it and press the "edit..." button OR double click on it
6) in the "Actions:" box there should be the word "Play"
   this word should be in BOLD, if not, select it, click on the
   "Set as Default" button.  NOW it should be BOLD.
at: zabman@hotmail.com. Hey, Even if it does, let me know!
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 8
  • 6
  • 2
  • +4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now