Solved

Page Fault Error

Posted on 1999-01-13
25
197 Views
Last Modified: 2010-04-27
I have a Celeron 300A overclocked to 450MHz.  It runs fine until I try to play Half-Life or NFL Football Pro '99.  The games load up fine it's only when I try to play them.  I get an error box that pops up.  When I click on the details button, in says something about a page fault.  Can anybody help me?  Thanks.
0
Comment
Question by:brock125
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 7
  • 3
  • +7
25 Comments
 
LVL 5

Expert Comment

by:Jason_S
ID: 1015062
If you change it back to run at 300, does it work properly?
0
 

Expert Comment

by:rich2323
ID: 1015063
You are getting the "page fault" most likely becuse the processor is getting overheated. Try to change back to 300 configuration. Make sure your fan is running. you may also want to add another fan, to keep the CPU cooled.

0
 

Author Comment

by:brock125
ID: 1015064
Thanks Rich, but I should have given more details in my question.  I have a B-Cool triple fan on it.  The tempature is usually between 87F and 89F.  It does work fine when I set it back to 300MHz.  Do you know of any reasons for this or anything I can change to correct this?  Thanks again.
0
PeopleSoft Has Never Been Easier

PeopleSoft Adoption Made Smooth & Simple!

On-The-Job Training Is made Intuitive & Easy With WalkMe's On-Screen Guidance Tool.  Claim Your Free WalkMe Account Now

 
LVL 5

Expert Comment

by:Jason_S
ID: 1015065
Probably just a bug.  Even though heat is not a factor, overclocking a processor can bring out the worst in it.
0
 
LVL 1

Expert Comment

by:eosu
ID: 1015066
What type of memory have you and what speed does it operate at?
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1015067
Just because your processor starts out running at 450 doesn't mean it is going to operate at that speed reliably.
Reduce it's speed incrementally (maybe 400?) until you get reliable results.
You won't notice the difference, except that it'll quit crashing.
Regards,
Ralph
0
 

Expert Comment

by:piercetim
ID: 1015068
I agree with rmarotta.  Back you clock speed down to 400. If you have a jumperless mother board and can control your processor voltage, take it up by .1 or .2 volts at 450.  Be very carefully when stepping up the voltage!!
0
 
LVL 1

Expert Comment

by:jcarlo
ID: 1015069
YOu sure you have PC100 SDRAM?  To run at 450 you need it.  Also, check your AGP slot (if you have a video card there) and be sure it is not being overclocked - your PCI and ISA buses automatically revert to 33 MHz when your bus hits 100.  That may solve your problem.  Dropping bact to 83x4.5 (if your board supports it) may not help either, as the PCI and ISA buses will then be overclocked to 41.5 MHz, putting an extra strain on particularly your hard drive.  You probably would still need PC100 RAM anyway at that speed.

You might as well get PC100 (you can probably sell your original RAM for a good fraction you purchased it at) because you'll need it if you ever upgrade your processor.

Regards,
Jeremy
0
 

Author Comment

by:brock125
ID: 1015070
I have 64MB PC-100 SDRAM(I don't know the brand).  My core voltage is set at 2.20V.  The next step down from 450Mhz is 374MHz(4.5 x 83).  I have an ABIT BH6 motherboard.  I haven't yet tried the 83 FSB yet.  I'll have to try it.  The thing is, it only gives my the error on these two games.  All the other applications I've tried seem to run fine.  Those two games are 3D graphics games.  I have a Diamond Viper V550 16MB AGP card.  I'm hoping it's just a setting in the Soft Menu that I can change.  I read about a setting in Soft Menu that deals with the AGP slot.  I might have to change it and see what happens.
0
 
LVL 1

Expert Comment

by:jcarlo
ID: 1015071
try disabling the L2 cache, it may make your system more stable (although the system is probably almost as damn fast with the cache enabled at 300 MHz!)

-JPC
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1015072
It'll probably sit there all day long displaying the desktop without failing.......  Intense graphics (high CPU load) is what is causing your problem.
Slow it down.
I'd rather have a system that runs my software than one that needs constant re-booting.
As I said, you won't otherwise notice any difference!

Ralph
0
 

Expert Comment

by:dambruso
ID: 1015073
get a faster processor
0
 
LVL 13

Expert Comment

by:Epsylon
ID: 1015074
Where is your CPU made? I heard something about Celeron 300A's from Maleysia are less stable at 450 Mhz...
I forgot where mine was made but it works fine at 450 Mhz.
0
 
LVL 3

Expert Comment

by:vikiing
ID: 1015075
Sometimes an error appears due to too much speed. Just as an example, Pascal programs which use an old version of Crt Unit have a problem derived from an overflow condition generated during a base-time calculation, where a tick count goes over maximum allowed value, precisely when processor runs too fast. Just at program start, it simply dies.

It sounds as if this problem would have to see with this matter of speed.
0
 

Author Comment

by:brock125
ID: 1015076
I got the problem solved.  I changed the SDRAM CAS Latency Time from 3 to 2.  I changed the Video BIOS Cacheable from disabled to enabled.  I changed the CPU L2 Cache ECC Checking from enabled to disabled.  That seemed to do the job.  I have had no problems since.  Thanks for all the ideas everyone.
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1015077
Now, you are "handcuffing" your CPU.........
0
 

Author Comment

by:brock125
ID: 1015078
rmarotta, what exactly do you mean by "handcuffing" my CPU?
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1015079
Would you take a car with a 300hp engine in it and only feed enough fuel to it to produce 100hp?
How fast would it run?
Enhanced performance is the reason for having L2 cache in the first place!
Ralph
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1015080
To carry the analogy a little further:

The car with reduced fuel can run 100 mph.
By applying adequate fuel, the car runs at 200 mph, but it miss-fires occasionaly, stopping the engine.
Reducing the engine timing a little permits the car to run perfectly at 190mph, all day long.
Can you look out the window and tell how fast you're going?
Ralph

0
 

Author Comment

by:brock125
ID: 1015081
Um.....ok.
0
 

Author Comment

by:brock125
ID: 1015082
Ralph,

I didn't disable the L2 cache.  I disabled the L2 cache ECC checking.  When I run benchmarks on my computer I get the same results as I did before I changed the BIOS settings.  I like all the advice that everyone is giving but as far as your analogy goes with the car engine, if you had a 300hp engine, you have a 300hp engine.  It doesn't matter if you only give it a quarter of a tank of fuel.  It still will be 300hp and always be a 300hp engine.
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1015083
I guess there's always a problem of mis-understanding when using analogy.
What I meant was to reduce the amount of fuel delivered to the engine by restricting fuel flowing to it.  (Not the fuel tank's capacity)

Anyway, if that fixed the problem, I'm happy for you!
But......
You're running in "uncharted territory" here, so don't be too surprised if unexpected things happen.

Have fun with it!
Ralph
0
 

Author Comment

by:brock125
ID: 1015084
Ralph,

I get the point now.  If you want to respond to this with an answer, I don't care what it is, you can have the points.  Thanks again everyone.
0
 
LVL 9

Accepted Solution

by:
rmarotta earned 200 total points
ID: 1015085
The CPU really "doesn't care" how fast it is run.    ......up to the point at which it will fail to perform without errors.
These limits, (which may be different for each CPU) cannot be exceeded for reliable operation.
I hope this helps.

Regards,
Ralph
0
 
LVL 1

Expert Comment

by:jcarlo
ID: 1015086
Is your processor multiplier locked (I think it is, as all new cpu's are and the 300A is a new cpu)?  If so, your only recourse may be to try 83*4.5, and if that doesn't work, then 75*4.5 (note that at those two speeds your PCI bus will be overclocked and you may experience other types of instabilities due to your drives and expansion cards).  This isn't good, as I just purchased a 300A and was looking forward to overclocking to 450.  But I do have an Abit BX6 board, which allows me to up the processor core voltage, so that might do it.  But as Ralph said, all processors have an inherent limit as to how fast they can go, and I'm crossing my fingers :)

Regards,
jeremy
0

Featured Post

[Webinar] Learn How Hackers Steal Your Credentials

Do You Know How Hackers Steal Your Credentials? Join us and Skyport Systems to learn how hackers steal your credentials and why Active Directory must be secure to stop them. Thursday, July 13, 2017 10:00 A.M. PDT

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Rasberry PI is a low cost piece of hardware that you can have a lot of fun with through experimenting and building/working on projects like media players, running a low cost computer, build data loggers etc. - see: https://www.raspberrypi.org
This is about my first experience with programming Arduino.
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question