Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 130
  • Last Modified:

Changing file download option in IE 4.0 (200pts)

I wanted to download a .zip file.   An IE4 dialog box came up with the options "Run this program from current location" and "Save this program to disk".  I accidentally chose the "Run this.." and to top it off I also unchecked the "Always ask before opening this type of file" box.  Now whenever I want to download a zip file,  it automatically tries to run it.   How do I (1) get the dialog box back so that I can choose what I want to do or (2) tell IE4 that I want to automatically save zip files?
0
moorer
Asked:
moorer
  • 2
  • 2
1 Solution
 
Jason EvansSenior Software DeveloperCommented:
I do not have a complete answer to this, only a couple of suggestions.

If you right mouse click on the hyperlink to the file, you will see a popup-menu. Select the 'Save Target As..' option, this will allow you to select where you want to save the file and should not allow IE4 the chance to try and run the file.

Secondly you could try going to the 'View' menu of IE4 and choose 'Interent Options' from the bottom. Click the 'Security' tab. You'll see a button with 'Reset' on it, next to the zone selection box. Try clicking on this and then clicking on 'OK'. See if when you next download a zip file that it comes up with the dialog box you mentioned. As the option 'Always ask before opening this type of file' is part of the security setup for IE4, this might reset this box to include a checkmark in it.

Hope this helps.
0
 
Jason EvansSenior Software DeveloperCommented:
(Sorry about the re-posting of this message. I selected the 'Comment' option when I posted it the first time, not the 'Answer' option. Oops!)

I do not have a complete answer to this, only a couple of suggestions.

If you right mouse click on the hyperlink to the file, you will see a popup-menu. Select the 'Save Target As..' option, this will allow you to select where you want to save the file and should not allow IE4 the chance to try and run the file.

Secondly you could try going to the 'View' menu of IE4 and choose 'Interent Options' from the bottom. Click the 'Security' tab. You'll see a button with 'Reset' on it, next to the zone selection box. Try clicking on this and then clicking on 'OK'. See if when you next download a zip file that it comes up with the dialog box you mentioned. As the option 'Always ask before opening this type of file' is part of the security setup for IE4, this might reset this box to include a checkmark in it.

Hope this helps.
0
 
rlippertCommented:
I don't know if that method will work but here is a pretty simple method to fix it:
Load up regedit.exe and open up the "HKEY_CLASSES_ROOT" key and scroll down until you see the entry for ".zip" and click on it (not on the plus sign)
Look at what is says under the value of (Default) (should be Winzip assuming you have that installed) and then scroll down farther till you see the key (folder icon thingy) with that name and click on it and find the value "EditFlags" and just delete it.
Problem Solved and you don't have to erase all of your other preferences too.
0
 
moorerAuthor Commented:
MRclyfar:

Unfortunately, neither of the options that you proposed worked.

rlippert:

Your answer did work,  but I for some reason I can't assign points to you.  I am re-opening the question.  Answer it again and I will give you the points.
0
 
rlippertCommented:
Alright, glad I could help.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now