Networking with Win98

null
TomgAsked:
Who is Participating?
 
dew_associatesConnect With a Mentor Commented:
Tomg, let's start with the logon problem.

Unless I'm mistaken, when you start Windows, you do not receive any Windows Logon dialog box, and you **may** even receive one of these error messages:

No network provider accepted the given network path, or The operation being requested was not performed because the user has not logged on to the network. The specified service does not exist. You may even note that the Change Passwords tab may be missing from the Passwords Properties dialog box. Note that this symptom occurs only if the second cause listed below is in effect.
 
Causes for this:
=================
 
This can occur if any of the following conditions are true:

The Primary Network Logon field is not set correctly.

The following entry appears in the HKEY_LOCAL_MACHINE\Software\  Microsoft\Windows\CurrentVersion\Network\Real Mode Net registry key
 
      AutoLogon=<x>

where <x> is a number.

The AutoLogon key must be BINARY and must be set to 0 for AutoLogon to work.

You are logging on to a Microsoft network and you have cached your network password.

The network adapter is improperly configured.
 
Possible Resolution:
===================
 
Use these troubleshooting steps to try and resolve the problem. Make sure to restart Windows after each step.
 
You can edit the registry using System Policy Edito (Poledit.exe) or Registry Editor (Regedit.exe).You should make a backup copy of the registry files (System.dat and User.dat) before you edit the registry.
 
System Policy Editor (Poledit.exe) is available in the Admin\Apptools\Poledit folder on the Windows 95 CD-ROM. Use the Add/Remove Programs tool in Control Panel to install System Policy Editor.
 
In Windows 98, System Policy Editor is available in the
Tools\Reskit\Netadmin\Poledit folder on the Windows 98 CD-ROM.
 
1. In Control Panel, double-click Network. Click the appropriate setting in the Primary Network Logon box, and then click OK.
 
2. Delete the following entry in the KEY_LOCAL_MACHINE\Software\ Microsoft\Windows\CurrentVersion\Network\Real Mode Net registry key:
 
      AutoLogon=<x>
 
 
3. Disable the Automatic NetWare Login option with System Policy Editor, or with Registry Editor by adding the following DWORD value:
      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NWNP32\NetworkProvider\DisableDefaultPasswords = 1
 
Let me know how you make out!
Dennis
0
 
KayserCommented:
Try changing the windows password on system#1 (in Control Panel)
0
 
TomgAuthor Commented:
I deleted the .pwl file c:\windows called pam.pwl (the name of his secretary) so that should have done the same thing. I'll check that the next opportunity I get to visit his office.

0
[Webinar] Improve your customer journey

A positive customer journey is important in attracting and retaining business. To improve this experience, you can use Google Maps APIs to increase checkout conversions, boost user engagement, and optimize order fulfillment. Learn how in this webinar presented by Dito.

 
Patricia Siu-Lai HoCommented:
To Tomg, In yr system-1, Go to the control panal-network icon, click into it and check if you have added the service-new component of "Microsoft family logon". and check if the primary Network logon to be selected "Microsoft family logon". save, exit and reboot. Then the logon popup window will appear.
If worked or not, please advise.    Pslh
0
 
bushheadCommented:
search for autologon in your registry. do this by going start, run and then regedit. after this do a search for the string autologon. delete this string and the next time u boot up your machine it will ask you to logon and i think this will solve your problem.

bush
0
 
bushheadCommented:
i hope that if it is the autologon key that i get the points instead of dew who likes posting answers.. :)

bush

0
 
dew_associatesCommented:
Bushhead, that's what I do, answer questions, and I stick with the problem until it's resolved. The logon entry within the scope of the question is only a small part of the process. If you think you can solve the entire puzzle I'll gladly back off, just say the word and Tomg will reject the proposed answer. However, you will have to solve the **entire** problem!
0
 
TomgAuthor Commented:
I won't be going to his office for a few days, but I'll met you know what happens. Guys, please don't fight over this stuff. I appreciate you wanting to help, but the tone of the messages is not conducive to the topics of discussion.

0
 
bushheadCommented:
age old argument on whether you should comment or answer. as far as i can tell, dew's answer might not be the definitive one. it would probably be better if it was a comment and the question was left open for other expert's to come and take a read, so i'm just looking after the interests of tomg in that area.

i'm also looking out for my own interest because obviously i wouldn't want dew taking my points. i do appreciate that dew's answer is more comprehensive than mine, and may well solve your problem. however if mine hit the mark, i would just like to be recognised for that, simple as that.

bush
0
All Courses

From novice to tech pro — start learning today.