?
Solved

browsing the linux server using win98 and samba

Posted on 1999-01-18
6
Medium Priority
?
278 Views
Last Modified: 2010-03-18
i've downloaded and installed the samba utility on my linux server. i can browse the shares on the win98 machine from the linux machine using the smbclient program.
my problem is to browse the linux machine from my win98 machine. 've tried to map network drives´and stuff but it don't seem to work.
how do i set the name for the linux machine to be used from win98? is it the same as the hostname?

well, here's my smb.conf

[general]
 workgroup = GRAHN
 hosts allow = localhost, 192.168.1.0/255.255.255.0
 security = USER

[test]
 path = /home/anders
 writeable = true
 public = yes
0
Comment
Question by:Grahn
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
6 Comments
 
LVL 2

Accepted Solution

by:
wqclatre earned 80 total points
ID: 1588136
Oh.. that was a small config file.
To name the computer add:
netbios name = Name in the general part.

Is the 192.168.1.0 the ip of the win98 machine?
Add:
remote announce = 192.168.1.0

Do you like to have direct acess to /home/anders (Without any password?

Then try to change to:

security = share


Tell me how you like it to work and I'll post a smb.conf file for you.
Or try this... I don't know how like it to work so it's hard to give you an answer...


[global]
   netbios name = Bill
   workgroup = GRAHN  
   remote announce = 192.168.1.0
   browseable = yes    
   guest account = nobody

   log file = /var/log/samba/log.%m
   max log size = 50
   security = share
   socket options = TCP_NODELAY
   local master = yes
   os level = 33
   domain master = yes
   preferred master = yes
   domain logons = yes
   wins support = yes

[test]
   comment = Hmmmmmm
   path = /home/anders
   public = yes
   writable = yes



0
 
LVL 2

Expert Comment

by:wqclatre
ID: 1588137
I saw that you have [general] in the beginning. I think it shall be [global]
If you like to login with username anders and password anders You have to run
smb smbadduser anders:anders

then change to this in smb.conf:

[global]

   workgroup = GRAHN
   log file = /var/log/log.%m
   max log size = 250
   security = user
  password level = 8
  encrypt passwords = yes
   socket options = TCP_NODELAY
  remote announce = ip_of_win98_machine
   local master = yes
   os level = 33
   domain master = yes
   preferred master = yes
   domain logons = yes
   wins support = yes

[homes]
   comment = Home Directories
   browseable = no
   writable = yes

 [netlogon]
   comment = Network Logon Service
   path = /usr/local/samba/lib/netlogon
   locking = no
   public = no


secur
0
 

Author Comment

by:Grahn
ID: 1588138
hmmm, still not working...but thanks for taking time helping me!
well, here's how i want it to work:

win98 machine:
ip: 192.168.1.13
name: win98
workgroup: grahn

linux machine:
ip 192.168.1.11
name: linux

samba:
-1 one share called "test", which will be password protected/only user "anders" should have access to it

-1 one share called "pub", which all users will have read access to.

-the shares have to be accessed by either browsing the network or mapping a network drive.

-netlogon is not necessary



.and finally a small question: do i have to change my network settings in win98 in any way?
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 2

Expert Comment

by:wqclatre
ID: 1588139
Try this:

[global]
netbios name = linux
   workgroup = grahn
   remote announce = 192.168.1.13
   guest account = nobody
   log file = //var/log/samba/log.%m
   max log size = 50
   security = share
   password level = 8
   encrypt passwords = yes
   socket options = TCP_NODELAY
   local master = yes
   os level = 33
   domain master = yes
   preferred master = yes
   wins support = yes
   dns proxy = no

[homes]
   comment = Home Directories
   browseable = no
   writable = yes

This will get youre linuxmachine to act as a wins server. I might be a good idea to set youre linuxmachine as primary and secondary wins server in Win98.

Hope this works. I don't have any win-machine to try with.

You also have to do a smbadduser anders:anders
to get this to work.

Good luck!
0
 

Author Comment

by:Grahn
ID: 1588140
hey! it works! thanks alot for helping me out!

0
 
LVL 2

Expert Comment

by:wqclatre
ID: 1588141
It seems like I forgott the public part:
[Pub]
   comment = Public
   path = /home/samba
   public = yes
   writable = no

I think you can add writelist=anders if you want the user anders to have write acess..
0

Featured Post

Give Your Engineering Team a Productivity Boost

Learn why container technology is so powerful and how it can provide your team with productivity gains and other benefits.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…

801 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question