Solved

Can't get to Intranet

Posted on 1999-01-20
9
364 Views
Last Modified: 2010-04-25
We have an NT server running IIS4.0.
Whenever the macs type in the URL of an Intranet site, they immediately try and dial up to our external ISP to get to an Internet site rather than look at the NT Server first

All PC's can see the Intranet

URL being entered http://10.0.0.23
Macs Running Mac OS 8.1
Somebody help! Please!
0
Comment
Question by:robinM
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +2
9 Comments
 

Expert Comment

by:jrsjr
ID: 1540875
Sounds like a proxy issue with the browser.  Which browser are you using?  In Netscape, go in to the preferences menu item to advanced and the proxies.  In the DO NOT USE section, make sure you put the above IP address or the domain of the Infranet.
0
 
LVL 30

Expert Comment

by:weed
ID: 1540876
uhhhh....that IP address is a poor choice for an intranet ip. 10.0.X.X is a registered ip address and so does in fact exist on the INTERNET. A better (and standard) ip scheme would be 192.168.x.x which has been specifically set aside for intranets. That may be part of your problem. Secondly it sounds like youve got the wrong router/dns server information set up on the macs. Theyre checking an external dns server for the dns of the local network to which it has to dial to get to.
0
 

Author Comment

by:robinM
ID: 1540877
I tried everything jrsjr suggested but to no avail.

Weed, how do I change the router/dns server information set up on the macs.  If PC's can see the Intranet, I'm pretty sure it's not the fact that we're using invalid Intranet IP Addresses.  
0
Enroll in June's Course of the Month

June’s Course of the Month is now available! Experts Exchange’s Premium Members, Team Accounts, and Qualified Experts have access to a complimentary course each month as part of their membership—an extra way to sharpen your skills and increase training.

 
LVL 10

Expert Comment

by:rbr
ID: 1540878
Use the control panel TCP/IP and change the connection from PPP to ethernet.
0
 
LVL 30

Expert Comment

by:weed
ID: 1540879
You change that information in the TCP/IP controll panel. Now if and when you get the macs to finally see the intranet they will no longer be able to see any 10.0.x.x addresses on the INTERNET because they think those IP addresses exist solely on your intranet (which is what your PC server is telling them). Which is why we use the 192.168.x.x convention for LANs. I would highly suggest switching your network to the conventional addressing scheme as it will likely prevent some ugly "issues" in the future. BTW i just did a name scan on all the IP addresses between 10.0.0.1 and 10.0.0.255 on the internet (just to make sure) and they all come back as valid. This will definitely lead to issues when your computers are looking for 1 IP address that exists both on the internet and the intranet. One of them is going to be ignored and it may be the one you want.
0
 

Expert Comment

by:jrsjr
ID: 1540880
So I take it that the network you are on is on the intranet that you want to access.  Do you access the Internet through a firewall on the intranet or only dial-out through an ISP?
0
 

Author Comment

by:robinM
ID: 1540881
RBR, I worked that bit out late yesterday and I can know get the Macs to see the Intranet.  My problem know is that the mac users need to go and change their TCP/IP settings back to PPP for when they are online/picking up mail.  This clears all the settings used in the TCP/IP ethernet panel.  How do I get both of them running so, it checks the NT server for addresses first and then goes via the dial up PPP connection.
0
 
LVL 10

Accepted Solution

by:
rbr earned 20 total points
ID: 1540882
Store 2 differnt configurations under the TCP/IP settings so the the User are able to change to configuration under the Menu FILE configuration. The MAC isn't able to handle to TCP/IP connection at the same time, sorry.
0
 

Expert Comment

by:cg906903
ID: 1540883
You need
If you connect to the Internet via PPP but to the intranet via the local lan you need two IP addresses. (one for each)
try,
IPNetRouter
needs 7.5.3 or higher
OT 1.1.1
and 68030 or higher
look at
http://www.sustworks.com/products/ipnr/specification.html
Allows intranet and ppp connection together (and more)
Multiple IP addresses should be available in OT 2.0 but don't quote me on this.

John

0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A lot of new and distinct gadgets are making their appearance every other day. The latest gadget that has wooed the attention of all gadget lovers and non gadget lovers alike is the Smartwatch. This tiny gadget is capable of offering live access to …
Article by: Justin
In light of the WannaCry ransomware attack that affected millions of Windows machines, you might wonder if your Mac needs protecting. Yes, it does and here is how to do it.
Users will learn how resize a batch of photos from a single command in Photoshop via Photoshop's Image Processor. Open up an Image you'd like to resize in Adobe Photoshop: Adjust the image size according to your preferences. Image > Adjustments > …
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question