Solved

Adding User

Posted on 1999-01-21
6
206 Views
Last Modified: 2013-12-27
solaris 7 (latest version) after I create my user via editing the passwd file, and then try to run passwd to give the user an encrypted password, it tells me passwd(system): mperez does not exist. Permission denied.  it may also be worth noting I couldn't create my users home directory either.  Does the home directory need to be mounted to create a directory?  because I umounted before and only til then could I create a directory under /home. Please advise.
0
Comment
Question by:teknow
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 

Author Comment

by:teknow
ID: 2009341
when I try to run "mount" on home, it says, " my partition ( and I've tried every one) is already mounted, and home is busy, allowable number of mount points have been exceeded.
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 2009342
editing /etc/passwd is not enough, you need to edit /etc/shadow too, or use a tool (see man usermod, useradd)

Why do you want to mount what is already mounted?
0
 
LVL 5

Expert Comment

by:n0thing
ID: 2009343
You could also use the X interface "admintool" it will ask you for all the necessary information. Just fill in and you will be on. By default ... the home directory on Solaris is /export/home/username

0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 

Accepted Solution

by:
pderrick earned 100 total points
ID: 2009344
There are more things you need to do in order to add a user. I am using an earlier version of Solaris so if this is out of date please accept my apologies. You do not want to mount on /home, this is done by NIS using the auto_home file in /var/yp/src. This is where your passwd file that you were editing should be also. Having added the user in the passwd file, you should edit the auto_home file to say where his home directory actually is (this will be mounted to /home/user).

e.g. if user directory is under, say, /users/rd/username on the server server1 the entry in auto_home would be

username    server1:/users/rd/username

or you could use

username    server1:/users/rd/&

You will need to create the directory /users/rd/username.

Then, in the directory above src (i.e. /var/yp), run "make passwd" and "make auto.home" (note this is now auto.home not auto_home), the file is auto_home, the make command expects auto.home). If you have secondary NIS servers you will also need to either wait until the secondary server updates itself or force an update. Look in the crontab on the secondary server to see how.
0
 
LVL 1

Expert Comment

by:notjames
ID: 2009345
The reason you can't mount or use /home is because of automountd.  If you go to /home and perform an ls -al you'll notice that it looks similar to this:

dr-xr-xr-x  20 root     root         512 Jan  2 14:53 .
drwxr-xr-x  26 root     root        1024 Jan 14 13:51 ..

This is because the automount daemon currently has control over the filesystem.

I sent this to you already but I don't see it here and I am a bit new to this so I thought, to be anal is to be sure....so I'm gonna repost it here.

I would go into /etc/init.d and perform the following:

/autofs stop

I would permanently keep this from starting up by renaming the startup script in /etc/rc3.d/S74autofs to /etc/rc3.d/autofs74s

ie: mv /etc/rc3.d/S74autofs /etc/rc3.d/autofs74s

Then you should be able to add to your home directory.  As for adding your account I would not suggest adding yourself manually.  Instead use admintool (which is the GUI tool.)  Use the useradd command to add yourself via command line.
0
 
LVL 1

Expert Comment

by:notjames
ID: 2009346
erm...by the way...that is supposed to be a (dot slash) "."/autofs stop.  It looks like I just put a /autofs...
It just didn't post correctly.
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Ready to improve network connectivity? Watch this webinar to learn how SD-WANs and a one-click instant connect tool can boost provisions, deployment, and management of your cloud connection.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In tuning file systems on the Solaris Operating System, changing some parameters of a file system usually destroys the data on it. For instance, changing the cache segment block size in the volume of a T3 requires that you delete the existing volu…
Why Shell Scripting? Shell scripting is a powerful method of accessing UNIX systems and it is very flexible. Shell scripts are required when we want to execute a sequence of commands in Unix flavored operating systems. “Shell” is the command line i…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

687 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question