Solved

Error: dstartio: I/O request repeatedly delayed

Posted on 1999-01-21
5
1,118 Views
Last Modified: 2012-08-13
Hi,

    Here's a few errors I got from my Sybase's log.
block number: 30451, vdn: 3
00:00000:00000:1999/01/21 13:09:22.39 kernel  dstartio: I/O request repeatedly delayed;
and it's repeated ... many times. It happend mostly when I do some bcp into my database. Could someone point me into the right direction as what might have cause it and the fixe ?
0
Comment
Question by:n0thing
  • 3
5 Comments
 
LVL 9

Expert Comment

by:david_levine
ID: 1098572
I found the following post on DejaNews. It was posted by someone with your issue and is a response from Sybase to that person.

The dstartio error you're seeing is often caused by unequal rates of asynchronous i/o between the server and the operating system.  This is informational, sometimes indicates some small performance degradation, but unless you're seeing a huge amount of them, it can safely be ignored.  In most cases, changing three configuration parameters clears up the problem,
so I'd like you to try this, please:  set to 500 the following parameters:
disk i/o structures, max async i/os per server, and max async i/os perengine.

For reference, there's an excellent writeup (although rather well-hidden) in the back of the Error Messages manual.  It's titled "Dstart I/O Request Repeatedly Delayed", and does have an index entry for the page number.

0
 
LVL 5

Author Comment

by:n0thing
ID: 1098573
I've reconfigure the server with the sync I/O and other parameters. Seems to be working fine right now. I didn't see your
comment. However it points to the right direction. Would you mind posting an empty answer so I could give you the points ??
Regards,
Minh Lai
0
 
LVL 9

Accepted Solution

by:
david_levine earned 50 total points
ID: 1098574
Glad you seem to be running!
0
 

Expert Comment

by:syeats
ID: 1098575
Hi, just joined this site.
I'm having the same problem with the third dataserver on a Sun box
I've set the 3 parameters you mention to 100, but still get the errors.
The Sybase doco says not to configure maxasync i/os per server higher than 200 for versions of Solaris 2.4 or higher.
Why do you recommend 500?
Regards,
Simon Yeats.
0
 
LVL 9

Expert Comment

by:david_levine
ID: 1098576
Sorry, I don't know what you should do in your case. I found the answer I posted by searching the net. It helped the person whose problem seemed to match the one I found.

David
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Cloud-based technologies and services will continue to grow in popularity in 2017 thanks to the simple, scalable and cost-effective solutions they deliver. Here are three areas where cloud adoption is poised to really take off.
Introduction This article is intended for those who are new to PHP error handling (https://www.experts-exchange.com/articles/11769/And-by-the-way-I-am-New-to-PHP.html).  It addresses one of the most common problems that plague beginning PHP develop…
This Micro Tutorial demonstrates using Microsoft Excel pivot tables, how to reverse engineer competitors' marketing strategies through backlinks.
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now