Solved

PPP failed to connect halfway

Posted on 1999-01-22
9
547 Views
Last Modified: 2008-02-26
Summary: Disconnected halfway when tried to connect to freeserve.co.uk via
Linux
Program: pppd, chat
Kernel: RedHat 5.0, kernel upgraded to 2.0.36
Hardware: Pentium 133 (AST Bravo), 12 MB RAM, Hayes Accure 14.4 modem,
NE2000 ethernet card

Description:
Tried to connect to my ISP (freeserve.co.uk) using Linux, in order to get
advantage of its IP-masq capability. But stumbled on PPP setup.
Whenever trying to dial, always stuck after giving password, Linux tried to
load IPX protocol, then got disconnected. Doing this from Minicom or pppd +
chat gives same result.
ifconfig don't show any ppp device yet when this happened.

Enclosed below is log from /var/log/messages file
--------------------------------------------------
Jan 21 21:21:32 linux pppd[497]: pppd 2.2.0 started by root, uid 0
Jan 21 21:21:33 linux chat[498]: report (CONNECT)
Jan 21 21:21:33 linux chat[498]: timeout set to 3 seconds
Jan 21 21:21:33 linux chat[498]: abort on (NO\sDIALTONE)
Jan 21 21:21:33 linux chat[498]: abort on (BUSY)
Jan 21 21:21:33 linux chat[498]: abort on (NO\sANSWER)
Jan 21 21:21:33 linux chat[498]: send (^MAT^M)
Jan 21 21:21:33 linux chat[498]: expect (OK)
Jan 21 21:21:33 linux chat[498]: ^MAT^M^M
Jan 21 21:21:33 linux chat[498]: OK -- got it
Jan 21 21:21:33 linux chat[498]: send (ATH0^M)
Jan 21 21:21:33 linux chat[498]: timeout set to 90 seconds
Jan 21 21:21:33 linux chat[498]: expect (OK)
Jan 21 21:21:33 linux chat[498]: ^M
Jan 21 21:21:33 linux chat[498]: ATH0^M^M
Jan 21 21:21:33 linux chat[498]: OK -- got it
Jan 21 21:21:33 linux chat[498]: send (AT&F&C1&D2&K3^M)
Jan 21 21:21:33 linux chat[498]: expect (OK)
Jan 21 21:21:33 linux chat[498]: ^M
Jan 21 21:21:33 linux chat[498]: AT&F&C1&D2&K3^M^M
Jan 21 21:21:33 linux chat[498]: OK -- got it
Jan 21 21:21:33 linux chat[498]: send (ATDT08450796699^M)
Jan 21 21:21:34 linux chat[498]: expect (CONNECT)
Jan 21 21:21:34 linux chat[498]: ^M
Jan 21 21:21:51 linux chat[498]: ATDT08450796699^M^M
Jan 21 21:21:51 linux chat[498]: CONNECT -- got it
Jan 21 21:21:51 linux chat[498]: send (^M)
Jan 21 21:21:51 linux chat[498]: expect (ogin:)
Jan 21 21:21:51 linux chat[498]:  19200^M
Jan 21 21:21:52 linux chat[498]: ^M
Jan 21 21:21:52 linux chat[498]: ^M
Jan 21 21:21:52 linux chat[498]: User Access Verification^M
Jan 21 21:21:52 linux chat[498]: ^M
Jan 21 21:21:52 linux chat[498]: login: -- got it
Jan 21 21:21:52 linux chat[498]: send (sufehmi.freeserve.co.uk^M^M)
Jan 21 21:21:52 linux chat[498]: expect (ssword:)
Jan 21 21:21:52 linux chat[498]:  ^M
Jan 21 21:21:52 linux chat[498]: login: sufehmi.freeserve.co.uk^M
Jan 21 21:21:52 linux chat[498]: Password: -- got it
Jan 21 21:21:52 linux chat[498]: send (??????????^M^M)
Jan 21 21:21:52 linux pppd[497]: Serial connection established.
Jan 21 21:21:53 linux pppd[497]: Using interface ppp0
Jan 21 21:21:53 linux pppd[497]: Connect: ppp0 <--> /dev/cua0
Jan 21 21:21:58 linux kernel: Swansea University Computer Society IPX 0.34
for NET3.035
Jan 21 21:21:58 linux kernel: IPX Portions Copyright (c) 1995 Caldera, Inc.
Jan 21 21:21:59 linux modprobe: can't locate module net-pf-5
Jan 21 21:22:02 linux pppd[497]: Hangup (SIGHUP)
Jan 21 21:22:02 linux pppd[497]: Modem hangup
Jan 21 21:22:02 linux pppd[497]: Connection terminated.
Jan 21 21:22:02 linux pppd[497]: Exit.
--------------------------------------------------
0
Comment
Question by:suharma
  • 4
  • 2
  • 2
  • +1
9 Comments
 

Author Comment

by:suharma
ID: 1639236
Any idea how to solve this problem? I have visited every documentation site that I know (FAQs, HOWTO, help site, etc) - but still no avail so far.

Many thanks in advance.
0
 
LVL 3

Expert Comment

by:bluepet
ID: 1639237
http://www.serv.net/~cameron/ezppp/

this site is what you should use.... it's the easiest ppp utility that I have used...
I got it and got connected after 5 minutes... my first time configuring ppp....

use the static binary....  

get the ezppp
decompress it   gzip -cd ezppp.gz.tar | tar xfv -
read the README file and follow the short instruction....

hope that help
bluepet
0
 

Author Comment

by:suharma
ID: 1639238
Thanks for the information bluepet, but I'm sorry I can't use it... this Linux box is monitor-less, so I can access it only via telnet. That means I can't use X-window -> can't use EzPPP

Anyway... thanks again for trying.

Anybody else can help me...?
0
 
LVL 4

Expert Comment

by:mcdonc
ID: 1639239
Well, I think you actually have two problems.  The net-pf-5 thing seems to relate to Appletalk, which is not meaningful for your installation, to get rid of the message see http://x6.dejanews.com/getdoc.xp?AN=429793053&search=thread&threaded=1&CONTEXT=917127647.469041280&HIT_CONTEXT=917127578.470417479&HIT_NUM=4&hitnum=3 and follow the directions there.

Your problem probably won't be solved by following the advice given in the URL I gave as I think the message is an informational one.  To solve your problem, you're gonna have to pay your dues on this one I imagine.

First, is your ISP giving you a static IP address or a dynamic one?

Second, add a line to /etc/ppp/options, "debug", which will cause further messages from pppd to be directed to your messages file.

Retry the stuff and post what you've found.



0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 

Author Comment

by:suharma
ID: 1639240
McDonc.... you're right, referring to the DejaNews posting, I finally eliminate the net-pf-5 thing and the loading of IPX protocol... but unfortunately, that's it.
The modem still hangs up after the "Connect: ppp0 <--> /dev/cua0" line.
The logs also still the same as I enclosed above, except for the net-pf-5 and IPX protocol line.

For your other question, my ISP gives me dynamic IP address, and I have setup my /etc/ppp/option already before to include the "debug" line

While at it I've been continuing to find more information regarding this, but still unsuccessful. Any other ideas?

Thanks
0
 
LVL 4

Expert Comment

by:mcdonc
ID: 1639241
Well.  I had a similar problem.  My solution was to add lines like this to my /etc/ppp/options file:

1.2.3.4:5.6.7.8
ipcp-accept-local
ipcp-accept-remote
ipcp-restart 6

to my /etc/ppp/options, where 1.2.3.4 was my proposed "local" IP address and 5.6.7.8 was the IP address of the terminal server on the remote end.  Put numbers in here that you "normally" get when you connect (maybe you can get them from a Windows machine that works with this ISP currently).  The next two lines (ipcp-accept-*) tell pppd to allow the remote server to "overwrite" these proposed addresses.  The third line (ipcp-restart) increases the timeout for PPP session IPCP negotiations to six seconds (double its default value).

I don't think the "debug" line is having any effect on putting debug messages into your /var/log/messages file.  I don't know why you're not getting any debug messages out of pppd.  You may have to add this option (and possibly the other options I've given you) directly to the line in your scripts which calls pppd.
0
 
LVL 7

Expert Comment

by:HalldorG
ID: 1639242
Does PPP start after you login and send password
as you are not sending any command to start the ppp

And also check that /etc/ppp/secrets file is correct

remoteuser      *      password

That will normally do the trick


You may check out with minicom that there is a ppp chat started
when you log in.


0
 

Author Comment

by:suharma
ID: 1639243
HalldorG & mcdonc, I still can't connect after following your  instructions. But I found my fault, I wrongly set the MTU, it was 576 while it should be 1500.
After I correct that in /etc/ppp/options, now I could connect to my ISP _only_ if I use Minicom to login, and then drop to shell and run pppd.
In other words, I must not execute the chat program from within /etc/ppp/options

I have checked my chatscript, and I can't see anything wrong with that, yet I will always get disconnected if I use it. I enclose it (/etc/ppp/chatscript) and also my /etc/ppp/options below for your information. If you could help me inform what's wrong, I'd be grateful.

Thank you.

---/etc/ppp/chatscript----------------------------
REPORT          CONNECT
TIMEOUT         3
ABORT           NO\sDIALTONE
ABORT           BUSY
ABORT           NO\sANSWER
''              \rAT
'OK-+++\c-OK'   ATH0
TIMEOUT         90
OK              AT&F&C1&D2&K3
OK              ATDT08450796699
CONNECT         ''
ogin:           sufehmi.freeserve.co.uk\r
ssword:         xxxxxx\r

---/etc/ppp/options----------------------------------------
debug
connect "/usr/sbin/chat -v -t 90 -f /etc/ppp/chatscript -r /tmp/log.chat"
/dev/cua0
modem
crtscts
defaultroute
asyncmap 0
mtu 1500
ipcp-accept-remote
ipcp-accept-local
ipcp-restart 6
lcp-max-configure 20
0
 
LVL 7

Accepted Solution

by:
HalldorG earned 100 total points
ID: 1639244
Simplify your chatscript
Have it just

'TIMEOUT 90 "" AT&F&C1&D2&K3 OK ATDT0,8450796699 ogin: sufe ssword: xxxxxxx ""'

I do not belive that \r does matter and the -r /tmp/log.chat
is something that I do not think that matter but you might
add a lock to the option file and even a debug to check
what your are getting.  But the ppp options are correct as
you now get connection using minicom.  So it is the chatscript

I see you are using -v parameter with the chat but that shows you
what happens on the screen I believe.  So when is it that you do
not get the responce you wan't to.  The username that you supply is it the same as you use in minicom.  
Compare the two of those. Do you have to enter any command
after you log in using minicom or does ppp negotiation start
right after that.

I would also skip the -t 90 parameter with chat.

HG


0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

The purpose of this article is to demonstrate how we can upgrade Python from version 2.7.6 to Python 2.7.10 on the Linux Mint operating system. I am using an Oracle Virtual Box where I have installed Linux Mint operating system version 17.2. Once yo…
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
This video will show you how to get GIT to work in Eclipse.   It will walk you through how to install the EGit plugin in eclipse and how to checkout an existing repository.

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now