Solved

pppd can connect only ONCE

Posted on 1999-01-24
5
226 Views
Last Modified: 2010-03-18
I'm running RH 5.2 (kernel 2.0.36) and pppd version 2.3.5-1 (rpm -qf pppd). My problem is this: pppd can connect to my ISP just fine (can send/recieve packets, etc) but, after hanging up, trying to dial again results in chat hanging waiting to send ATZ to the modem (deduced from watching log/messages in debug mode). The modem and serial port seem fine - I can connect to it (using minicom) and AT/OK sequence works as expected. I can also run the chat script manually (chat -f dialing-script </dev/modem >/dev/modem) and it can talk to the modem and dials just fine. This leads me to believe I'm seeing some sort of bug in pppd that causes the io redirrection for chat to get muffed. I've tried manually rmmod ppp & slhc between connections thinking that might reset things but no luck; clearing the condition requires rebooting the kernel. After reboot it connects just fine, again, only once. I've been poking around with search engines but can't find anyone else with this problem...

Sound familar to anyone?

Oh yes, this modem worked flawlessly with ppp version 2.2.0f-5 and windows 98 (shudder) so I don't think the modem is the problem.
0
Comment
Question by:oxymoron
  • 4
5 Comments
 

Author Comment

by:oxymoron
ID: 1588212
Edited text of question
0
 

Author Comment

by:oxymoron
ID: 1588213
Edited text of question
0
 

Author Comment

by:oxymoron
ID: 1588214
Edited text of question
0
 

Author Comment

by:oxymoron
ID: 1588215
Edited text of question
0
 
LVL 7

Accepted Solution

by:
HalldorG earned 200 total points
ID: 1588216
Check where the lock file is, it looks like the chat does not release the lock.

A lock parameter with pppd could also solve something.
I also as always suggest using mgetty for control of the
serial line.
HG
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
This video discusses moving either the default database or any database to a new volume.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now