Solved

pop3 server - HOW?

Posted on 1999-01-26
8
232 Views
Last Modified: 2010-03-18
I'm trying to set up the pop3d(?) daemon so that I can retrieve my email from a remote machine.  Here's my inetd.conf file.  What is missing from here or what other config file do I need to tweak?

Thanks!

# These are standard services.
ftp      stream      tcp      nowait      root      /usr/sbin/tcpd      in.ftpd -l -a
telnet      stream  tcp       nowait  root    /usr/sbin/tcpd      in.telnetd
gopher      stream  tcp       nowait  root    /usr/sbin/tcpd      gn

# Shell, login, exec and talk are BSD protocols.
shell      stream      tcp      nowait      root      /usr/sbin/tcpd      in.rshd
login      stream      tcp      nowait      root      /usr/sbin/tcpd      in.rlogind
#exec      stream      tcp      nowait      root      /usr/sbin/tcpd      in.rexecd
talk      dgram      udp      wait      root      /usr/sbin/tcpd      in.talkd
ntalk      dgram      udp      wait      root      /usr/sbin/tcpd      in.ntalkd
#dtalk      stream      tcp      waut      nobody      /usr/sbin/tcpd      in.dtalkd

# Pop and imap mail services et al
pop-2   stream  tcp     nowait  root    /usr/sbin/tcpd      ipop2d
pop-3   stream  tcp     nowait  root    /usr/sbin/tcpd      ipop3d
0
Comment
Question by:daveko
8 Comments
 
LVL 4

Expert Comment

by:mcdonc
ID: 1588230
1.  What IP address do you type into your POP client for the entry marked "POP server".
2.  What's the IP address of the machine that you yanked that inetd.conf off of?
3.  What error do you receive when you try to get your mail?

0
 
LVL 4

Expert Comment

by:mcdonc
ID: 1588231
1.  What IP address do you type into your POP client for the entry marked "POP server".
2.  What's the IP address of the machine that you yanked that inetd.conf off of?
3.  What error do you receive when you try to get your mail?

0
 
LVL 1

Author Comment

by:daveko
ID: 1588232
That's the error I get.  The ip address that I typed in is the ip address of the machine and it can also be seen in the error msg below:

Your server has unexpectedly terminated the connection. Possible causes for this include server problems, network problems, or a long period of inactivity. Account: '206.63.66.13', Server: '206.63.66.13', Protocol: POP3, Port: 110, Secure(SSL): No, Error Number: 0x800CCC0F
0
 
LVL 4

Expert Comment

by:mcdonc
ID: 1588233
That "account" parameter should be your username, shouldn't it?
0
Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

 
LVL 2

Expert Comment

by:jeffa072897
ID: 1588234
Two things you might want to check -
1) Is pop in your /etc/services file? 109 is pop2 and 110 is pop3 both tcp.
2) Setup a telnet session and watch ps -axf and see if the pop daemon ever starts
    under inetd.
3) You could, as a test, run the pop3 as a regular daemon, not under inetd.
4) Is your mailbox file(commonly in /var/spool/mail) owned by the user trying to read
    the mail?

0
 
LVL 5

Accepted Solution

by:
tfabian earned 100 total points
ID: 1588235
as mentioned previously, you've got to setup the ports for the pop server to respond through..

in /etc/services

add


  pop-2      109/tcp
  pop         110/tcp

your inet.conf looks okay..

also you've got to ensue that the popper software has adequate rights to execute.. check it's permissions..

from your pop client, your machine's IP address/name are all you need, plus a valid user id and password..  your client should connect to your system via ports 109 or 110..  if they're not in /etc/services (on the server) you'll get errors..


 
0
 
LVL 1

Author Comment

by:daveko
ID: 1588236
Argh!  Someone told me to do a kill -1 on the httpd daemon to force a SIGHUP but it wasn't working.  the tcl script in /etc/rc.d/init.d worked perfectly.  All I had to do was restart the inetd services and it worked.  my services and inetd.conf were fine.

thanks!
0
 
LVL 1

Author Comment

by:daveko
ID: 1588237
Argh!  Someone told me to do a kill -1 on the httpd daemon to force a SIGHUP but it wasn't working.  the tcl script in /etc/rc.d/init.d worked perfectly.  All I had to do was restart the inetd services and it worked.  my services and inetd.conf were fine.

thanks!
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
In this video I am going to show you how to back up and restore Office 365 mailboxes using CodeTwo Backup for Office 365. Learn more about the tool used in this video here: http://www.codetwo.com/backup-for-office-365/ (http://www.codetwo.com/ba…

895 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now