VB6 PDW - Setup fails

I created a setup program with the VB6 Package & Deployment Wizard.
When I run it I receive the message :
"Cannot start main setup program! (CreateProcess()returned error code 0x000000C1H)"
after he has finished to copy MSVBVM60.DLL at the beginning of the setup.
LVL 3
greischAsked:
Who is Participating?
 
mackagpConnect With a Mentor Commented:
Wahay :)

0
 
mackagpCommented:
I've experienced this problem, the fail is due to unable to spawn setup1.exe after copying the main files. As yet i've not found a solution, but am working on it. I found that if a machine returned this error it would not run any VB6 setup's. I will update as i find stuff out. (unless somebody finds a solution!)

0
 
mackagpCommented:
This taken from newsgroups.. Not been able to test it yet, cause i don't have access to the relevant PC.. But give it a go.

Have them check in the \WINDOWS Directory of the machine that can't run the
setup.
Make sure they don't have any .CAB files with the same file name as the ones
that come with your program you're distributing. If they find them, delete
them from the WINDOWS directory. If it's an NT machine, that would be the
\WINNT dir.

Also want to them check to be sure the following filesizes. If any are zero
bytes, delete them (note, if NT machine use \WINNT and \WINNT\SYSTEM32

\WINDOWS\SYSTEM\VBSTKIT.DLL
\WINDOWS\SYSTEM\MSVBVM60.DLL
\WINDOWS\ST6UNST.EXE
\WINDOWS\SETUP1.EXE


Then have them run the setup program again.
0
 
greischAuthor Commented:
To mackagp :

I have deleted SETUP1.EXE, my CAB file.
Then the setup has worked.

Thanks.

Submit your answer to get the points !!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.