• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 515
  • Last Modified:

pppd Daemon Died Unexpectedly !!!

Dear Experts,

When I login as a ordinary user and try to initiate a dialup connection using kppp from KDE, I got an error message saying "pppd daemon died unexpectedly" although the modem dials and it connects, the error pops up when is in Login on to network state.

FYI, I have setuid for the following:
- /var/lock
- /usr/sbin/pppd
- /etc/ppp/options
- /usr/sbin/kppp

My PC is running RedHat Ver6.0 with KDE 1.1 and gnome 1.0 installed and an external modem.

thanx in advance for any solutions.

1 Solution
Does the error appears all the time?
Does the error appears all the time?
cklim060797Author Commented:
yes, whenever I login as ordinary user.
Build your data science skills into a career

Are you ready to take your data science career to the next step, or break into data science? With Springboard’s Data Science Career Track, you’ll master data science topics, have personalized career guidance, weekly calls with a data science expert, and a job guarantee.

Open the file /dev/ppp/option and make it empty .

cklim060797Author Commented:
reason being the question is not answer !!
I had some difficulty with the same message.  You havn't
indicated if this message appears when logging on as root.
Are you using a script logon? PAP? CHAP?
edit the proper file in /etc/ppp.
ie. PAP:  "internet.account.userid"  *  "password"
    CHAP: internet.account.userid   *  password
your script should contain those commands set forth by your
ISP.  terminal databits 8 and so forth. ( check with your ISP).  They may also require a file called /etc/ppp/login containing the same information as PAP or CHAP.
/etc/resolve.conf must have your ISP DNS and a domain string.  ie:  domain  gate.net

It might help to try and connect with a program other than kppp to see if the daemon is even working.  Try opening up minicom, typing atdt and your number, and entering your username and password.  Then type Ctrl+Q to exit minicom, and type pppd -d detach /dev/modem &.
Perosnally, I don't really like kppp, and find it easier to use the ppp-on scripts that come with RedHat.
Just a thought. I remember using ezppp a while back and getting the same error message. The problem was down to /usr/sbin/pppd being a symbolic link to /usr/sbin/pppd-2.2. ezppp needed to know the location of the actual file not a symbolic link. It had the option of specifying a different location for the ppp daemon, so I typed that in instead and it worked fine. I think that this error is just a generic error for any unspecified problem with the ppp daemon.
Hope this might be of some help

I set up RH 6.0 on three boxes and this worked every time for me:

As root, using vi, comment out "lock" in /etc/ppp/options.

Then <chown root ${KDEDIR}/bin/kppp> and,
<chmod +s ${KDEDIR}/bin/kppp>.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Train for your Pen Testing Engineer Certification

Enroll today in this bundle of courses to gain experience in the logistics of pen testing, Linux fundamentals, vulnerability assessments, detecting live systems, and more! This series, valued at $3,000, is free for Premium members, Team Accounts, and Qualified Experts.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now