Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

System will not boot after Bios update.

Posted on 1999-06-26
9
Medium Priority
?
374 Views
Last Modified: 2013-12-28
I recently bought an AMD K6-2 450 to replace my 300 on my Biostar M5ALA motherboard.  On the Biostar web site I was informed that I needed to update the Bios to support the 450.  I dl'ed the Bios update and the Award flash program and followed the instructions to the letter.

The system will now not boot to Win98.  It will boot to Dos via a boot floppy but stopped just short of booting to Win98 as I get the following error:  While initializing device CONFIGMG:
Windows protection error. You need to restart your computer.

The system will not boot to safe mode but will boot to the command prompt.

On the Microsoft support site it tells me that this error is caused by Win98 flushing the L2 cash and could be corrected by disabling the L2 cash in the Bios.  Not an acceptable solution.  It also gives another possible fix which is eliminating the AGP video card and using a PCI version.  Again, not an acceptable fix.

The mb maker Biostar has not responded to my emails about this problem nor have they ever reponded to any of my questions.

Since Award is now owned by Phoenix they don't give out any assistance concerning Bios problems.

I tried to reflash the Bios using the saved backup but the flash program doesn't seem to recognize the backup file and again I have nowhere to turn for support.
0
Comment
Question by:jdanddog
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
9 Comments
 

Author Comment

by:jdanddog
ID: 1671489
Edited text of question.
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1671490
JD, unfortunately you're in the middle of two no-no's, one that of changing the processor to a different series, 300MHz and below and 330 and above. The second is the bios change. Sometimes, and I say that with toungue in cheek, you may be able to get around the problem by following a strick set of procedures and do not skip any steps. The why is very simple. Win98 builds several files during the setup, one of which is VMM32. This file interacts with the dynamic portion of the bios. If you make a series change to a processor, VMM32 has no way to repair itself and the only way to fix it is a reload (and that's a maybe). Give the following a try in the order given.
=======================================
The following is predicated upon to factors, (1) the MB is bootable, at least to the floppy; (2) you have the MB manual and at least a basic understanding of the bios settings. With that, try the following:

1. Shut the machine down and then locate the method (and jumpers if necessary) to clear the CMOS on the motherboard.

2. Boot the system into the bios setup. Move through the selections until you find the area to set the bios to it's default settings and choose those. Save the settings and boot to the floppy.

3. Reboot the system again into the Bios setup. Now carefully go through each area of the Bios setup and check all of the settings, such as cpu voltages, plug and play aware OS, Advanced Power Management, and most importantly memory settings and hard drive settings. Use auto for the hard drive as opposed to user settings.

4. Once you made your changes, save them and try to boot to the hard drive and into Windows 98. If you're successful, stop here. If you aren't, go onto the next step.

5. Boot to either your Windows 98 install disk, or to the Windows 98 Startup disk. Make sure you have cd rom drive access. Now reload Win98 over top of the existing Win98 install. This will repair VMM32 unless there is actual file damage. NOTE: You may have to re-add your windows updates, but it's better than losing everything.

If you have any questions, please ask!
Dennis
0
 

Author Comment

by:jdanddog
ID: 1671491
Dennis, thank you for your prompt response.  I've followed your suggestions and the system will not boot to Win98 althought it does get quite a bit further along the boot sequence according to the "bootlog" file.

I ran Win98 setup and got the following msg after scandisk:  Error loading USER.EXE

As I sit here and dispair starts to set in, a few thoughts have crossed my mind.  

Could I purchase a new motherboard from a quality mfg. and go around the problem that way?  The super 7 motherboards are relitively cheap in cost as I've seen them for under $100.  I would gladly pay $100 for a fix verus losing my entire C drive contents.  

Could I install Win98 to my D drive and work around the problem that way?

Now that I'm on that track: Could I take out my old C drive, install a new C drive and install Win98 to that drive and then reinstall the old drive under letter D and copy the files I want to save to the new disk?  I really like this last thought as my old system(the one I'm using to contact you)is in need of a larger second disk and with disk costs being what they are today it would be an easy and do-able today kind of fix.

Is the desperation showing?

:)
 
Thanks again for your help and I look forward to your next response.

Jim Dugan
0
Turn your laptop into a mobile console!

The CV211 Laptop USB Console Adapter provides a direct Laptop-to-Computer connection for fast and easy remote desktop access with no software to install.

 
LVL 25

Expert Comment

by:dew_associates
ID: 1671492
Jim, you could add a new "C" drive, install 98 on it (making your old drive "D") and then copy over data, but there may be a better solution, but I will need to know the type of data you want to save.

As for a new motherboard, what I suggest is that you visit the AMD site and look through their approved MB list and use that as the basis for your choice.

In all honesty, you may also want to consider a 400+ celeron and one of the later PII GX or ZX boards.

Let me know what types of files (be thorough on what you have) and I'll outline how we handle similar situations for our clients.
Dennis
0
 

Author Comment

by:jdanddog
ID: 1671493
Hi Dennis

Well I had to take a break and get away from the problem for a while.  I'm back at it now and here is where I am with it now.

I've been messing with some of the suggestions given by Microsoft and by some others with some knowledge and I've gotten the system to boot up to the following msg:  WINGUARD: Bad "MESSAGES.DRV"

Winguard is a virus program by Dr. Soloman.

The system will now complete the loading of CONFIGMG so I'm making a little headway.
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1671494
Okay, try bypassing the autoexec.bat and config.sys by renaming them config.old and autoexec.old.

Now boot the system and hold the control key down to force Windows into its boot menu. From there, choose step by step and see how the system reacts. Approach this from the standpoint that there may be some file damage, disk damage or maybe even a virus or trojan.

A step by step will at least show you where the problem may lay. Also, you may want to boot into the menu again and invoke the bootlog.txt and then open it in wordpad to see where any failures occur.
0
 

Expert Comment

by:kristofv
ID: 1671495
boot your system with a ISA video card in it, reflash the BIOS with the original BIOS file (that is, if you have saved it before initial flashing)

0
 

Author Comment

by:jdanddog
ID: 1671496
Thanks both kristofv and dew.

I finally figured it out and it not even close to what I would ever have imagined.  I got the hint of what it might be as I would get a "memory error" only when I tried to boot the system to "safe mode".  So what I did is to remove one of the 2 64meg Dimm's I have and sure enough one of them is bad.

So dew if you respond to this I will give you the points.

Thanks

Jim Dugan
0
 
LVL 25

Accepted Solution

by:
dew_associates earned 800 total points
ID: 1671497
Thanks Jim!
0

Featured Post

Supports up to 4K resolution!

The VS192 2-Port 4K DisplayPort Splitter is perfect for anyone who needs to send one source of DisplayPort high definition video to two or four DisplayPort displays. The VS192 can split and also expand DisplayPort audio/video signal on two or four DisplayPort monitors.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Sometimes clients can lose connectivity with the Lotus Notes Domino Server, but there's not always an obvious answer as to why it happens.   Read this article to follow one of the first experiences I had with Lotus Notes on a client's machine, my…
Compliance and data security require steps be taken to prevent unauthorized users from copying data.  Here's one method to prevent data theft via USB drives (and writable optical media).
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question