VB6 - getting Data Environment to work

I can't get the data environment designer to work - at all.  I can't even add the object to my project (I get an unspecified error).  I can, apparently, reference it as a component.  

I previously was able to use it problem free on an older PC (which once had VB5 installed and then VB6).  If I load a project with a Data Environment object in it, and try to double click on the data environment object, it says 'Object Library not registered'.  The help in MSDN on this is:

"In earlier versions, when you started an application that uses Visual Basic for Applications, certain object libraries were loaded. This error has the following cause and solution:

An attempt was made to load a previous version of the Visual Basic for Applications object library (vaxxx.olb) orhost-application object libraries. However, the correct language version of these object libraries could not be found in the systemregistry.
Reregister your application. "

So, I have to re-register my application - what VB6?

Hope you can help

Who is Participating?
BGillhamConnect With a Mentor Commented:
Install Service Pack v3 (SP3) and ADO2.11 and your problem will go away.

It's better you should re-register VB6 after removing it.After loading check whether
references & components are successfully loaded.Also make it sure you are referencing to the appropiate library while developing the application.

tomnichAuthor Commented:
What do you mean by re-register VB6 ? - you mean re-register the file Vaen21.olb (which the MSDN help is refering to)?

I tried, using regsvr32, but an error message said the the olb file was "..not a valid Windows NT image.."
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

First you remove your existing VB version(Uninstall) it.Then try to install it once again.

tomnichAuthor Commented:
I've already done that, and it's no good still.

By the way, a few weeks ago I manually registered an ADO DLL (MSADO15.DLL) for ADO 2.1 - I don't know if this would have messed things up.
tomnichAuthor Commented:
Cheers that worked.  Actually I just had to install the MS ADO Data Access Pack 2.1.  I had previously just installed one of the DLLs of this pack and it was obviously incompatible with the others (so much for COM!)
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.