• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 224
  • Last Modified:

Windows98 and Memory Leaks

I recently upgraded to Win98 2nd edition. After doing so, I started to see a severe memory leak problem. Usually after heavy hard drive access. I use a system with a VIA chipset and 256 MB Ram. The memory will slowly leak down to 0....


UPDATE...Thank you for the Memturbo suggestion. However, I neglected to say that I did a clean install of just the OS and Free Mem Pro.. Same problem.. Even in Safe mode I get the leak..I think it has to do with the VIA Chipset, But their is no help from them.....Any other help would be appreciated
1 Solution

Sounds like you are having a problem with some software that you are running.  Not a windows fix but a good program to take care of memory problems is mem turbo you can download it from this site.  


get the free demo it recovers ram from programs that don't give it back to the operating system.  It then does a defrag and there you go your ram will never hit zero again.

theveritasAuthor Commented:
Edited text of question.
Theveritas, you are correct, the VIA chipset does create a large portion of the problem. Any program that calls the Win32 EnumObjects() API function may drop a memory sector during each call and eventually stop working, with the following error message:
   <Program name> caused a General Protection Fault in module GDI.EXE.
The EnumObjects() function leaks a selector each time it is called. If enough calls are made during a particular session, the local descriptor table (LDT) can
become exhausted. The computer must then be rebooted to recover the correct memory core and restart the kernel.
Back in April Microsoft reported that the manufacturer was cooperating with them in developing a supported fix that would correct this problem and would be available from Microsoft. As of the 7/1/99 release of the MS Technet, the release is still in development and hos not even entered
full regression testing.

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

I had the same problem on my system after I upgraded to SE, using a Mustang R534F MB (SiS chipset).  I found that by manually setting my virtual memory settings in the Performance Section of the System Properties, the problem went away.  I set mine to min 64meg, max 200meg.  I have 64 meg RAM in my system, and this seems to work fine, with no real performance hit.  
You should also be aware that W98+ is allocating all free RAM as cache. Worse, it will re-size the cache at the worst possible time (when it is out of RAM and has something important to do). You can set your cache size in system.ini as follows to stop this: (if you don't have a [vcache] entry, you can just paste this in.)


This would set the cache to 8 MB, and it will not re-size. Change to whatever you want of course. My system with 256 MB RAM works well with these settings, but you may have to experiment to see what is best for you.

There's also a freewareprogram, that will make the changes for you. Unfortunately I don't remember the location I got it from, but it's called 'Cacheman 3.60' and a simple search with a searchengine, will probably lead you to it...
Ups! I accidentally checked answer instead of comment, sorry!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Train for your Pen Testing Engineer Certification

Enroll today in this bundle of courses to gain experience in the logistics of pen testing, Linux fundamentals, vulnerability assessments, detecting live systems, and more! This series, valued at $3,000, is free for Premium members, Team Accounts, and Qualified Experts.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now