CD-ROM Working/Not Working...

Hi,

I have a CD-Rom drive on my hard drive.  I can't get any CD softwares(games) to be recognized.  However, I could get it to recognize sometime if I restart my computer a few times, or eject it a couple of times (with restart).  I think this is very annoying.  So can anyone help?  Please help and I appreciated it.  Oh yeah, here is my system info.

Pentium 233MMX
31MB RAM
Windows 95 with IE5 installed
6x CD-ROM

If you need to know the name of my CD-ROM drive, I have no idea.  But several places say I have Toshiba(from W95 softwares) and Oak Technology...(from autoexec.bat)types.

Also, I can't find my CD-ROM thing on the My Computer>Properties>System Devices.  I don't know why.  Another thing, for some reason it doesn't do autorun anymore for computer software (audio CDs are fine), so I manually have to run it.  

I hope that's enough information for you guys to help me.  Thanks.  
kobu84Asked:
Who is Participating?
 
Gryphon031198Connect With a Mentor Commented:
K.  If you know what make your CD-ROM is, then you can start off by finding it's drivers...you can either find the drivers for your CD-ROM at the site of the manufacturer or at driver sites ie. driverguide.com

If you have these drivers, then you can put them on a stiffy along with mscdex.exe and install your CD -ROM in Dos mode.  Once isntalled you can run the Windows Install from there.

I want to add that swcole actually has a point...why not try and upgrade the motherboard drivers first before doing this whole reformat thing?

You might also try removing the cd-rom drive, cleaning the connector pins (make sure you put it back correctly) put it ack and clean the laser lens with a lens cleaner and see what happens.  Erratic behaviour asks for erratic experiments :)


0
 
kobu84Author Commented:
Edited text of question.
0
 
OttaCommented:
> I can't find my CD-ROM thing on the My Computer>Properties>System Devices.

Edit your 'C:\AUTOEXEC.BAT' file.
Look for a line containing 'MSCDEX' in it.
Insert the string 'REM ' at the start of this line.
Look for the 'D:xxxxxxxx' on this line.
Save the changed file.
Edit your 'C:\CONFIG.SYS' file,
looking for the string 'xxxxxxxx' in some line of this file.
Insert the string 'REM ' at the start of this line.
Save the changed file.
Shutdown.
Reboot, and the MS DOS version of the CD-ROM driver
will *NOT* be used, but Windows own(!) drivers will be used,
and you'll be able to see what you previously could not see.
0
Will You Be GDPR Compliant by 5/28/2018?

GDPR? That's a regulation for the European Union. But, if you collect data from customers or employees within the EU, then you need to know about GDPR and make sure your organization is compliant by May 2018. Check out our preparation checklist to make sure you're on track today!

 
kobu84Author Commented:
I edited the autoexec.bat and config.sys by adding REM to the line containing MSCDEX...

I rebooted, and it's look like Dos CDROM Driver is not loaded.  But I still can't see the CD-ROM on the list of Device Manager.

My main problem is that I can't really get any CD-ROM software to be recognized.  Please still help.  Thanks.
0
 
kobu84Author Commented:
Hi, I also want to mention few more things about your tips above.  I looked into My Computer and saw CD DRive missing and if I try to open, the drive, the drive goes back in after 1 second without letting me put disc in.  I almost broke my NHL'98 cd.  Anyway, this happened after I put the REM line in autoexec.bat and config.sys.  (Sorry, Otta, I am going to reject your answer, but please give me other solution, thanks.)

I also forgot to tell you that my CD-ROM Drive is label as G:\.  Also all of my hard disk including my CD-ROM is MS-Mode Compatabilty (or something like that).  This happens after I upgraded my computer last year (Oct/98 and Aug/98).  I upgraded to 6X CDROM, Pentium 233MMX (with new motherboard), and 32MB RAM (but now 31 because 1MB is for the onboard video card - SiS 5597/98).  Hopefully that an enough information to help me solve my problem.  

Thanks and please still help.
0
 
Gryphon031198Commented:
First scan your computer with an UPDATED virus scanner.  Erratic behaviour of this sort can be caused by the Exebug virus or similar virii.  If no virii found read on...

If your drives are in compatibility mode it implies that Windows cannot see your drives using normal Windows 95 based drivers but rather DOS drivers that bypass Windows.  That is why Otta's solution wouldn't have worked.

This error is probably one that is most easily fixed by reinstalling Windows 95 (and therefore all of the hard drive drivers + all motherboard drivers) on a formatted hard drive.  

It appears as if your hard disk is partitioned.  If so, move all of the info you want to save from your main (C) partition to any other partition as a backup.  Format your main partition as a system disk, install your CD-ROM in Dos and reinstall Windows.
0
 
kobu84Author Commented:
Hi, people.

Sorry for keeping you guys waiting for my feedback.  I was busy, and was researching for a while about my problem.  

Gryphon,

I'm sorry to reject your answer, even though it looks like a perfect solution for anybody.  However, even I formatted my drive and uninstall W95, I'm pretty sure that I won't be able to read my CD-ROM, even though I'm using Dos Driver (or in Dos mode).

Do you know you know what I mean?  I mean that if I uninstall W95 and format C drive, and can't read my CD-ROM from DOS, then I'm in big trouble.  

As you guys can see, my main problem is getting W95 to recongized my CD (games, utilities, etc.).  So what I have to do is to get my CD Drive to work properly, then I'll be sure to format my hard drive to give my computer a fresh start.  

I hope you guys can still help me.  

Kobu S.

P.S.: I also scanned my hard drive for virus, but none are found.  However, I may try to put the virus-scanning sheduler back on, so I can (hopefully) keep my computer in good shape.  Here is my computer spec, for those who may want to know.

Pentium 233MMX
31MB RAM, 6.4GB
Windows 95 with IE5 installed
6x CD-ROM

 
0
 
swcoleCommented:
Have you tried upgrading your motherboard drivers? Many Pentium boards have a patch for CD Rom compatiblity problems with IRQ 14.
0
 
kobu84Author Commented:
Hey guys,

I have good news and bad news.  The good news is that my CD-ROM is working normally!! (but I still don't have that autorun or CD-ROM thing in the Device Manager).  The bad news is that I fixed it before I actually have a chance to read Gryphon's and Swcole's solution.  So it looks like that I won't be formatting hard drive or updating drivers for a while.  I heard that we shouldn't bother updating drivers at all when they are working fine.  

The problem is that I don't know who to give the point to to.  I think I have a solution. I'll give Gryphon 100 (half of the total points)and Swcole a 100 pts. (another half of the total points).  I think that's fair.

In case you guys are wondering how I fixed my problem.  Well, at first I was looking at my System properties, and played with it:  

First, I put my virtual memory to F:\ drive(because it's empty), then went to CD-ROM caching and put Quad speed or higher setting, and drag the notches to Small.  I restarted my computer.  I went to the Control Panel, and was also playing with it.  I opened TweakUI, and made changes that I don't need.  For example, I unchecked tastbar animation, welcome messages, etc., because I couldn't get these to work anyway.  I also emptied my History and C:\Windows\Temp folder. Then I restarted my computer a couple of times.  And decided to give CD-ROM drive one more chance.  Guess what it works.

Anyway, I just want to say thank you for helping me.  I really appreciate it.

See-ya.

P.S.:

Swcole, I'll post another "question," so just answer anything you want, and I give you points.  I am giving points to Gryphon, because he posted the Proposed Answer.  Thanks, and be sure to look for me in the General Hardware section.    
0
 
Gryphon031198Commented:
Thanks buddy :)  
0
All Courses

From novice to tech pro — start learning today.