Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Sound under RedHat 6.0 doesn't work

Posted on 1999-07-06
7
Medium Priority
?
263 Views
Last Modified: 2013-12-15
I installed RedHat 6.0 on my system and everything worked out fine. However, when I use the included sndconfig utility to configure sound support, I ran into a problem. After selecting the correct card (Aztech Sound Galaxy Washington 16) and setting all of the settings (IRQ's, DMA's, etc.) to the correct values (I quadruple-checked the values under Windows 95 under System Properties in the Device Manager), and clicking OK to test the configuration by playing a sample sound, I get an error message titled "modprobe":

  The following error occured running the modprobe program:
  /lib/modules/2.2.5-15/misc/sgalaxy.o: invalid parameter   mpu_io
  sound: Device or resource busy

I know for sure (from the Win95 Device Manager, anyway) that the MPU IO setting is correct. Even if I change it to the other MPU IO option, the same error occurs. I've tried using alternate soundcard selections (such as MAD16 or WSS) which generate similar errors. The only soundcard selections that seem to work are the Sound Blaster ones, but when these are used, only CD audio and a few select .wav files will play correctly while all other .wav files, .mp3 files, etc. will play, but all I hear is static. Again, with the SB selection, some sound works, most doesn't (which is why I need to use the correct soundcard settings, I figure).

What generates the above error, how could it be resolved, how can I get correct sound support under RedHat 6.0?
0
Comment
Question by:Myst120
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
7 Comments
 

Author Comment

by:Myst120
ID: 1629288
Adjusted points to 200
0
 
LVL 2

Expert Comment

by:nirsim
ID: 1629289
Hi Myst,

  I don't know that card, but I would like to know, is that a PNP card ?

Regards,
  Nir Simionovich
  Linux-IL Member
  Artnet Experts Ltd.
0
 

Author Comment

by:Myst120
ID: 1629290
no, it's not a PnP card..
0
How Blockchain Is Impacting Every Industry

Blockchain expert Alex Tapscott talks to Acronis VP Frank Jablonski about this revolutionary technology and how it's making inroads into other industries and facets of everyday life.

 
LVL 2

Expert Comment

by:guiyu
ID: 1629291
Offhand, based the Sound Galaxy module info @

http://store.redhat.com/corp/support/hardware/intel/60/rh6.0-hcl-i.ld-13.html

The only supported parameters are
         io, irq, dma, dma2
whereas mpu_io was not stated as supported, and is confirmed
from your error message:

/lib/modules/2.2.5-15/misc/sgalaxy.o: invalid parameter   mpu_io

Therefore the first thing to try

a) edit your
         /etc/conf.modules
file and remove the "mpu_io=xxxxx" reference (see my sample file below).

b)do a:

        lsmod
to see what modules are listed.

c) remove all sound modules
       rmmod sound, etc.
   when you get dependency, remove the depended modules first

d) reinstall the sound modules
       modprobe -a sound

That should get rid of your 'mpu_io' error.
If there is no improvement, then please provide additional info that will help in the diagnosis:

Type the following commands (minus the numberings) and post the output:

1) lsmod
2) cat /dev/sndstat
3) cat /proc/interrupts
4) cat /proc/dma
5) cat /etc/conf.modules


Please repeat the above procedure for
a) SoundBlaster configuration (under sndconfig)
b) Aztech Sound Galaxy configuration (under sndconfig)

==========================================================
The following is an example of the output from my linux Red
Hat 6.0 when typing these commands:

1) lsmod

Module                  Size  Used by
awe_wave              157804   0
sb                     33652   0
uart401                 6032   0  [sb]
sound                  59064   0  [awe_wave sb uart401]
soundlow                 304   0  [sound]
soundcore               2788   7  [sb sound]
nfs                    30072   5  (autoclean)
nfsd                  151192   8  (autoclean)
lockd                  31336   1  (autoclean) [nfs nfsd]
sunrpc                 53572   1  (autoclean) [nfs nfsd lockd]
tulip                  25348   1  (autoclean)
aic7xxx               107024   8
alias scsi_hostadapter aic7xxx
alias eth0 tulip
alias parport_lowlevel parport_pc
pre-install pcmcia_core /etc/rc.d/init.d/pcmcia start
alias sound sb
pre-install sound insmod sound dmabuf=1
options opl3 io=0x388
alias midi awe_wave
post-install awe_wave /bin/sfxload /etc/midi/GU11-ROM.SF2
options sb io=0x220 irq=5 dma=1 dma16=5 mpu_io=0x330

2) cat /dev/sndstat

OSS/Free:3.8s2++-971130
Load type: Driver loaded as a module
Kernel: Linux zoro.ece.utexas.edu 2.2.5-15smp #1 SMP Mon Apr 19 22:43:28 EDT 1999 i686
Config options: 0

Installed drivers:

Card config:

Audio devices:
0: Sound Blaster 16 (4.16) (DUPLEX)

Synth devices:
0: AWE32-0.4.3 (RAM512k)

Midi devices:
0: Sound Blaster 16
1: AWE Midi Emu

Timers:
0: System clock

Mixers:
0: Sound Blaster

3) cat /proc/interrupts

           CPU0       CPU1
  0:   50739031   50725725    IO-APIC-edge  timer
  1:      95680      96814    IO-APIC-edge  keyboard
  2:          0          0          XT-PIC  cascade
  5:    1196581    1187763    IO-APIC-edge  soundblaster
  8:          1          1    IO-APIC-edge  rtc
 12:    1272005    1265355    IO-APIC-edge  PS/2 Mouse
 13:          1          0          XT-PIC  fpu
 16:    3132883    3132249   IO-APIC-level  eth0
 19:     134206     133972   IO-APIC-level  aic7xxx
NMI:          0
ERR:          0

4) cat /proc/dma

 1: SoundBlaster8
 4: cascade
 5: SoundBlaster16

5) cat /etc/conf.modules

alias scsi_hostadapter aic7xxx
alias eth0 tulip
alias parport_lowlevel parport_pc
pre-install pcmcia_core /etc/rc.d/init.d/pcmcia start
alias sound sb
pre-install sound insmod sound dmabuf=1
options opl3 io=0x388
alias midi awe_wave
post-install awe_wave /bin/sfxload /etc/midi/GU11-ROM.SF2
options sb io=0x220 irq=5 dma=1 dma16=5 mpu_io=0x330

0
 

Author Comment

by:Myst120
ID: 1629292
thanks...my sound card now works
guiyu, if you want your points, submit an answer..
0
 
LVL 2

Accepted Solution

by:
guiyu earned 800 total points
ID: 1629293
Answer:
See previous comment

What did you do to make it work?
0
 

Author Comment

by:Myst120
ID: 1629294
I deleted the unsupported soundcard settings from /etc/conf.modules, deleted the sound modules and reinstalled them like you said...
must be a bug in the Red Hat sndconfig utility because it asks for mpu io and mpu irq settings for the aztech soundcard
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How many times have you wanted to quickly do the same thing to a list but found yourself typing it again and again? I first figured out a small time saver with the up arrow to recall the last command but that can only get you so far if you have a bi…
SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Suggested Courses

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question