Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

CD ROM won't display long filenames

Posted on 1999-07-07
5
Medium Priority
?
233 Views
Last Modified: 2010-04-27
P133
Mitsumi CD ROM drive
Win 95


For some reason my CD Rom drive won't display long filenames.

I had a hard drive crash on this machine and now the Primary IDE controller (dual fifo) and Secondary IDE controller (dual fifo) show an exclamation point in Device Manager. However, I can still access my main harddrive.  I don't know if the controller problem has anything to do with the CD ROM problem.

I've reinstalled the IDE controller drivers and the CD Rom drivers, but I still only see DOS filenames, not long filenames.

Any thoughts?
0
Comment
Question by:fredga
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
5 Comments
 
LVL 5

Accepted Solution

by:
JBURGHARDT earned 600 total points
ID: 1158639
Your computer los drivers for ide ports you need to do thing reinstall bus mastering drivers and or look for "noide" in registry and remove it. Your cd-rom using dos drivers that don't support long name after you correct problem with ide controler all will be back to the way it should be

0
 

Author Comment

by:fredga
ID: 1158640
Ok, I removed the NoIDE from the registry. This temporarily made the CD ROM work normally, and made the problems in the Device Manger go away, but then the system locked up and when I attempted to reboot, Windows gave error messages.

I had to boot in Safe Mode and add NoIDE back to the registry. NoIDE had a value of 01 if it matters.

So, I'm back where I started.  I had already installed the IDE drivers supplied by the motherboard manufacturer.

Any more ideas?
0
 

Author Comment

by:fredga
ID: 1158641
Adjusted points to 200
0
 
LVL 6

Expert Comment

by:kschang
ID: 1158642
If you are using MSCDEX as your driver (i.e. you have that loaded in AUTOEXEC.BAT)), that'll cause CD-ROM to have no long file names, because MSCDEX is ISO9660 level 1 only (i.e. the DOS 8.3 filename limit).

0
 

Author Comment

by:fredga
ID: 1158643
I finally corrected a couple of other problem, but removing the NoIDE from the registry fixed the problem.  Thanks!
0

Featured Post

Take our survey for a chance to win!

As a valued customer of Targus, we’d like to ask you a few questions about us. As thanks, you will be automatically entered for a chance to win a $500 VISA gift card. To enter, just complete the survey by September 15, 2017.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A clone is a duplicate copy. Sheep have been cloned and maybe someday even people will be cloned, but disk cloning (performed by the hard drive cloning software) is a vital tool used to manage and protect data. Let’s look at what hard drive cloning …
Arrow Electronics was searching for a KVM  (Keyboard/Video/Mouse) switch that could display on one single monitor the current status of all units being tested on the rack.
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question