CDROM not detected in win98, fine in DOS

I recently enabled the DMA on my mitsumi 12X cdrom, after a reboot, the cdrom was not detected by win98 at all. I have tried everythin under the sun and I still can't get it. The drive works fine under DOS. Windows detects it as new hardware, but of an unknown type, and can't install drivers for it. I put my old 6X mitsumi back in and it works fine, so I know something is up the the 12X. Has anyone ever had this problem or has heard of it? If so please help me... Thanks
Who is Participating?
shift1Connect With a Mentor Commented:
OK,here we go...
1-have you checked master/slave jumpers on CD-ROM?Make sure these are set correctly(I'm assuming you know this,as you've actually installed everything yourself).
2-do you have low-level device driver added to CONFIG.SYS or MS-DOS cd-rom driver(MSCDEX) in your AUTOEXEC.BAT?
3-have you tried cd-rom in another system(if possible)?This is to verify(somewhat)that device works.
4-in the autoexec.bat file there will be a line which reference your cdrom and also a line will appear in your config.sys file - i am sorry but i dont remember the exact file name it will reference but it will end with either 000 or 001 at the end of the file name - these must have the same number at the end for it to work properly eg mscd001 or mscd000
5-try different drivers - i have a samsung driver for a 12x and it has worked for a lot of other cdroms that i have installed - when their drivers did not work - the install program it utilizes is CDSETUP as opposed to MSCDEX - more information is needed, this will get us started
6-if your scsi or ide cdrom drive does not appear in device manager make sure your driver appears in the ios.ini safe list - if a real mode driver is loaded for the cdrom drive and the driver does not appear in the ios.ini safe list then windows does not install protective mode drivers for it and does not appear in device manager - if this is the case you comment out the real mode driver [eg. rem device=c:\sbrpo\drv\sbpcd.sys/d:mscd001 /p:220] and then reboot your computer - windows should then automatically detect your cdrom

need to know what version os you are running
Make sure that in the BIOS, the CDROM is set for auto .
Go to device manager and delete the cdrom. Reboot and let windows find and install it.
If it still does not work then when you remove the cdrom, you may have to manually choose a driver from windows driverbase dy using search and show all devices.Go to Mitsumi and select the one that suits.

I have the same thing in my office. I installed the driver for the CD-ROM but Windows cannot find it. I went to DOS and there it is. Then went back to Windows, no CD-ROM drive. I do add new hardware and it find but doesn't appear.

The Problem is the CD-ROM itself. I think there is a loss connection with the PINS. Its not with the Windows, its the CD-ROM.

We Need Your Input!

WatchGuard is currently running a beta program for our new macOS Host Sensor for our Threat Detection and Response service. We're looking for more macOS users to help provide insight and feedback to help us make the product even better. Please sign up for our beta program today!

Make sure cdrom is DMA capable...if it worked before checking DMA box,the possibility of no DMA on cd-rom is highly likely.Try un-checking DMA.A 12X cd-rom sounds old.
Try checking DMA in cd-rom settings,apply it,close out,go back into settings and see if DMA is still checked.If so,DMA applies to cd-rom...if not,DMA is not possible w/cdrom.Just a test,nothing more.
darkfist_Author Commented:
On the boot up following the normal reset (after selecting the DMA option) windows did detect new hardware but didn't know what it was. Subsequently i couldn;t install the driver.. When i went in to the add new hardware section of the control panel, i could add a cdrom, but couldn't  accept any drivers what so ever. The 12X should autodetect and not need any drivers according to mitsumi. My 6X auto installs its drivers normally, as did the 12X before I toggled the DMA switch. Again in DOS the 12X is fine, since i can manually load the sys drivers. But in windows i can't get any driver inf file to work. The cd refuses to work. Something must be wrong with the CDROM itself, It's as if the mechanism in the cdrom which tells windows what it is and what drivers it needs has malfunctioned... i hope this additional info may be of help...
one other thing..chk pins at back of CDROM to make sure none are missing or bent..have spent numerous hrs. only to realize this was problem.
also,remember pin1 rule on cable...
chk DMA channels in BIOS-tho' I'll assume OK because DMA worked on 6X,or was 6X not DMA capable?
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.