pcmcia scsi irq

Since I upgraded to RH6.0, suddenly my pcmcia has a different irq=3, which clashes with my ttyS1. I could not find a configuration file to set the irq for the scsi controller. Consulted the howtos but the only option mentioned is passing parameters at boot time. I would rather have a text file configuration if possible.
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
If there is a text file to configure the irq PORT address etc, please let me know, with some example if possible
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
MY dmesg output of bootup is included here for completeness.
IO port probe 0x1000-0x17ff; excluding 0x1220-0x122f 0x1278-0x127f 0x1300-0x131f 0x1380-0x139f 0x1620-0x162f 0x1678-0x167f 0x1700-0x171f 0x1780-0x179fcs; IO port probe 0x0100-0x04ff; excluding 0x220-0x22f 0x278-0x27f 0x378-0x39f 0x4d0-0x4d7cs; IO port probe 0x0a00-0x0aff; excluding 0xa20-0xa2f 0xa78-0xa7fcs; memory probe 0x0d0000-0x0dffff; clean.aha152x; processing commandline; okaha152x; BIOS test; passed, detected 1 controller9s0aha152x0; vital data; PORTBASE=0x340, IRQ=3, SCSI ID=7, reconnect=enabled, parity=enabled, synchronous=disabled, delay=100, extended translation=disabledaha152x; trying software interrupt, ok.

LVL 1
dryzoneAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mauricetokyoCommented:
The file to set the configuration for the PCMCIA is

/etc/sysconfig/pcmcia

Try to set up
irq_list=9,10,11 or whatever there to tell it which IRQ to use.

For questions please don't hesitate to contact me.

Maurice
0
dryzoneAuthor Commented:
The entry in the config file did not solve the problem. After booting, the irq was still 3
0
dryzoneAuthor Commented:
What tells the kernel to take irq=3 !! if it is not in the config file. This is crazy -- almost windoze.
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

mauricetokyoCommented:
The BIOS tells it that it is on IRQ 3. You can change the settings in BIOS.

The /etc/sysconfig/pcmcia tells it how to utilise the IRQs.

MOshe
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dryzoneAuthor Commented:
Thanks for the answer - but no, The bios can be on pnp or manual. For pnp I get irq 3, For nanual,I set it to ISA for everything but the scusicard. I then leave open irqs 10 and 11, which are not taken at all in order that linux can probe and at least use a software interrupt there. The software interrupt also fails as you can see from my initial posting since it does not say using irq11 etc. So this must be a Linux probe/config file problem. The bios is not guilty. I also disabled com2 at irq3 in order to let Linux have its stubborn way but to no avail. There is nothing wrong with the hardware. It runs as is on a dual boot on win 95. Maybe it is time to switch back to windows? At least what you expect from Linux is that everything is configurable -- which seems to be less the truth with RH6.0 (5.2 served me flawlessly). Reinstalls dont work, upgrades trashed my entire network setup--6.0 is really crap if you ask me.
But, keep on trying. Your help is appreciated.

0
mauricetokyoCommented:
Well, yes, you are right. RedHat 5.1 or 5.2 worked much better than 6.0 . The reason is that 6.0 sports a new kernel, the 2.2.x series, which make a lot of problems.

In my configurations, I had to change the PCMCIA setting from 11 to 3 to make it work. So, I changed the sound from 10 to 5 in the BIOS and also told it to put the mouse on 11.

The, in linux I told it to scan only 3, 8 and 9 for IRQs during boot. That worked and my network is now up and running.

Maybe reading the PCMCIA will help. It certainly helped me.

Be well

Moshe
0
dryzoneAuthor Commented:
The pcmcia mini howto and howto is real sloppy. I actually found more help in A Rubini's book in an indirect way. I think anybody can improve on those howtos. It is written without any system initial conditions in mind.
All I need is to be able to set the irq to use in a text configuration file somewhere, without it automatically being chosen for me. irq=3 is a real stupid choice and should be seen as a violation by the kernel since serial ports usually use that.
If you have any more suggestions please inform me.
----------------------------------------------------
I think that this is a typical problem caused by some silly automation or detect  code somewhere -- exactly the thing that drove me away from ms.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.