• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 234
  • Last Modified:

problem setting up my internal modem with Mandrake


I just installed a Linux Mandrake 5.3 into my PC, and I am having a hard time letting it detect my modem (internal Cnet 56K), I used kdeppp, and the result of my "query modem"
is that modem is busy... why?

Thanks in advance
  • 3
  • 2
1 Solution
Is it a Winmodem? AFAIK, forget it.

What does setserial report about your modem, which tty, etc.?
In which port is it installed?

 Can you at least communicate with your modem if you do:

minicom -s /dev/ttyS1

 Once under minicom, choose "Exit" and try typing:


 Even if you don't see what you're typing, just to see if you get some "OK"s...

 Note that ttyS1 is if your modem is in COM2. Follow the table below to find out wich serial tty it is:

COM1 = /dev/ttyS0
COM2 = /dev/ttyS1
COM3 = /dev/ttyS2
COM4 = /dev/ttyS3


delphiusrAuthor Commented:
Well, the thing is, it is said to be COM4 (ttyS3) in Windows 98

to ahoffmann:
  I tried to use setserial, but there is to much parameters and options to enter, could you please be more specific about the command line

to EatEmAndSmile:
  I tried using what you suggested but, the status bar always resets to "offline" when I press a key.
Build your data science skills into a career

Are you ready to take your data science career to the next step, or break into data science? With Springboard’s Data Science Career Track, you’ll master data science topics, have personalized career guidance, weekly calls with a data science expert, and a job guarantee.

Well, I'm afraid there's a big chance your modem is a winmodem, so... It doesn't work with Linux.

 If your modem where on COM1 or COM2, it could be in conflict with another port, but as this is not the case, I can't find another reason for it to be not working.

 I suggest you to grab another modem from a friend or any other person and try it.
setserial /dev/ttyS2
tells you how linux uses this port (COM3).
You also can set the appropriate parameters like irq, ioadr, etc.. Go to Win9x and write down these values, then read man setserial and try to set these values in Linux.
didn't I say to forget the Winmodem?
What's different/better in EatEmAndSmile's answer?
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now