• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 357
  • Last Modified:

Installing New CDROM

I'm installing a new CD-ROM on my Win 95 computer...hardware nothing unusual that I know of.  I'm replacing the old one, so I'm using the same power supply, same 40 pin connector, and the 4 pin connector to the sound card.  I'm getting nothing, even when I run the Add New Hardware wizard (it doesn't find anything).  I swapped the power supply cord with another one (on my disk drive) and that's not the problem.  When I boot up, I get error messages that it can't read the CD-ROM (abort or retry, etc.).  The brand of the new CD-ROM is Digital Research (this one actually made by BTC, I believe), model DRCDROM40.  I'm out of ideas...can anyone help?
  • 5
  • 3
1 Solution
mrjlalAuthor Commented:
Edited text of question.
mrjlalAuthor Commented:
Also, I've looked through some of the other questions in this section, and see that others have had similar problems.  For clarification, I've removed any reference to MSCDEX in autoexec.bat and the related line in config.sys.  Also, I don't have any yellow exclamation points in Device Manager.  
First, make sure that the CDROM is jumpered correctly.  If it is on a cable by its self, it needs to be set as master.  If it shares a cable with the hard drive and is on either the middle or end connector, it needs to be set as slave.
  If the middle connector on the IDE cable is connected to the MB/controller, with the hard drive at one end and the CDROM at the other end (so the whole shmele looks like a Y or a V), You have to set it for cable select(CS).  If the CDROM is correctly jumpered, continue with the rest below.

Add a device= line to your config.sys line including the name of the cdrom driver (hope you got dos driver diskette with the cdrom). EG DEVICE=C:\CDROM\CDROM.SYS /MSCD000 /V

Reboot, and press f8 when "starting Windows 95" appears.
Select "Step by step confirmation".  Press y, y, y uptill and including the device= statement you added in your config.sys.  Watch what happens.  The dos-mode cdrom driver should detect your CDROM.  If it detects your CDROM, and you continue selecting y,y,y until the load all windows drivers prompt comes up and you select y again, I think you will find that WIN95 now "sees" your CDROM.  If this is the case , just leave that device line in there and problem is solved (with some CDROMs and WIN95, this step seems to be required, I don't know why).

     If the dos mode driver hangs, or fails to detect your CDROM, you probably bought a lemon and will have to exchange it or get a refund.

SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

mrjlalAuthor Commented:
Thanks very much Ghead for your thorough and easy to understand advice.  I did what you recommended, and I'm still not getting any response from the CDROM and still the message when I boot up.  Before I return the thing, let me tell you exactly what I've got setup in config.sys and what messages I'm getting...maybe you'll see something else I've done wrong:

config.sys now has the following:
There isn't anything in the autoexec.bat file, however, which seems contrary to some advice that similar problems in E-E have been given...still okay with you?

I get the following message during boot-up:

ATAPI IDE CD-ROM Device Driver
Copyright 1998-1999 Behavior Tech Computer
Release Date:  11/10/1998
/DMA --> Enable PCI Bus Master DMA Mode
/UDMA --> Enable PCI Bus Master Ultra DMA Mode
Sound card IDE Port 168 --> IRQ 10
Sound card IDE Port 1E8 --> IRQ 11
Driver Version:  2.8
Device Name:  MSCD001

CDROM driver not read.
Abort or Retry?

It looks like it's reading the driver okay, so the bad equipment theory is starting to sound correct.  One point of info...I have a additional hard drive (slave) designated as D: and I tried making the D: into E: with no luck...should this make any difference?

Again, thanks.

mrjlalAuthor Commented:
I'm waiting for Ghead to reply to my additional comment...E-E still seems to want me to accept or reject his previous answer.  Ghead, are you out there?
Hello mrjlal.  The response shown indicates that your CDROM is not being initialized by the driver, meaning it doesn't work.  You previously mentioned that all cables were connected.  The final check to perform is on the ribbon cable where it connects to the CDROM.  Just check to ensure that the red side of the cable is aligned to pin1 side on the back of the CDROM.  Some CDROM drives have the pinouts as a mirror image of others, so you have to double check this.

     If the cable is hooked up red-to-pin1, the drive is defective.   Yours  probably will not have been the first CDROM brought back to the vendor with this problem.

     Drive letters are assigned by the bios and OS automatically. There is not any way to change this order: A:FLOPPY, B:FLOPPY, C:BOOT DRIVE, D:2ND HD(if exist) or REMOVABLE DRIVE(CDROM) E...?;LOGICAL PARTIONS ON HARD DRIVES, ?=LASTDRIVE=?:REMOVABLE DRIVE(CDROM)

So one floppy, 2 disks with single partions, and 1 CDROM should be A:floppy, C:harddisk, D:harddisk, E:CDROM

These manufacturers are pumping out so many units, and profit margins are so tight, you really can't be suprised if you pick up a bad unit.  Good Luck -Greg
One quick comment, the statement you added to config.sys is more or less a trouble shooting step and can be removed once you get the OS to acknowledge your CDROM.  Leaving it there will not cause any problems and only use 10k of memory. If you want to reject my answer and wait until you are sure that the advice I gave is correct, fine by me.  I have no objections.
mrjlalAuthor Commented:
Thanks Greg..you've convinced me that the equipment is bad...I had already made sure the red stripe was on #1.  Appreciate the superb help!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now