Pentium3 , NT4.0 , sp4 and PCI Driver

HI Experts,
I am facing a problem with Nt Driver.The driver is for a PCI card which supports Bus mastering and DMA transfer. It was working perfectly with Pentium 11 Machine with NT4.0 and sp3.
When I Loaded that driver in Pentium 3 with NT4.0 and SP4.
it is giving a Blue screen at start-up.
I tried the following :
new install nt-4.0 with service pack 3 -> not ok
                                service pack 4 -> not ok
                              latest bios version -> not ok

2 different Card -> not Ok
different slots -> not Ok
But when I Uninstalled the Ethernet driver, the driver started up.After a shutdown of the system,and adding an other ethernet pci board,just plugged it in and rebooting the system.The Driver crashes again.
I suspect, it due to some interrupt  problem.
What could be the reason?
Please Help me.. If the information is not enough, I can provide you more.
Thanks in Advance
Jijo

JijoAsked:
Who is Participating?
 
vispaulConnect With a Mentor Commented:
goto cmos setup & neter all the defaults

then restart
0
 
satwaCommented:
This is a fair;y common problem with Windows NT 4.0 as it is a non-plug and
play OS, and if you use plug and play and Bus Mastering cards with NT 4.0.
it sometimes gets confused, and to top all this off some of the Microsoft
Service packs have patches in them to cure known bugs, but when the bugs
are eliminatied others surface.

The methos that I use to sort all this out is to remove the hard disk with
Windows NT on it, put in a fresh hard disk, install Windows 95B OSR2.5
or Windows 98 on it, and get every thing working using the Win95/98
Plug and Play, check everything 2 or 3 times to be sure  that I do not
have any problems, and then I go to control panel select system, then device
manager, and then write down all the I/O , DMA, IRQ, Resources, etc. for
each and every device.

I then shut down, turn off the power, remove the Win95/98 hard disk, install
the Windows NT 4.0 disk, power on, select last known good hardware profile
in NT during boot-up, and go to NT diagnostics or control panel and set each
device manually as to I/O, DMA, IRQ resources, etc. then re-boot.  This has
worked everytime for me, when I have problems with a new Service Pack
installation.
0
 
JijoAuthor Commented:
Hi vipul,
Thanks very much for your answer.
Could you please substantiate your answer?
How the CMOS setup deafaults will save the Problem?
regards
Jijo
0
Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

 
vispaulCommented:
yes jijo,As you might be knowing there are certyain options in the cmoswhere in you allocate irq s to pci slots.So if there is a problem over there then you could face this problem.Check it out & let me know if the problem is solved.

Regards,

Paul
0
 
JijoAuthor Commented:
Thanks vispaul fro your promt reply.
i will try this out and let you know.
thanks once again
0
 
KejtarCommented:
A side comment without getting into specifics really....
You mention that you are running service pack 4.0.... from personal experience with it and talking to people I know that there is an enourmous amount of problems that it causes, some of which Microsoft does not admit to, but they dissapear the second SP5 is installed....
Just my two cents worth
Kejtar
0
All Courses

From novice to tech pro — start learning today.