Disk drive a: is not recognized

I have installed a new motherboard (Chaintech 5AGM2), an AMD k6-2 400MHz and a Diamond Speedster A/50. When I connected everything and booted the system at first I got an error message "Windows protection error IOS .." I tried again I was able to get in the safe mode. but my floppy drive and CD ROM were not recognized anymore. I disconnected the floppy and connected again nothing worked. I can hear the floppies to run but not recognized. So now I can start windows and cannot reinstall windows again.
Who is Participating?
dalehendConnect With a Mentor Commented:
You should check Device Manager in the Systems icon in Control Panel. Check floppy disk controller and drives for interrupt conflicts under resources tab. If there is a conflict, see if it allows you to select another configuration to enable the controller.
Hi Photon!

When you are changing motherboard on a computer you should ALWAYS do a reinstall of the operating system so i can re-recognize all hardware in the machine. Your problem will certinly dissapear, you could get your floppy working doing something else aswell but skipping a reinstall after changing mb is like begging for problems!

Rgds JorgenC
PHOTONAuthor Commented:
he did not answer the question fully.  i asked why did it initially recognize the drives but then would not recognize them again after i rebooted. he just told me to reinstall it, which i have already done but did not work.

Windows Protection error caused in many ways. From bad memory or wrong drivers.

In your case, try to open the CPU case and re-checked the floppy cable and make sure it goes into the right floppy controller. Now there is a red mark on the floppy cable itself. That red line goes to mark 1 in your floppy controller cable. Make sure as well that the power cable connects to your floppy disk drive. For your CD-ROM, is it connected to a Slave Drive or a Master Slave drive connection? Make sure the the red line strap goes near the power connection of your CD-ROM. Make sure as well that it plugs properly. Check your memory simms.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.