Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

MS-DOS problem

Posted on 1999-07-16
58
Medium Priority
?
279 Views
Last Modified: 2013-12-28
I download the demo version of Ramexam that after opening it made an MS-DOS icon to get into the program, but after the program was finished it wouldn’t let me back into Windows. No mater what I did, it brought me right back to the DOS program.
Only after going using 'safe mode' I was able to get back to 'System configuration Utility' and then I tried taking the check marks out of what I thought was creating the problem (2 lines with Ramdemo).

All this did was to make the computer reboot back to the Bios screen and getting a question about going back to windows or DOS, I hit 'enter' for the windows choice and it rebooted right back to that same screen and question.
Finally I took the check marks out of 'Process Config.sys file' and also the 'Process Autoexec.bat file' and now able to get back to a normal boot.

I did write Ramexam about this problem that their program created but didn’t get any answer, nice company.

@ECHO OFF
SET TMP=C:\WINDOWS\TEMP
SET TEMP=C:\WINDOWS\TEMP
SET PROMPT=$p$g
SET winbootdir=C:\WINDOWS
SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
SET CLASSPATH=C:\Program Files\PhotoDeluxe 2.0\AdobeConnectables
SET BLASTER=A220 I5 D1 T4
REM
REM The following lines have been created by Windows. Do not modify them.
REM
C:
CD C:\WINDOWS\DESKTOP\RAMDEMO
CALL C:\WINDOWS\DESKTOP\RAMDEMO\RAMDEMO.EXE
C:\WINDOWS\WIN.COM /W

I would appreciate any help getting this put back to normal, Mike

0
Comment
Question by:mjcap
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 25
  • 21
  • 10
  • +1
58 Comments
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 1674138
mjcap, I read under my perspective, you may create a loop back to your program ramdemo.exe

LINE 1   C:
LINE 2   CD C:\WINDOWS\DESKTOP\RAMDEMO
LINE 3   CALL C:\WINDOWS\DESKTOP\RAMDEMO\RAMDEMO.EXE
LINE 4   C:\WINDOWS\WIN.COM /W

     After finishing program ramdemo.exe , it is back to working directory as stated in the first line 1 as above "C:"
     BUT at Line 2 and Line 3, you set it go back to call for Ramdemo again.  Thus forming a loop and not back to windows.

     Suggesting using following lines:
C:
CD C:\
CALL C:\WINDOWS\COMMAND.COM
C:\WINDOWS\WIN.COM /WX

     Then finished program, back to the c: prompt and stay there. After receiving your type "EXIT" or "WIN", it will go back to window desktop.

Try and let me know.          pslh
0
 

Author Comment

by:mjcap
ID: 1674139
I edit the 3 lines in 'System configuration Utility' but now have a continuous rebooting without getting into Windows.

I changed this
C:
CD C:\WINDOWS\DESKTOP\RAMDEMO
CALL C:\WINDOWS\DESKTOP\RAMDEMO\RAMDEMO.EXE
C:\WINDOWS\WIN.COM /W

into this
C:
CD C:\
CALL C:\WINDOWS\COMMAND.COM
C:\WINDOWS\WIN.COM /WX


Mike

0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 1674140
mjcap, <the demo version of Ramexam that after opening it made an MS-DOS icon to get into the program, but after the program was finished it wouldn’t let me back into Windows>,

The demo version has amended your autoexec.bat as you stated above. This autoexec.bat should be rename to "autoexec.ram"

Restart your computer and try to boot into command mode by pressing <CTRL> before winlogo appear.

At the c:\ prompt , type "rename autoexec.bat autoexec.ram" without quotation, <enter>

Restart your computer, see if you can boot back to normal win98 desktop.

If success, then carry further steps.
Let me know your status.             pslh
0
Optimum High-Definition Video Viewing and Control

The ATEN VM0404HA 4x4 4K HDMI Matrix Switch supports 4K resolutions of UHD (3840 x 2160) and DCI (4096 x 2160) with refresh rates of 30 Hz (4:4:4) and 60 Hz (4:2:0). It is ideal for applications where the routing of 4K digital signals is required.

 

Author Comment

by:mjcap
ID: 1674141
Sorry for not mentioning this before, I'm not using or keeping this Ramdemo program. I would like to have all their stuff off the computer.

Mike


0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 1674142
Mike, if <continuous rebooting without getting into Windows. > rebooting in Ms-dos mode,

at c:\ prompt type "win" without quotation , <enter>

It will restart the computer and then normal windows.

Have you done that and did it go to windows?

If it can go to windows, then use notepad to open the autoexec.bat and save it as autoexec.ram.  

Try to look for any autoexec.old before RAMdemo wrote and changed your autoexec.bat and config.sys.  Try to open then and Save it As autoexec.bat and config.sys

ie Save As autoexec.old to autoexec.bat
   Save As config.old to config.sys

If there is no backup copies of autoexec.bat and config.sys before the installation of the RAMdemo.

Use notepad to open the faulty autoexec.bat as stated in your question.  Amended it to contain only following lines as :-

@ECHO OFF
SET TMP=C:\WINDOWS\TEMP
SET TEMP=C:\WINDOWS\TEMP
SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
SET CLASSPATH=C:\Program Files\PhotoDeluxe 2.0\AdobeConnectables

Save this as your autoexec.bat

Then next time, you restart your computer will not boot into MS-dos mode.
--------
Let me know if you have queries.     pslh
0
 

Author Comment

by:mjcap
ID: 1674143
This is what I found

IN C:Autoexec.bat

@ECHO OFF
rem
rem   *** DO NOT EDIT THIS FILE! ***
rem
rem   This file was created by the System Configuration Utility as
rem   a placeholder for your AUTOEXEC.BAT file. Your actual
rem   AUTOEXEC.BAT file has been saved under the name AUTOEXEC.TSH.
rem

---------------------------------------------------------

IN C:AUTOEXEC.TSH


@ECHO OFF
SET TMP=C:\WINDOWS\TEMP
SET TEMP=C:\WINDOWS\TEMP
SET PROMPT=$p$g
SET winbootdir=C:\WINDOWS
SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
SET CLASSPATH=C:\Program Files\PhotoDeluxe 2.0\AdobeConnectables
SET BLASTER=A220 I5 D1 T4
REM
REM The following lines have been created by Windows. Do not modify them.
REM
C:
Rem TShoot: CD C:\WINDOWS\DESKTOP\RAMDEMO
CD C:\
Rem TShoot: CALL C:\WINDOWS\DESKTOP\RAMDEMO\RAMDEMO.EXE
CALL C:\WINDOW\COMMAND.COM
Rem TShoot: C:\WINDOWS\WIN.COM /W
C:\WINDOWS\WIN.COM /WX


Should I change AUTOEXEC.TSH to AUTOEXEC.BAT and then make the changes as

@ECHO OFF
SET TMP=C:\WINDOWS\TEMP
SET TEMP=C:\WINDOWS\TEMP
SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
SET CLASSPATH=C:\Program Files\PhotoDeluxe 2.0\AdobeConnectables

What about ‘SET Blaster=A220 i5 D1 T4’
        also       ‘SET PROMPT=$p$g’
                    ‘SET winbootdir=C:\WINDOWS’
Does it make any difference that right now I don’t have 'Process Config.sys file' and  'Process Autoexec.bat file'
check off?
I do have a back up tape made just before this happen but not able to use it at this time.

Thanks for helping, Mike

0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 1674144
Mike, for windows98, even no autoexec.bat and config.sys , the windows still can be booted into normal desktop.  Thus, don't worry if there isn't any autoexec.bat nor config.sys in your system.  It is because the environment is already set at the IO.SYS , this feature is different from win95.
In win95, it still relies on the config.sys and autoexec.bat. In win98, we made config.sys and autoexec.bat to contain line which may further providing other drivers needed and/or configuration that are going to override/supercede the settings in the io.sys.
 
Since there are already having backup copies for reference.

Thus, for the time being , just delete the autoexec.bat and config.sys.  Let the system boot back to normal windows desktop.  I will then tell you to make it back a right copy of autoexec.bat and config.sys to optimize your windows' environment.

------
For those lines:
SET Blaster=A220 i5 D1 T4’  - This is added by your RAMDemo when running in MS-DOS mode.  In MS-DOS mode, we have to specify this for soundcard, thus providing the sound work in the DMA.  
But for win98 window , this is not needed as windows will locate the resources for your sound card automatically by plug and play function.

'SET PROMPT=$p$g’ , this is a set environment to clear the page, it is an option for clearing the screen display to show following display without the history screen.

'SET winbootdir=C:\WINDOWS’ , this is needed in MS-DOS mode autoexec.bat.  However, not needed for window98 in windows' environment as it is already included in the io.sys and MSdos.sys    Thus, no need to add for windows98 autoexec.bat.  The default winbootdir in MSdos.sys for win98 is already set as C:\WINDOWS ,  

---
Let me know if you have queries and your testing status.  pslh
0
 

Author Comment

by:mjcap
ID: 1674145
Should I delete all 4 files, 2 of each autoexec.bat and config.sys.
I have 1 of each in C: and also 1 of each in C:\WINDOWS\COMMAND\EBD

Should I reboot with the checks out the boxes by  'Process Config.sys file' and  'Process Autoexec.bat file' in the 'System configuration Utility' folder?

Mike

0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 1674146
Mike, please tell me currently, can you restart your computer and boot to normal desktop?

If you cannot, then at the c:\prompt of command mode,
delete two files only, not others.
ie C:\autoexec.bat
   C:\config.sys

There is only one autoexec.bat and one config.sys in the root directory of your c: drive

Other autoexec.* and config.* in the root and other directory eg. C:\windows\command\EBD\
don't delete them.  

After deletion, restart the computer and boot to the desktop. If you have previously selected "selective startup" by only Process Config.sys and Process Autoexec.bat" ,  Then boot into the safe mode, select the normal startup -

Restart the computer and boot into normal.       pslh
0
 

Author Comment

by:mjcap
ID: 1674147
I can only get a normal boot using "selective startup" without'Process Config.sys' and 'Process Autoexec.bat' being checked.

Mike
0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 1674148
Mike, <I can only get a normal boot using "selective startup" without'Process Config.sys' and 'Process Autoexec.bat' being checked. > Okay, fine. Boot into this stage.  

Open notepad, open the AUTOEXEC.TSH and then make the changes to contain only these lines, others delete them,

@ECHO OFF
SET TMP=C:\WINDOWS\TEMP
SET TEMP=C:\WINDOWS\TEMP
SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
SET CLASSPATH=C:\Program Files\PhotoDeluxe 2.0\AdobeConnectables

Then save the file as Autoexec.bat

I have no details about your old config.sys or the config.sys content listed in the msconfig. If the Ramdemo didnot make any changes from your previous good old state.

Use notepad to open the config.old and save it as config.sys

Then go to the msconfig, select the normal startup with the Process COnfig.sys and autoexec.bat checked.

Restart the computer.       pslh
0
 

Author Comment

by:mjcap
ID: 1674149

I used notepad to make the changes (5 lines per your instructions), then saved it as AUTOEXEC.bat  (clicked yes to replace existing file)

In Msconfig I selected ‘normal startup’ with process Config.sys and autoexec.bat checked.

Reboot into continuous rebooting like before (up to the Windows splash screen).

Reboot using ‘safe mode’ then take checks out of  'Process Config.sys file' and 'Process Autoexec.bat file’ so I can get a normal boot.

IN safe mode I still have the original AUTOEXEC.bat file, below is what I now have using a normal boot

Hope this helps, Mike

---------------------------
AUTOEXEC.bat

@ECHO OFF
rem
rem   *** DO NOT EDIT THIS FILE! ***
rem
rem   This file was created by the System Configuration Utility as
rem   a placeholder for your AUTOEXEC.BAT file. Your actual
rem   AUTOEXEC.BAT file has been saved under the name AUTOEXEC.TSH.
rem
-------------------------------

AUTOEXEC.TSH

@ECHO OFF
SET TMP=C:\WINDOWS\TEMP
SET TEMP=C:\WINDOWS\TEMP
SET PROMPT=$p$g
SET winbootdir=C:\WINDOWS
SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
SET CLASSPATH=C:\Program Files\PhotoDeluxe 2.0\AdobeConnectables
SET BLASTER=A220 I5 D1 T4
REM
REM The following lines have been created by Windows. Do not modify them.
REM
C:
Rem TShoot: CD C:\WINDOWS\DESKTOP\RAMDEMO
CD C:\
Rem TShoot: CALL C:\WINDOWS\DESKTOP\RAMDEMO\RAMDEMO.EXE
CALL C:\WINDOW\COMMAND.COM
Rem TShoot: C:\WINDOWS\WIN.COM /W
C:\WINDOWS\WIN.COM /WX
---------------------------------


0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 1674150
Mike,  go to the msconfig as you can edit,
 
[x] @ECHO OFF
[x] SET TMP=C:\WINDOWS\TEMP
[x] SET TEMP=C:\WINDOWS\TEMP
[x] SET PROMPT=$p$g
[ ] REM SET winbootdir=C:\WINDOWS
[x] SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
[x] SET CLASSPATH=C:\Program Files\PhotoDeluxe 2.0\AdobeConnectables
[ ] REM SET BLASTER=A220 I5 D1 T4
[ ] REM
[ ] REM The following lines have been created by Windows. Do not modify them.
[ ] REM
[ ] REM C:
[ ] Rem TShoot: CD C:\WINDOWS\DESKTOP\RAMDEMO
[ ] REM CD C:\
[ ] Rem TShoot: CALL C:\WINDOWS\DESKTOP\RAMDEMO\RAMDEMO.EXE
[ ] REM CALL C:\WINDOW\COMMAND.COM
[ ] Rem TShoot: C:\WINDOWS\WIN.COM /W
[ ] REM C:\WINDOWS\WIN.COM /WX

REMARK AND UNCHECK ALL THOSE LINES AS ABOVE.

Click OK and check again the boxes for [x] Process config.sys and [x] Process autoexec.bat. Confirm OK and exit msconfig.


-------
At the start-run, at the open box type [regedit] , OK
At the registry editor, route the path

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]

You will find a Name
"Shutdown Setting"   Data 0x00000002 (2)

If the value is 2 (2) that means windows will restart to its normal desktop.

If the value is 3 (3) that means windows will restart into its MS-DOS mode.  
In such a case, place the cursor on "Shutdown Setting", At EDIT menu, select modify and change the value to 2 . OK.

Exit the registry editor.

-------
Restart the computer. See any improvement.     pslh
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1674151
Hi Mike,

I've read through all of the posts here, and there seems to be some confusion as well as lack of communication, so hopefully the following will clear up the problem for you.

If you click Start, Run and type in SYSEDIT and click OK, this will bring up your system files beginning with your AUTOEXEC.BAT file. All of these files can then be directly edited without using notepad or wordpad.

Using Sysedit, please change your Autoexec.bat file to the following and save it. This will be all you need. The problem is that your file entries are causing the reboot.

@ECHO OFF
SET TMP=C:\WINDOWS\TEMP
SET TEMP=C:\WINDOWS\TEMP
PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
SET CLASSPATH=C:\Program Files\PhotoDeluxe 2.0\AdobeConnectables
SET BLASTER=A220 I5 D1 T4


================================================
Mike, do not use any of these lines in the autoexec.bat file. Use only what I've posted above.

SET winbootdir=C:\WINDOWS
Rem TShoot: CD C:\WINDOWS\DESKTOP\RAMDEMO
CD C:\
Rem TShoot: CALL C:\WINDOWS\DESKTOP\RAMDEMO\RAMDEMO.EXE
CALL C:\WINDOW\COMMAND.COM
Rem TShoot: C:\WINDOWS\WIN.COM /W
C:\WINDOWS\WIN.COM /WX

The first line and last line are a major part of the problem.

=====================================
As for the Config.sys file. If your using Sysedit as I mentioned above, Config.sys is right behind the autoexec.bat file. So, if you changed that file and saved it, you're ready to edit the config.sys. Change the config.sys to the following:

DEVICE=C:\WINDOWS\HIMEM.SYS
DEVICE=C:\EMM386 NOEMS

Now save this file as well and then do a normal restart and let us know!
Dennis


0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 1674152
Yes,Dennis! The problem is rather simple but now it looks very complicated.  Mike, please don't give up.  pslh
0
 

Author Comment

by:mjcap
ID: 1674153
ps1h

I changed data 0x00000001  to  data 0x00000002, followed your instructions in msconfig

Now getting continuous  rebooting to win98 splash then get
“You are currently running in MS-DOS mode, do you want to return to normal mode, to run windows application again [enter=Y, esc=N]?”
ESC  takes me to an C” prompt
‘Y’ brings me right back to this question

To get a normal boot I’m back to using ‘selective startup’ and no checks in ‘process CONFIG.sys and AUTOEXEC.bat’

What should I do with the change with     ‘data 0x00000002’, leave it as is or change it back to 1

Why can't we use the 'System Configuration Utility', 'selective startup', 'process Config.sys & Autoexec.bat' then putting checkes in or out of the boxes till you find out where the problem is?


dew
Can this be done in 'safe mode', can't do it in a normal boot.

Below is what I have now
Thanks to both for helping, Mike


Config.sys  (in safe mode)

DOS=SINGLE
DOS=HIGH,UMB
Device=C:\WINDOWS\Himem.Sys
DeviceHigh=C:\WINDOWS\EMM386.Exe

-----------
AUTOEXEC.bat  (in safe mode)

@ECHO OFF
rem
rem   *** DO NOT EDIT THIS FILE! ***
rem
rem   This file was created by the System Configuration Utility as
rem   a placeholder for your AUTOEXEC.BAT file. Your actual
rem   AUTOEXEC.BAT file has been saved under the name AUTOEXEC.TSH.
rem

--------------------------------------

In NORMAL BOOT

AUTOEXEC.bat  (in normal boot)

ECHO OFF
rem
rem   *** DO NOT EDIT THIS FILE! ***
rem
rem   This file was created by the System Configuration Utility as
rem   a placeholder for your AUTOEXEC.BAT file. Your actual
rem   AUTOEXEC.BAT file has been saved under the name AUTOEXEC.TSH.
rem

--------------------
CONFIG.sys   (in normal boot)

rem   *** DO NOT EDIT THIS FILE! ***
rem
rem   This file was created by the System Configuration Utility as
rem   a placeholder for your CONFIG.SYS. Your actual CONFIG.SYS
rem   file has been saved under the name CONFIG.TSH.
rem


0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1674154
Mike, yes you can run SYSEDIT in safemode. Please, just change the config.sys and autoexec.bat to exactly what I gave, as follows. Don't add or delete anything, just as it appears.

For autoexec.bat use this:

@ECHO OFF
SET TMP=C:\WINDOWS\TEMP
SET TEMP=C:\WINDOWS\TEMP
PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
SET CLASSPATH=C:\Program Files\PhotoDeluxe 2.0\AdobeConnectables
SET BLASTER=A220 I5 D1 T4

For config.sys, use this:

DEVICE=C:\WINDOWS\HIMEM.SYS
DEVICE=C:\EMM386 NOEMS





0
 

Author Comment

by:mjcap
ID: 1674155
dew

I made the changes in safe mode per your instructions and using a 'normal startup' choice, no good, still getting the continuous  rebooting to win98 splash screen (no'currently running in MS-DOS mode' message)

What are these for and should I put them back in?
DOS=SINGLE
DOS=HIGH,UMB


Mike


0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1674156
No Mike, leave them out. We're trying to find out what is causing this, and changing back and forth only confuses things..

Shut the system down, let it sit for 15 minutes, and then start it. Now note the progress and write down each part that goes right or wrong and post it here so we can sort it out.
0
 

Author Comment

by:mjcap
ID: 1674157

For a normal boot should I use "selective startup" without'Process Config.sys' and 'Process Autoexec.bat' being checked?

Mike


0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1674158
No Mike, just start the PC and let it boot up! If it is booting to the Start menu, then choose normal.
0
 

Author Comment

by:mjcap
ID: 1674159
Please explain "just start the PC "

For a normal boot I have to use "selective startup" without'Process Config.sys' and 'Process Autoexec.bat' being checked?

Or use safe mode?

Using normal "startup" in 'msconfig'I will get the continuous  rebooting

Mike




0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1674160
Mike,

1. Shut the machine off by switching it off.

2. Now wait 15 minutes and switch the machine back on.

3. At this point, does it try to boot normally or does it boot to a boot menu, which includes safemode etc?

4. If it is to a menu, boot to safemode, NOTHING ELSE.

5. Once safemode has booted, shut down the system by clicking Start, Shutdown, and then select shutdown. Does it do this? If not, what does it do?

6. If it doesn't boot to a menu, tell me exactly what it does do. Forget about Msconfig, selective startup or anything else. Just tell me what happens when you attempt a normal startup on the machine.
0
 

Author Comment

by:mjcap
ID: 1674161
I have 2 ways of booting to windows

1--- using  this "selective startup" without'Process Config.sys' and 'Process Autoexec.bat' being checked?

2---using "normal startup" in msconfig and then after I get tired of watching it continuous  reboot I'll go to 'safe mode'

As I explained before, I have been using # 1 (above) to boot to windows, this is the only way I know how to get a boot straight to windows.


0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1674162
I understand that Mike, but you must understand that I can't see what is happening, which is why I take you through a series of procedures. With that, please do the following exactly in the order given.

1. Insert the Windows 98 startup disk in the floppy drive and restart the computer. At the menu, choose boot with CD-ROM support.

2. At the prompt: A:\> change to the "C" drive by typing C:<enter>

3. At the prompt: C:\. type cd windows\command<enter>

4. At the prompt: C:\>Windows\Command, type:

SCANREG/FIX<enter>

And let scanreg run the repair sequence to check the registry.

5. Restart the system back to the Win98 Startup Disk.

6. Insert your Windows 98 CD-ROM disk into the drive.

7. At the prompt: A:\> type SETUP /P F

This will cause the Windows 98 installer to check your files and registry for errors. Choose the custom mode and add check all items that are on your system.

Note: No software currently installed will need to be reinstalled. Nothing will be lost.
0
 
LVL 6

Expert Comment

by:satwa
ID: 1674163
I have been using RamExam since 1993, and it is not designed to be run
from within Windows or for that matter from c:\  prompt in DOS if the computer
is booted normally.  The correct way to rum RamExam is to do the makedisk
option in RamExam, let RamExam make you a boot disk, shut down the
computer, put the RamExam bootdisk in A:\ drive and boot the computer.

RamExam can sometimes be run in pure DOS mode for the quick test only
(testing of only the first 640KB of memory) if there are not too many other
things loaded in config.sys and autoexec.bat. but it is designed to be
run from a bootdisk to give an accurate test of the memory.

RamExam is a very good program, but I agree with what you said about the
company(Qualitas, inc.) that make RamExam, thay are not helpful at all.
0
 

Author Comment

by:mjcap
ID: 1674164
RAMdemo didn't give me any option to make a disk, it made a MS-DOS icon which I used.

Now i'm looking to fix the problem that Ramdemo created, I'm not interesred in RAMexam at all.

I don't want any part of a company like that

Mike
0
 

Author Comment

by:mjcap
ID: 1674165
Dew

NO GOOD, still getting the continuous  rebooting as before.

To get into Windows I am using  "selective startup" without'Process Config.sys' and 'Process Autoexec.bat' being checked?


CONFIG.SYS in safe mode (after using setup /P F)

DOS=SINGLE
DOS=HIGH,UMB
Device=C:\WINDOWS\Himem.Sys
DeviceHigh=C:\WINDOWS\EMM386.Exe
--------------

AUTOEXEC.BAT in safe mode (after using setup /P F)

@ECHO OFF
SET TMP=C:\WINDOWS\TEMP
SET TEMP=C:\WINDOWS\TEMP
SET PROMPT=$p$g
SET winbootdir=C:\WINDOWS
SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
SET CLASSPATH=C:\Program Files\PhotoDeluxe 2.0\AdobeConnectables
SET BLASTER=A220 I5 D1 T4
REM
REM The following lines have been created by Windows. Do not modify them.
REM
C:
Rem TShoot: CD C:\WINDOWS\DESKTOP\RAMDEMO
CD C:\
Rem TShoot: CALL C:\WINDOWS\DESKTOP\RAMDEMO\RAMDEMO.EXE
CALL C:\WINDOW\COMMAND.COM
Rem TShoot: C:\WINDOWS\WIN.COM /W
C:\WINDOWS\WIN.COM /WX








0
 
LVL 6

Expert Comment

by:satwa
ID: 1674166
edit your autoexec.bat file and remove the lines that read:

CALL C:\WINDOWS\COMMAND.COM
C:\WINDOWS\WIN.COM /WX

OR REM THESE 2 LINES OUT.



0
 

Author Comment

by:mjcap
ID: 1674167
I Rem them out and rebooting to this

“You are currently running in MS-DOS mode, do you want to return to normal mode, to run windows application again [enter=Y, esc=N]?”
ESC  takes me to an C” prompt
‘Y’ brings me right back to this question

I took the Rem out and to get to windows I'm using  "selective startup" without'Process Config.sys' and 'Process Autoexec.bat' being checked?

Mike






0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1674168
Mike, I just downloaded the detail info on ramexam. Somewhere on your system, your loading that program which is causing your system to update the config.sys and autoexec.bat. This is why you're seeing your config.sys and autoexec.bat being updated after you change it.

Try and boot into safemode and see if you can uninstall it either through add/remove programs or by way of it's own installer.

Use Find, Files and Folders and locate all instances of config.*** and Autoexec.*** and rename them to 001, 002 etc and then reboot.
0
 

Author Comment

by:mjcap
ID: 1674169
1--Ramdemo or Ramexam wasn’t listed in ‘add/remove programs’ so I used ‘uninstaller’ to remove the program.

2—reboot to safe mode

3--I changed 10 AUTOEXEC.* and 12 CONFIG.* per your instructions.

4—reboot twice to windows using both settings listed below.

I now have these 2 folders (AUTOEXEC.BAT-CONFIG.SYS) empty.

In ‘msconfig’ the “process Autoexec.bat file’ and ‘process Config.sys file’ are both grayed out

I can boot to windows using either ‘normal startup’ or ‘selective startup’

Mike
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1674170
Okay, based upon your latest posting, you can now switch your computer on and boot right into Windows 98, correct? or is it still booting to some sort of menu?
0
 

Author Comment

by:mjcap
ID: 1674171
yes, I can turn the computer on (using switch) and boot to windows using either ‘normal startup’ or ‘selective startup’

Mike


0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 1674172
Mike, not quite understand what you mean using either ‘normal startup’ or ‘selective startup’ ,
When switch on the computer, after the bootup menu of CMOS/BIOS , then the power on test, then the ram test (some computer may hide all this). At the stage if you press  <CTRL> or <F8> key before the windows logo appear, there is a boot menu:
1. normal  2.Logged  3.Safe mode  
4.Step-by-step confirmation 5.Command prompt only 6. Safe mode command prompt only.

If you do not press any <CTRL> or <F8> key , the windows logo will appear, then booting into normal desktop.

Please clarify to us what it looks like when you bootup your computer.                  pslh
0
 

Author Comment

by:mjcap
ID: 1674173
In System Configuration Utility (Run,msconfig)you have to select 1 of the 3 choices
1-Normal Startup
2--Diagnostic Startup
3--Selective Startup

Because of the problem of continuous rebooting, I have to use the 'Selective Startup'without'Process Config.sys' and 'Process Autoexec.bat'being checked.

WITHOUT a CONFIG.SYS and AUTOEXEC.BAT file I can use either choice of 'Normal Startup' or 'Selective Startup'which is not what I want, I would like to use the choice of 'Normal Startup'or 'Selective Startup' with the full CONFIG.SYS and AUTOEXEC.BAT files in place.

Mike


0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 1674174
Mike, Now you are already in normal desktop of windows,right? Use windows explorer, at the root of C:\drive , is there any autoexec.bat and config.sys ?  pslh

 
0
 

Author Comment

by:mjcap
ID: 1674175
No, they were all changed

Per instructions posted at 7:15PM 17 July

"I changed 10 AUTOEXEC.* and 12 CONFIG.* per your instructions."

Mike




0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 1674176
Mike,At the System Configuration Utility msconfig, at the config.sys Tab and autoexec.bat Tab. What content stated inside the boxes.   pslh
0
 

Author Comment

by:mjcap
ID: 1674177
Both empty

Mike
0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 1674178
Mike, can you find the autoexec.tsh and config.tsh ? what content there?  pslh
0
 

Author Comment

by:mjcap
ID: 1674179
No AUTOEXEC.TSH or CONFIG.TSH listed


AUTOEXEC4.bat     (this would be the same as autoexec.tsh)

@ECHO OFF
SET TMP=C:\WINDOWS\TEMP
SET TEMP=C:\WINDOWS\TEMP
SET PROMPT=$p$g
SET winbootdir=C:\WINDOWS
SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
SET CLASSPATH=C:\Program Files\PhotoDeluxe 2.0\AdobeConnectables
SET BLASTER=A220 I5 D1 T4
REM
REM The following lines have been created by Windows. Do not modify them.
REM
C:
Rem TShoot: CD C:\WINDOWS\DESKTOP\RAMDEMO
CD C:\
Rem TShoot: CALL C:\WINDOWS\DESKTOP\RAMDEMO\RAMDEMO.EXE
CALL C:\WINDOW\COMMAND.COM
Rem TShoot: C:\WINDOWS\WIN.COM /W
C:\WINDOWS\WIN.COM /WX


--------------
CONFIG3.SYS  (this would be the same as CONFIG.TSH)

DOS=SINGLE
DOS=HIGH,UMB
Device=C:\WINDOWS\Himem.Sys
DeviceHigh=C:\WINDOWS\EMM386.Exe


0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 1674180
Mike, fine I got your picture now.

       Use notepad to open a new file, (cut and paste following lines to the new file): and save it as AUTOEXEC.BAT :-

@ECHO OFF
SET TMP=C:\WINDOWS\TEMP
SET TEMP=C:\WINDOWS\TEMP
SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
SET CLASSPATH=C:\Program Files\PhotoDeluxe 2.0\AdobeConnectables
SET BLASTER=A220 I5 D1 T4



       Use notepad to open a new file, (cut and paste following lines to the new file): and save it as CONFIG.SYS :-


DEVICE=C:\WINDOWS\HIMEM.SYS
DEVICEHIGH=C:\WINDOWS\EMM386.EXE NOEMS


Then,

Start-shutdown-restart,  Restart the computer.

After restart, At msconfig , At the config.sys tab , you will find content:-

DEVICE=C:\WINDOWS\HIMEM.SYS
DEVICEHIGH=C:\WINDOWS\EMM386.EXE NOEMS

At the autoexec.bat tab , you will find content:-

@ECHO OFF
SET TMP=C:\WINDOWS\TEMP
SET TEMP=C:\WINDOWS\TEMP
SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
SET CLASSPATH=C:\Program Files\PhotoDeluxe 2.0\AdobeConnectables
SET BLASTER=A220 I5 D1 T4

Then go to the General tab checked the boxes,
[x] Selective startup
[x] Process Config.sys file
[x] Process Autoexec.bat file
[x] Process System.ini file
[x] Process Win.ini file
[x] Load startup grounp items

Then click back the normal startup, following boxes are turned gray but checked.
[x] Normal startup              [gray]
[x] Process Config.sys file     [gray]
[x] Process Autoexec.bat file   [gray]
[x] Process System.ini file     [gray]    
[x] Process Win.ini file        [gray]
[x] Load startup grounp items   [gray]

Click Ok and exit.

Restart Pc by start-shutdown-restart.

Now, you will be back to normal startup.

Use window explorer, locate the config.sys and autoexec.bat , open by notepad.
They should be stated as above as we newly saved version.

--------
let me know your status.     pslh
0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 1674181
Mike, sorry, should be at line stated above:
[x] Normal startup           not grayed but checked.

0
 

Author Comment

by:mjcap
ID: 1674182
Everything is working fine, I can use either 'Normal Startup' or 'Selective Startup'(with checks at both 'process Config.sys and Autoexec.bat files)

What should I do with the 10 AUTOEXEC.*** and 12 CONFIG.*** that I changed, I can post the list if necessary.

Will I need these 2 lines?
DOS=SINGLE
DOS=HIGH,UMB

Will I need these 2 lines for anything?
SET PROMPT=$p$g
SET winbootdir=C:\WINDOWS

I thank both you and Dew for taking the time to work on this problem, I think Dew's research on the RamExam and uninstalling that program was very important.

Is there a way of adding 50-100 points and you each getting 1/2 of the total?

Thanks again, Mike

0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 1674183
Mike, Those lines are for MS-Dos environment. If you go to Ms-dos mode (exit the normal windows desktop), make certain these line are with the config.sys (under MS-dos mode) and autoexec.bat (under Ms-dos mode). Remember :- the set of MS-DOS mode is completely different from window normal protected mode, although the name be the same as they switched without your notice.
-------
Will I need these 2 lines?
DOS=SINGLE
DOS=HIGH,UMB

Will I need these 2 lines for anything?
SET PROMPT=$p$g
SET winbootdir=C:\WINDOWS
-------
No need of these lines for normal windows protected mode of config.sys and autoexec.bat as we have just amended ones.

For those ten renamed AUTOEXEC.*** files and twelve renamed CONFIG.*** files. Keep those for future reference. Or you can open by notepad to view the content. If not worth to keep, just use windows explorer to delete some of it.
------------
pslh
0
 

Author Comment

by:mjcap
ID: 1674184
How do I check this out?
"mode (exit the normal windows desktop), make certain these line are with the config.sys (under MS-dos mode) and autoexec.bat (under Ms-dos mode). Remember :- the set of MS-DOS mode is completely different from window normal protected mode, although the name be the same as they switched without your notice."
-------
Are you saying not to put these 2 lines (DOS=SINGLE DOS=HIGH,UMB)in the C:\Config.sys file?

Mike


0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1674185
Pat, I give up! The root of the problem is the Ramexam program. The dos environment is all messed up, which is the reason for the elimination of the autoexec.bat and config.sys files. Mike needn't use these files or the configuration utility, but since he insists on doing so, I'm finished.
0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 1674186
Dennis, the problem is solved. You don't need to give up. You deserved to have points as Mike said.  <Be smile again>

Now, Mike is only having some confusion about what the function of those lines.
He is not insisting on using those lines.
I am going to explain him the "EXIT To DOS" mode so that he can see the difference between windows protected mode and MS-DOS real mode environment.....

RAMdemo program did make changes on his windows protected mode autoexec.bat with some lines to form a loop back to its demo program whenever Mike start his computer and messed up the dos and windows environment.  

Mike has gone back to window that I thought he couldn't. That's made a communication misunderstanding.

I've just simulated his environment and the problem finally got solved.
 
Be smile again, Den!       pslh
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 1674187
Thanks Pat, but the points are yours dear...you certainly worked extremely hard for them.
0
 

Author Comment

by:mjcap
ID: 1674188
Good point
0
 
LVL 12

Accepted Solution

by:
Patricia Siu-Lai Ho earned 800 total points
ID: 1674189
Mike, fine I got your picture now.

       Use notepad to open a new file, (cut and paste following lines to the new file): and save it as AUTOEXEC.BAT :-

@ECHO OFF
SET TMP=C:\WINDOWS\TEMP
SET TEMP=C:\WINDOWS\TEMP
SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
SET CLASSPATH=C:\Program Files\PhotoDeluxe 2.0\AdobeConnectables
SET BLASTER=A220 I5 D1 T4

       Use notepad to open a new file, (cut and paste following lines to the new file): and save it as CONFIG.SYS :-

DEVICE=C:\WINDOWS\HIMEM.SYS
DEVICEHIGH=C:\WINDOWS\EMM386.EXE NOEMS

Then,

Start-shutdown-restart,  Restart the computer.

After restart, At msconfig , At the config.sys tab , you will find content:-

DEVICE=C:\WINDOWS\HIMEM.SYS
DEVICEHIGH=C:\WINDOWS\EMM386.EXE NOEMS

At the autoexec.bat tab , you will find content:-

@ECHO OFF
SET TMP=C:\WINDOWS\TEMP
SET TEMP=C:\WINDOWS\TEMP
SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
SET CLASSPATH=C:\Program Files\PhotoDeluxe 2.0\AdobeConnectables
SET BLASTER=A220 I5 D1 T4

Then go to the General tab checked the boxes,
[x] Selective startup
[x] Process Config.sys file
[x] Process Autoexec.bat file
[x] Process System.ini file
[x] Process Win.ini file
[x] Load startup grounp items

Then click back the normal startup, following boxes are turned gray but checked.
[x] Normal startup              
[x] Process Config.sys file     [gray]
[x] Process Autoexec.bat file   [gray]
[x] Process System.ini file     [gray]    
[x] Process Win.ini file        [gray]
[x] Load startup grounp items   [gray]

Click Ok and exit.

Restart Pc by start-shutdown-restart.

Now, you will be back to normal startup.

Use window explorer, locate the config.sys and autoexec.bat , open by notepad.
They should be stated as above as we newly saved version.

--------
RAMdemo program did make changes on his windows protected mode autoexec.bat with some lines to form a loop back to its demo program whenever Mike start his computer and messed up the dos and windows environment.
--------    
just to repost this as an answer.         pslh
0
 

Author Comment

by:mjcap
ID: 1674190
pslh

Thank you for all your time and work in helping me with this problem.

I'm still not sure what to do with these 2 lines (DOS=SINGLE DOS=HIGH,UMB)

How do I check that they are in the config.sys (under MS-dos mode) and autoexec.bat (under Ms-dos mode)

Mike
0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 1674191
Mike, following stated, just try to search and study, don't amend anything from your current settings of win98.

I'm trying to show you Window98 is an operating system which is different from window95. Where to set the configuration for MS-Dos mode. You have to split the settings for protected mode for windows from that of the settings for real mode for Ms-Dos.  Mixed them up with unsuitable lines of configuration will mess up both system and cause booting errors.

=============

Window95 can co-exist with Ms-Dos that both environment (protected mode for win95 and real mode for Ms-Dos ) can be configured by the two sets of files -
in windows95 protected mode config.sys and autoexec.bat , you will detect there are two files called config.dos and autoexec.dos.

As you select the shutdown-restart in Ms-Dos mode, the system of win95 will switch automatically to use config.dos and autoexec.dos to start the real-mode Ms-Dos.  
In Ms-Dos mode, the config.dos will automatically rename as config.sys and autoexec.dos will rename as autoexec.bat.  Where, the protected mode win95 config.sys will rename as config.w40 and the protected mode win95 autoexec.bat will rename as autoexec.w40.

Thus, you can set differently the content of config.w40 + autoexec.w40 and config.dos + autoexec.dos .

In windows protected mode config.w40 , we have to use doublespace and smartdrive, EMM386.exe
In Ms-dos real mode config.dos, we have to specify the DOS to load high,using UMB, Number of files handler, buffers, lastdrive, Stacks numbers, etc.

They have some common files, eg. HIMEM.SYS

=====================

In windows98, it is an operating system that means it controls solely the whole system environment.
 
In Windows 98, the Io.sys system file replaces the MS-DOS system files Io.sys and Msdos.sys. This real-mode operating system file contains the information needed to start the computer. Your computer no longer needs Config.sys and Autoexec.bat to start the Windows 98 operating system (although these files are preserved for backward compatibility with certain applications and drivers).

........
Note

The Windows 98 Io.sys file is automatically renamed to Winboot.sys if you start the computer using your previous operating system.
........

The drivers loaded by default in Io.sys include the following files, if they are found on the hard disk:

Himem.sys
Ifshlp.sys
Setver.exe
Dblspace.bin or Drvspace.bin if Dlbspace.ini or Drvspace.ini exists in the root of the boot drive.
 
Most of the common functionality provided by the various Config.sys file entries in older operating systems is provided in Io.sys. Following lists the common entries from Config.sys that are incorporated into Io.sys for Windows 98.
 
dos=high
himem.sys
ifship.sys
setver.exe
Files=
lastdrive=
buffers=
stacks=
shell=command.com
fcbs=

Note

Io.sys does not load Emm386.exe. If any of your applications requires expanded memory or loads data into the high memory area, EMM386 must be loaded in Config.sys.

==========
Msdos.sys: Special Startup Values
==========

Windows 98 Setup creates a hidden, read-only system file named Msdos.sys in the root of the computer’s boot drive. This file contains important paths used to locate other Windows files, including the registry. Msdos.sys also supports an [Options] section, which you can add to tailor the startup process.

The following example shows a typical file with default values:

[Options]
BootGUI=1

[Paths]
WinDir=C:\WINDOWS
WinBootDir=C:\WINDOWS
HostWinBootDrv=C

Most values in the [Options] section are Boolean, that is, the value can be 1 (enabled) or 0 (disabled).


Thus, In windows 98, when startup the system, Windows 98 automatically loads drivers and sets defaults by using Io.sys, the registry, and other mechanisms, rather than Config.sys and Autoexec.bat.

Within the win98 system, if set to start the computer to previous operating system Ms-DOS , the io.sys will be rename as Winboot.sys. The DOS environment will be automatically loaded using the MSDOS.sys.

==========
How to go to the MS-dos mode,
In window 98, you can go to the Ms-Dos mode under normal desktop using MS-DOS prompt or tell windows to restart and entering the MS-DOS mode.

When you click the Start-shut down-restart to Ms-Dos mode, actually it will follow the settings of "EXIT TO DOS" shortcut.

You can use FIND to locate the  "EXIT TO DOS" shortcut to view the MS-DOS environment configuration. You can add/remove/delete some of the drivers there in the pif properties windows.

Use Find, at the open box, type "pif", OK
Then a list of all pif shortcuts shown up. Select the "EXIT TO DOS" shortcut. Right click into a popup, select the properties.
At the Program Tab, You can set the config.dos and autoexe.dos , view it now by clicking the [ADVANCED] button,
[x] MS-DOS mode,

Now, at the open box of config.sys and autoexec.bat

There you'll note lines for dos environment is set.

DOS=SINGLE
DOS=UMB,HIGH
Device=C:\WINDOWS\Himem.Sys
Device=C:\WINDOWS\EMM386.EXE NOEMS



SET TMP=C:\WINDOWS\TEMP
SET PROMPT=$p$g
SET winbootdir=C:\WINDOWS
SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
SET xxxxxxxxxxxxxxxxxxx
SET BLASTER=A220 I12 D3 H7 T5


Above lines will not add to the current window98's config.sys and autoexec.bat (under window's environment).

They will be used only when restarting in the Ms-dos mode automatically.

Thus,following lines do not needed to add in the windows' config.sys or autoexec.bat  
DOS=SINGLE
DOS=UMB,HIGH
Otherwise, this will confuse windows and messup the environment.

Since original io.sys of window98 renamed as winboot.sys under Ms-dos mode, following lines will be automatically added by windows in the dos-mode autoexec.bat
CALL C:\WINDOWS\COMMAND.COM
C:\WINDOWS\WIN.COM /WX

This will call back to windows and rename winboot.sys back to window98' io.sys when typing at the c:\prompt "win" without quotation.


-----
Hope this can help you.
0
 

Author Comment

by:mjcap
ID: 1674192
pslh

Thanks for your reply, I have to let this sit for a few days.

Mike
0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 1674193
Mike,

Perhaps, now you have a better perspective about the operating system of win98 and its Ms-DOS mode.

Thank for the reminder from Dew_associates/Dennis that :
<<Ramexam is a dos only program. It resets command.com, among other things, which when Windows sees it, Windows modifies its own files>>

Msdos.sys may be altered too by the Ramexam causing booting to the Startup BootMenu.
 
In order to make certain :-
a clean boot into the Windows desktop  and not to a menu.

You may need to
1>  On normal desktop of window, Use windows explorer to locate the file
    C:\ Msdos.sys

2>  Use notepad to open the file C:\Msdos.sys
    At the [options], see if there is  Bootmenu = 0

    If the Bootmenu=0, then exit without save.

    But if the Bootmenu = 1,

    then you may need to change the value from 1 (one) to 0 (zero).

    Since Msdos.sys is a system file ,  before editing,

    At windows explorer, Right click Msdos.sys to select its properties.

    Unchecked for the boxes of
    [ ] read only          [ ] hidden

    Then OK,
    Use notepad to open the file C:\Msdos.sys
    At the [options], change the value from 1 (one) to 0 (zero), ie.
    Bootmenu = 0
   
    Afterwards, checked back the boxes of  
    [x] read only          [x] hidden

Therefore, you will get a clean boot and stop the bootup menu.
------
Let us know if you have queries.     pslhMike,

Perhaps, now you have a better perspective about the operating system of win98 and its Ms-DOS mode.

Thank for the reminder from Dew_associates/Dennis that :
<<Ramexam is a dos only program. It resets command.com, among other things, which when Windows sees it, Windows modifies its own files>>

Msdos.sys may be altered too by the Ramexam causing booting to the Startup BootMenu.
 
In order to make certain :-
a clean boot into the Windows desktop  and not to a menu.

You may need to
1>  On normal desktop of window, Use windows explorer to locate the file
    C:\ Msdos.sys

2>  Use notepad to open the file C:\Msdos.sys
    At the [options], see if there is  Bootmenu = 0

    If the Bootmenu=0, then exit without save.

    But if the Bootmenu=1 ,  

    then you may need to change the value from 1 (one) to 0 (zero).

    Since Msdos.sys is a system file ,  before editing,

    At windows explorer, Right click Msdos.sys to select its properties.

    Unchecked for the boxes of
    [ ] read only          [ ] hidden

    Then OK,
    Use notepad to open the file C:\Msdos.sys
    At the [options], change the value from 1 (one) to 0 (zero), ie.
    Bootmenu=0

    Save and exit.

    Afterwards, checked back the boxes of  
    [x] read only          [x] hidden

Therefore, you will get a clean boot and stop the bootup menu.
------
Let us know if you have queries.     pslh
0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 1674194
above double pasted -messup the message. re-post as followings.     pslh
0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 1674195
Mike,

Perhaps, now you have a better perspective about the operating system of win98 and its Ms-DOS mode.

Thank for the reminder from Dew_associates/Dennis that :
<<Ramexam is a dos only program. It resets command.com, among other things, which when Windows sees it, Windows modifies its own files>>

Msdos.sys may be altered too by the Ramexam causing booting to the Startup BootMenu.
 
In order to make certain :-
a clean boot into the Windows desktop  and not to a menu.

You may need to
1>  On normal desktop of window, Use windows explorer to locate the file
     C:\ Msdos.sys

2>  Use notepad to open the file C:\Msdos.sys
    At the [options], see if there is  Bootmenu=0

    If the Bootmenu=0, then exit without save.

    But if the Bootmenu=1 ,  

    then you may need to change the value from 1 (one) to 0 (zero).

    Since Msdos.sys is a system file ,  before editing,

    At windows explorer, Right click Msdos.sys to select its properties.

    Unchecked for the boxes of
    [ ] read only          [ ] hidden

    Then OK.

    Use notepad to open the file C:\Msdos.sys
    At the [options], change the value from 1 (one) to 0 (zero), ie.
    Bootmenu=0

    Save and exit.

    Afterwards, checked back the boxes of    
    [x] read only          [x] hidden

Therefore, you will get a clean boot and stop the bootup menu.
------
Let us know if you have queries.     pslh
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article helps those who get the 0xc004d307 error when trying to rearm (reset the license) Office 2013 in a Virtual Desktop Infrastructure (VDI) and/or those trying to prep the master image for Microsoft Key Management (KMS) activation. (i.e.- C…
Sometimes clients can lose connectivity with the Lotus Notes Domino Server, but there's not always an obvious answer as to why it happens.   Read this article to follow one of the first experiences I had with Lotus Notes on a client's machine, my…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question