How can I eliminate sendmail from boot sequence?

I am using Redhat 5.1 and the boot sequence takes a frustrating long time.  One place that it waits for a long
time is "Starting sendmail".  As I do not use this computer to send or receive e-mail I would like to eliminat sendmail
from the boot process.

Who is Participating?
dsybiakConnect With a Mentor Commented:

You can try logging in as root
type "setup" at the terminal
choose system services from the menu
choose sendmail hit space to deselect
choose ok
hit esc at main menu to exit

That should fix your problem.
You can edit the sendmail cf file and oncomment
# my official domain name
# ... define this only if sendmail cannot automatically determine your domain

change this to your domain and sendmail will start at once
because sendmail does not get name resolved at the time
it starts it waits until the nameserver times out.

klopterAuthor Commented:
setup not only solved this problem for me it also
allowed to me to turn off smb - which was my next problem.
Now it boots quickly.  If only I could get X to work.
But, that is another question.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.