IP problem

hi,

sometime i can ping and get my IP (but slow), sometime i cant.
why this occur?
qazakaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rbrCommented:
more details pls. ping your own IP. Which network, which linux. Whats is the output of ifconfig.
0
qazakaAuthor Commented:

i m using freebsd.
when i ping at server , i can get the IP (bcos the IP is located inside the server)
i ping from my local PC , cant get it.

how to using 'ifconfig'?

0
rbrCommented:
Just type in ifconfig and post the output. Which IP to you ping. Your local IP or another. How is your network bould. Network card (which one), modem, ....
 
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

gunny051499Commented:
first make sure your hardware (wires) are ok. after that see if you set up the right network mask. as rbr said: post the output of ifconfig.
0
veoCommented:
Please give your exact sys conf and then print
output of ifconfig /sbin/ifconfig .If it shows only localhost ip i.e local loop back address 127.0.0.1.Then u have to configure your network ...
Check out the dmesg and see if the net card was picked up at boot time .Then check the physical connections on the system.


0
qazakaAuthor Commented:
usage: ifconfig interface address_family [address [dest_address]]
                [parameters]
       ifconfig -a [-d] [-u] [address_family]
       ifconfig -l [-d] [-u] [address_family]

ifconfig?

then dmesg

arp_rtrequest: bad gateway value
rtinit: wrong ifa (0xf32e2c80) was (0xf3303c00)
arp_rtrequest: bad gateway value
rtinit: wrong ifa (0xf340ad00) was (0xf343f480)
arp_rtrequest: bad gateway value
rtinit: wrong ifa (0xf34e9400) was (0xf34e9680)
arp_rtrequest: bad gateway value
rtinit: wrong ifa (0xf3336900) was (0xf34ce580)
arp_rtrequest: bad gateway value
rtinit: wrong ifa (0xf355f100) was (0xf35c0900)
arp_rtrequest: bad gateway value
rtinit: wrong ifa (0xf3385d80) was (0xf33bcc00)
arp_rtrequest: bad gateway value
rtinit: wrong ifa (0xf3422e00) was (0xf35b5400)
arp_rtrequest: bad gateway value
rtinit: wrong ifa (0xf3433280) was (0xf3376400)
arp_rtrequest: bad gateway value
rtinit: wrong ifa (0xf32b0280) was (0xf32ed080)
arp_rtrequest: bad gateway value
rtinit: wrong ifa (0xf3486300) was (0xf32a1200)
arp_rtrequest: bad gateway value
rtinit: wrong ifa (0xf34ca680) was (0xf3419700)
arp_rtrequest: bad gateway value
rtinit: wrong ifa (0xf34d5c80) was (0xf3569d00)
arp_rtrequest: bad gateway value
rtinit: wrong ifa (0xf2a7bb00) was (0xf3316500)
arp: 00:60:97:a7:3d:4a is using my IP address 206.235.122.22!
arp: 00:60:97:a7:3d:4a is using my IP address 206.235.122.22!
arp: 00:60:97:a7:3d:4a is using my IP address 206.235.122.22!

what is this mean?
help..me
0
EatEmAndSmileCommented:
You have an IP conflict on your network. At least two machines are using the same IP address... Change the IP addresses of the machines so as none of them have the same address. Prefferably, assign '192.168.1.x' IP addresses to your machines.

You also seem to have gateway problems... Make sure you configure your workstations with the right IP for your gateway.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
EatEmAndSmileCommented:
By the way, are you pinging IP addresses or hostnames?
0
qazakaAuthor Commented:
i m ping IP
0
qazakaAuthor Commented:
i m not very clear of your solution given.
could you give me more details way for fixing the problems

thanx alot
0
EatEmAndSmileCommented:
I believe you're using Red Hat, right?

Run 'linuxconf';
Go to the 'Network' settings;
There's a section for the local machine's IP address;
Change the IP address so every machine on your network have it's own IP address, like:

Computer 1 - 192.168.1.1
Computer 2 - 192.168.1.2
Computer 3 - 192.168.1.3
and so on...

This will fix the IP conflict that was noticed in your network.

And now about your gateway... Do you have a gateway? A gateway is a machine that links a network to other. It can be a machine with an ethernet card and a modem, or a machine with two ethernet cards, linked to two isolated networks... This would be your gateway. Put the IP address on the 'gateway' field of the same section on 'linuxconf'.

Good luck!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.