• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 322
  • Last Modified:

Us Robotics Modem troubles

I have a question regarding my US Robotics 56K internal modem. After much frustration and conflicting instructions in the box that the modem was packed in I have managed to get this modem to install in Windows. One pamplet, which was put there by the company that supplied me with the modem recommended that I install the modem by setting the jumpers for IRQ 3, Com 2. When I did that and installed the appropriate driver the modem ran like a dog and would not surf to any sites without returning a DNS error. I finally decided to use the instructions which US Robotics put in the box. They recommended that I use the default plug and play settings. Plug and Play set the modem to Com 2, IRQ 11 and it worked perfectly and travelled very fast to web sites. What on earth has happened here? Surely this modem should be able to be configured to work on IRQ 3, com 2. By the way I had turned the com port off in the bios.
  • 2
  • 2
  • 2
  • +6
1 Solution

I know what you mean as I have read that. That caused to set the Modem to use COM3 or COM4 if you have already COM1 and COM2. But if you insistly use COM2 as a PNP, you can do that (as what you did) but your default COM2 will be COM4 perhaps.

Do you have any problems surfing using your Modem?
> Surely this modem should be able to be configured to work on IRQ 3, com 2.

My USR Sportster modem worked fine as COM2/IRQ3.
Later, I moved it to COM4/IRQ3, so that the software
for my digital-camera could use COM2,
but that didn't have effect on the "speed" of the modem.

> would not surf to any sites without returning a DNS error.

This is not a symptom of a problem with your modem;
it's a symptom that your computer is not communicating,
to another computer on the Internet; specifically,
that other computer is running a "DNS-server".

A DNS-server "translates" names, e.g., 'www.experts-exchange.com',
into an IP-address, namely '',
because all communications over the Internet must be
messages from one IP-address to another IP-address.

Check that your COM2 port is not set to a "slow" speed
(9600?), which could cause the "non-greyhound" behaviour
which you have observed.

davepcam1Author Commented:
Your suggestion does not explain why, when the modem is jumpered for plug n'play and windows finds a driver for it that it works like a dream. I remember checking the modem speed setting when I was having the probs with the IRq3, COm2 problem and it was set to 115000.


I'm not having any probs surfing now but have asked the question because I would have thought that the manual configuration should have worked. I had nothing on com2 to conflict with the settings.
We Need Your Input!

WatchGuard is currently running a beta program for our new macOS Host Sensor for our Threat Detection and Response service. We're looking for more macOS users to help provide insight and feedback to help us make the product even better. Please sign up for our beta program today!

What about IRQ3? is there something else that was sharing it?
Another thing, maybe it is like a kid, they don't like being told to do something and if they are doing something and having fun until you tell them to do that, then they rebel.
Ain't a computer fun???
> Your suggestion does not explain why, when the modem is
> jumpered for plug n'play and windows finds a driver for
> it that it works like a dream.

Since COM1 and COM2 exist in hardware,
they could be defaulting to a "slow" speed.
On the other hand, when PnP "invents" a COM3 port,
it could be setting this port to a "high" speed.

> I remember checking the modem speed setting when I was
> having the probs with the IRQ3, COm2 problem and it was
> set to 115000.

Probably 115200, but that's not important.

Did you check the speed of the COM port,
in the hardware profile, or did you check
the setting which was configured for the modem?

Unless you set *both* values to '115200',
Windows will find the two different values,
and, as they say, "results will be unpredictable".

IRQ 3 may be in use by another device or another port, causing a conflict.  It's possible that another COM port is using IRQ3 and the system is attempting to share the IRQ with the modem, resulting in horrible performance.
davepcam1Author Commented:

I hadn't checked the speed setting on the com port. I didn't realize that it was adjustable. Thank you for that suggestion. I've just built another P3 system which will have the same type of modem installed in it. I'm determined to see if I can get this thing running on com2, irq3 so I will use your suggestion but also try what thoffman suggests and look out for a device using Irq3 although I think I used that option last time.
Also be aware that disabling a device in bios does not always prevent the OS from detecting the hardware and assigning resources.

Win95/98 have an annoying habit of detecting disabled com ports, as well as midi/game ports that are disabled.

My Isp said one time to use the 56000 setting, which is actually faster than the 150000. I use either on, depending if I have a problem
Try this.Remove all the com ports and the modem(physically remove it).Re-boot windows. The comports will be re-installed. Set your modem to whatever com port and IRQ you want to use. Put the modem in the computer. Remove whatever com port you want the computer to use.IE.-Com 3. Go to add/remove hardware in control panel. Don't search fo new hardware. Select modem from the list. Let windows search for your modem. It should find it on com 3. It will prompt you for the install disk, if not select have disk, browse to the cdrom drive and choose your modem from the list. The modem software should find the modem and detect which com port it is set to and install and assign that com port to your modem. Re-boot and com 3 will be re-installed by windows as com 4. This worked for me when installing an Aopen modem (56k) that used the Rockwell chipset.

Good Luck,



This question was awarded, but never cleared due to the JSP-500 errors of that time.  It was "stuck" against userID -1 versus the intended expert whom you awarded.  This corrects the problem and the expert will now receive these points; points verified.

Please click on your Member Profile and select "View Question History" to navigate through any open or locked questions you may have to update and finalize them.  If you are an EE Pro user, you can also choose Power Search to find all your open questions.

This is the Community Support link, if help is needed, along with the link to All Topics which reflects many TAs recently added.

Thank you,
Moderator @ Experts Exchange
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 2
  • 2
  • 2
  • +6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now