install kernel-2.2.10 problem

Hi,

I'm upgrading my system to run kernel-2.2.10 from kernel-2.0.X but unsuccessful. I did the following and got this error message.

cd /usr/src/linux
make xconfig; make dep; make clean; make zImage;

Before "make zImage" is done, it prompt this error:

"ld:warning:size of symbol `sdla_setup' changed from 599 to 31 in sdla.0 drivers/isdn/isdn.a(hisax.0)(__ksymtab+0x0): undefined reference to 'sed1_init_pcmcia'
make: ***[vmlinux] Error 1"

What does this error and warning messages mean? How do I fix it? Thanks for you help and suggestions.

qwertpoi
qwertpoiAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gunny051499Commented:
have you read /usr/src/linux/Documentation/Changes? you should make sure you have everything actualy needed.

if you are right and this doesn't help, get another kernel version (v2.2.5 should be one of the finest) and see what happens there.
0
qwertpoiAuthor Commented:
I've read the /Documentation/Changes. But what the error:
"make:***[vmlinux] Error 1" mean?
0
marcooCommented:
Use make zlilo instead of make zImage...
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

gunny051499Commented:
the use of zImage or zlilo is not relevant for this error. sorry marcoo.

the error "make:***[vmlinux] Error 1" simply means that there was an error while trying to make the target called "vmlinux". this is related to the previous error-messages or warnings. just for a try: leave out support for your isdn subsystem in setup and compile. what happens?
0
qwertpoiAuthor Commented:
I took gunny's suggestion and tried installing v2.2.5 and got a different error messages. The first message: "System is too big. Try using bzImage. make[1]:*** [zImage] Error 1". So I repeat the installation steps, and this time, I used bzImage instead of zImage. It did not work, it prompt this error message.

"tools/build -b bbootsect bsetup compressed/bvmlinux.out CORRECT > bzImage

Root device is (3,2)
Boot sector 512bytes
Setup is 3424 bytes
System is 1444 Kb
System is too big. Try using modules.
make[1]:***[bzImage] Error 1
make[1]:leaving directory '/usr/src/linux/arch/i386/boot
make:***[bzImage] Error 2"

P.S. I did selected to support modules in "make xconfig".

Is this mean that I don't have enough disk space? I have about 170Mb free space. How much disk space does the kernel use if it is selected to support everything? Thanks.
0
gunny051499Commented:
oh my god!!! what are you trying to compile into this kernel????? a big and I MEAN a realy BIG kernel of mine is usualy about 700 kb. what did you do to get it 1444 kb?????? ?-)

are you sure, you selected _just_ the things you need??? haven't you selected some drivers to be compiled as modules?

do that and you will be all right. i still don't know what exactly could be the problem with the isdn driver. anyway, first we will try to get out to a working kernel, afterwards we can worry to debug in detail.
0
qwertpoiAuthor Commented:
I've compiled and installed the new kernel v2.2.5 but when I did "uname -r", it prompt version 2.2.4. Is it because certain patch(es) is not install?

I tried to install the patch-2.2.5 patches but encounter the following message:"prviously applied patch detected: Assume -R?". What does this message mean? Should I say "yes" or "no"?

I'm booting from a floppy disk which I have made with "mkbootdisk" command  and get a "Uncompressing linux ..." message. Is this normal?

How do I assign points to the people that help me?
0
gunny051499Commented:
the message:

I tried to install the patch-2.2.5 patches but encounter the following message:"prviously applied patch detected: Assume -R?". What does this message mean? Should I say "yes" or "no"?

means, you have a problem. i'm quite sure you are using patch version 2.0/2.1 or whatever it was called. for the newer kernels (perhaps it already startet with 2.2.5) this version of patch will no longer work. you MUST get verion 2.5!!!

that means: get a clean "vanilla" kernel tree from some ftp.kernel.org server.... and patch it with patch v2.5 from now on....

the "uncompressing linux" message should not be wrong... ;)

points are assigned, when someone proposes his ideas as "answer" and not as "comment" as i do now...
0
gunny051499Commented:
this would be an example of how you could assign points :)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.