Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

RedHat 6.0 Pop3 Server

Posted on 1999-07-24
4
Medium Priority
?
384 Views
Last Modified: 2013-12-15
I am running RedHat 6.0 with an Intel Etherexpress 16 network card. I cannot get my pop3 server to work. I only want to use the normal pop3d but when i uncomment the pop-3 part of 'inetd.conf' and check to make sure pop3 is enabled in /etc/services it still doesn't work.

I connect to the port fine, but the pop3d deamon does not seem to comeup (no little welcome message) and after a couple of seconds the connection times out. I cannot issue any commands or anything either.

Any ideas?

0
Comment
Question by:moustachio
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 1

Expert Comment

by:reciprocity
ID: 1629847
Hi,

It could be your network card.What kind of network are you connected to ? It's either that or it's your settings. I can't elaborate much more than that. Based on your info.
0
 

Author Comment

by:moustachio
ID: 1629848
I'm testing this on a stand-alone. I am using an Intel EtherExpress 16. The weird things is that the pop3d server DOES work with slackware which i tried the other day when redhat's didn't. I can't figure out what is different in redhat. It did, however, like I said, work on SL\lackware with the same netconfig so it chouldn't be my hardware\.

Any other ideas? Do you use Redhat 6.0?
0
 
LVL 1

Accepted Solution

by:
jtg earned 300 total points
ID: 1629849
Have you checked to make sure the pop3 daemon is where inetd is looking for it? Does it have the corect permissions. I have downloaded and installed qpopper on mine for the same reason and it works a treat.

In answer to what is different, the biggest difference causing problems like this is the upgrade of the glibc environment. to correct this you can either mess you whole system up with lots of dirty links all over the place, or download a new source file, and recompile in the new environment.
0
 

Author Comment

by:moustachio
ID: 1629850
Thanks jtg...it was looking in the wrong place :) I tried qpopper before but with problems because of shadow md5 and i couldn't get -dauth to work on the configure file. anyway, thanks!
0

Featured Post

CHALLENGE LAB: Troubleshooting Connectivity Issues

Goal: Fix the connectivity issue in the lab's AWS environment so that you can SSH into the provided EC2 instance.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How many times have you wanted to quickly do the same thing to a list but found yourself typing it again and again? I first figured out a small time saver with the up arrow to recall the last command but that can only get you so far if you have a bi…
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Suggested Courses

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question