Low System & GDI Resources in Windows 98

We are using Windows 98 2nd edition with Novell Client 3.10 and Zenworks (Netware 5).  When Windows boots up we only have 48% maximum Windows system resources free before we even try to run anything!  I have tried closing down my virus checker, toolbars, system tray icons and STILL only get about 48% free resources.

HELP!!!  What can I try?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

To find out where applications are being Started from:

1. Start Button
2. Programs
3. Accessories
4. System Tools
5. System Information.
6. Expand "Software Environment" click on "Startup Programs".

Copy all the apps showing, SI has a copy feature>>>then please post the results.

Bud's Win95 Win98 Tips and Troubleshooter
Shazzer, without knowing how much ram you have installed on this machine, the first place I would begin looking would be at your Netware setup. Unfortunately if this is setup incorrectly it will eatup resources like nothing else! Also, there are two files that you should try and get from Novell or from Microsoft, and they are either:

Windows 98 w\Internet Explorer 4.01 Service Pack 1

3/11/99 10:05am 4.72.3515.1100 1,389,328 Shell32.dll


Windows 98 w\Internet Explorer 4.01 SP2 or Internet Explorer 5

4/27/99 4:55pm 4.72.3704.2700 1,390,352 Shell32.dll

As a test, remove the netware protocols, reboot and then recheck the resources.


Is a virtual device driver claiming a portion of RAM?
To determine whether a virtual device driver is being loaded from the System.ini file
Click Start, and then click Run.
In the Open box, type Msconfig.exe, and then click OK.
On the General tab, click to select Selective Startup.
Click to clear the Process System.ini file check box.
Click OK, and then click Yes when prompted to restart your computer.
Did your screen display the correct amount of memory after you restarted your computer?
If not, repeat the steps above, but on the General tab, click to select Normal Startup.

If disabling the System.ini file corrects the problem, the next step is to determine which file referred to in the System.ini file is causing the problem.

To determine which file is causing the problem

Click Start, and then click Run.
In the Open box type Msconfig.exe, and then click OK.
On the System.ini tab, double-click [386Enh] to open it.
Click to clear the check box next to the first line that does not contain a small Windows logo.
Click OK, and then click Yes to restart your computer.
If the problem recurs, repeat steps 1 through 3, and then click to select the check box that you just cleared.
Repeat steps 4 and 5 for the next line. Repeat this process until the problem recurs. The file that was cleared just before the recurrence is the problem file.
Temporarily disable the file by keeping its check box clear until you find a permanent solution.


This might help solve your PC speed.

Click the Start button, then Settings, then Control Panel. In the Control Panel, click on the System Icon. Once in the System, select Performance tab. Click on the File System button. Change te machine role to Network Server. This will drastically enchances the use of upper memory especially in machines with more than 32MB of RAM.

Let me tell you that Windows 95/98 does not use Smartdrive to cache the hard drives in your system. Instead, it uses 32bitVCache that dynamically grows and shrinks as the need arises(not to be confused with Swapfile, which operates in a similar manner). If you have more than 32MB of physical memory, VCache maybe using more memory than it can effeciently manage. You can limit the maximum amount of physical memory VCache used by adding the following to the System.ini file:


The above values are in Kbytes. Feel free to experiment, but you must have a value greater than 0 for the MinFileCache value. By limiting the VCache in this manner, you will experience IMPROVED SYSTEM PERFORMANCE.


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Shazzer, are you still with us?

This question was awarded, but never cleared due to the JSP-500 errors of that time.  It was "stuck" against userID -1 versus the intended expert whom you awarded.  This corrects the problem and the expert will now receive these points; points verified.

Please click on your Member Profile and select "View Question History" to navigate through any open or locked questions you may have to update and finalize them.  If you are an EE Pro user, you can also choose Power Search to find all your open questions.

This is the Community Support link, if help is needed, along with the link to All Topics which reflects many TAs recently added.

Thank you,
Moderator @ Experts Exchange
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.