Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

PPP Routing table entries

Posted on 1999-07-26
11
Medium Priority
?
298 Views
Last Modified: 2010-03-18
I have Linux (Redhat 5.2) networked with two other PC's and now want to connect to my freeserve account. I have configured CHAP and the modem dials to the server and connects.

If I do "ifconfig -a" I have three interfaces appear; loopback, eth0 and ppp0, I can ping all three addresses but cannot ping or nslookup any other address. I think this is something to do with the default route setting (10.1.1.1) but can't seem to be able to change the default route to the ppp interface, nslookup and netstat -r appear to "hang" but this may be trying to resolve addresses.

Can anyone point me in the right direction and what files need to be edited blah blah.


Cheers,

J :)
0
Comment
Question by:jools
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 2
  • +1
11 Comments
 
LVL 7

Expert Comment

by:HalldorG
ID: 1585874
The solution may be to not add your default route to
the eth0 interface.
Only have net 10.0.0.0 255.0.0.0 there
and use the defaultroute parameter with the ppp connection
0
 
LVL 19

Author Comment

by:jools
ID: 1585875
Yes I know but how?? If it were another Unix I'd know how but this linux networking thing just baffles me!

0
 
LVL 8

Expert Comment

by:stefanx
ID: 1585876
Edit /etc/rd.c/rc.inet1 and comment out the line that says something like:

route add default gw xxx.xxx.xxx.xxx

(xxx.xxx.xxx.xxx) is an IP address on your eth0 subnet
Then, when you establish the ppp connection say :

route -add default gw ppp0

(I don't know if ppp0 is allowed here and I don't have a Linux box here to check, but I think you get the idea)
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 8

Expert Comment

by:stefanx
ID: 1585877
Incidentally, to prevent DNS lookups, rather say netstat -nr ;)
0
 
LVL 19

Author Comment

by:jools
ID: 1585878
Thanks for the inifo.

I'll give it a go tonight, let you know tomorrow....
0
 
LVL 19

Author Comment

by:jools
ID: 1585879
Nearly there, I am now using netscape from linux, you comments weren't accurate for Redhat but certainly pointed me in the right direction.

The dial up connection doesn't add the default route automatically but after netstat -r resolves ok (see below)

If you can assist with the routing information to be added automatically, the points are your's

I'll post more infor here when done...


netstat -r output

Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
cortizone.dialu *               255.255.255.255 UH     1500 0          0 ppp0
127.0.0.0       *               255.0.0.0       U      3584 0          0 lo
10.0.0.0        *               255.0.0.0       U      1500 0          0 eth0
default         cortizone.dialu 0.0.0.0         UG     1500 0          0 ppp0
default         scratchy        0.0.0.0         UG     1500 0          0 eth0

ifconfig output

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Bcast:127.255.255.255  Mask:255.0.0.0
          UP BROADCAST LOOPBACK RUNNING  MTU:3584  Metric:1
          RX packets:35123 errors:0 dropped:0 overruns:0 frame:0
          TX packets:35123 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0

eth0      Link encap:Ethernet  HWaddr 00:60:97:D9:47:A9  
          inet addr:10.1.1.1  Bcast:10.255.255.255  Mask:255.0.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:263 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0
          Interrupt:11 Base address:0x6000

ppp0      Link encap:Point-to-Point Protocol  
          inet addr:62.136.58.228  P-t-P:195.92.68.154  Mask:255.0.0.0
          UP POINTOPOINT RUNNING  MTU:1500  Metric:1
          RX packets:477 errors:0 dropped:0 overruns:0 frame:0
          TX packets:459 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0
          Memory:26f9038-26f9c04




0
 
LVL 2

Expert Comment

by:helver
ID: 1585880
Couple things I see that could be issues here:

First, I think traditionally a non-connected network uses 192.168.* for its IP addresses... I guess 10.* might be the class A variety, but 192.168.* is more common for people with your size network.

Second it looks like your networking scripts assign a default route to the eth0 device.  This will likely cause problems and will conflict with your true default route out ppp0.  So long as you have a defined route to your local network through eth0, you shouldn't need a default route that points there.  So basically line 5 of your netstat output shouldn't be there.
0
 
LVL 19

Author Comment

by:jools
ID: 1585881
I use the 10.* IP address range because these tend to be anonymous address which are ideal for my uses, although I can use whatever I want as long as I don't setup some sort of gateway between the my local network and the internet...might upset someone!

I know there is a duplicate routing entry but I can't seem to find the correct file to edit it from. The HOW-TO's seem a bit vague or unclear, this is what I meant to say when I mentioned (above) the automatic routing information entries.

What I need is the default route to be added to the ppp0 interface and a static route for local traffic, although there may not be any need to have a local route at all as it is in the same subnet at the moment, I'm still trying to find the right files to edit to make this happen.
0
 
LVL 2

Expert Comment

by:helver
ID: 1585882
A kludgey solution would be delete the current default route just before you add the ppp0 default route:

route delete default

Another thing you may want to check out is /etc/sysconfig/network.  I think that by setting GATEWAY to 0.0.0.0 you make it so that the system doesn't initially assign a default route.
0
 
LVL 19

Author Comment

by:jools
ID: 1585883
Thanks for that, if you send an answer response, you'll get the points.

J :)
0
 
LVL 2

Accepted Solution

by:
helver earned 100 total points
ID: 1585884
Thank you, sir.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question