Modem and phone line problem

I have an IBM 600E laptop.  My dial-up networking works
with some phone lines and not others.  I believe that
all my properties are set up correctly (my ISP is NetZero).
If I use a phone line that "works", everything works just
fine.  When I use a phone line that is a problem, the
modem calls the number, you can hear the ISP answer,
the typical noises go back and forth.  The connection
is never actually made, even after as much as five
minutes.  It does seem to be related to the phone line.
I can repeatedly hook up on the "good" lines, and
repeatedly fail on the "bad" lines.  Unfortunately,
one of the "bad" lines is my home line!  To further
complicate matters, my desktop never has a problem
on the same line at home.

Who is Participating?
Did you try a new phone wire from laptop to the wall?  Are you using the same phone jack at your house for the laptop and desktop?
eastertAuthor Commented:
At home, the phone wire and phone jack are the same
for my laptop and desktop.
We Need Your Input!

WatchGuard is currently running a beta program for our new macOS Host Sensor for our Threat Detection and Response service. We're looking for more macOS users to help provide insight and feedback to help us make the product even better. Please sign up for our beta program today!

This is a long shot and may not work, but have you measured the carrier voltage
on the good lines and then compared that voltage reading to the reading you
get from the bad lines.  In some areas, the carrier voltage on the copper phone
lines is 48 VDC and in other areas it is 24 VDC.  I have found that some laptop
modems will fail to connect if the 48 VDC is down to 45 VDC or the 24 VDC is
down to 23 VDC.

You might also try using a noise filter on the phone line between your laptop
modem and the phone jack.  These phone line noise filters are available
from your local Radio Shack dealer.

Have you tried checking the modem properties once you tried to connect to the said bad line. Maybe that phone line is pulse not tone.
eastertAuthor Commented:
Thank you for your suggestion.  I checked - all the "bad" phone lines are tone.
1. Check for the S10 register setting for the modem on the laptop.
by the command ATS10? . The maximum value for this is 255.This means
that the modem waits for 25.5secs before disconnecting . also S7 register should be set to 60 with the command ATS7=60&w for storing.


This question was awarded, but never cleared due to the JSP-500 errors of that time.  It was "stuck" against userID -1 versus the intended expert whom you awarded.  This corrects the problem and the expert will now receive these points; points verified.

Please click on your Member Profile and select "View Question History" to navigate through any open or locked questions you may have to update and finalize them.  If you are an EE Pro user, you can also choose Power Search to find all your open questions.

This is the Community Support link, if help is needed, along with the link to All Topics which reflects many TAs recently added.
Thank you,
Moderator @ Experts Exchange
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.