Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

NT Service Application

Posted on 1999-07-30
7
Medium Priority
?
181 Views
Last Modified: 2010-04-04
I'm trying to write an NT Service Application. After I create the project with the wizard I compile it and run it. I look in the Event Viewer and I see the following error message:

The description for Event ID ( 0 ) in Source ( Project1.exe ) could not be found. It contains the following insertion string(s): Class does not exist.

and

The description for Event ID ( 0 ) in Source ( Service1 ) could not be found. It contains the following insertion string(s): The handle is invalid.

What is happening? Why my application is not running?
0
Comment
Question by:QAZY
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +1
7 Comments
 
LVL 20

Expert Comment

by:Madshi
ID: 1392058
I've not done any service programming yet. But perhaps this site helps:

http://www.jgsoftware.com/nt.htm

It contains a lot of Delphi examples about services.

Regards, Madshi.
0
 
LVL 17

Expert Comment

by:inthe
ID: 1392059
damn too fast madshi :o)
i too was going ot advise that site :-)it is good for service stuff
Regards Barry
0
 
LVL 20

Expert Comment

by:Madshi
ID: 1392060
Sorry, Barry...   :-)
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 13

Accepted Solution

by:
Epsylon earned 400 total points
ID: 1392061
You must first install the service by running it with INSTALL as parameter:

project1 -INSTALL

project1 -remove   to remove it

Cheers,

Epsylon.
0
 

Author Comment

by:QAZY
ID: 1392062
Thanks a lot Epsylon. It seems that this was the problem. I followed your advice and my service was installed. Then I could start it from Service Manager.
0
 

Author Comment

by:QAZY
ID: 1392063
I forgot to tell you something:

In order to uninstall the service you must run it with the parameter -UNINSTALL and not -REMOVE.

0
 
LVL 13

Expert Comment

by:Epsylon
ID: 1392064
My mistake then. Sorry.

Glad it works now and thanks for the points.    :o)

Cheers,

Epsylon.
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this tutorial I will show you how to use the Windows Speech API in Delphi. I will only cover basic functions such as text to speech and controlling the speed of the speech. SAPI Installation First you need to install the SAPI type library, th…
Creating an auto free TStringList The TStringList is a basic and frequently used object in Delphi. On many occasions, you may want to create a temporary list, process some items in the list and be done with the list. In such cases, you have to…
This course is ideal for IT System Administrators working with VMware vSphere and its associated products in their company infrastructure. This course teaches you how to install and maintain this virtualization technology to store data, prevent vuln…
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question