Install Delphi 4 CS Suite

Delphi 4 Client server Suite after setup does not launch
Delphi32 !
NT 4 (SP5) displays "Error starting app. 0-000005 etc...).
Win 98 displays " Required *.dll  @#.dll is missing...)
On Win 95 everything works fine !
What could be wrong ????
LVL 22
senadAsked:
Who is Participating?
 
intheConnect With a Mentor Commented:
Hi Senad
when you reinstall after the format you will notice a signifigant speed increase with the windows;/system dirsectory being clean.i did mine a while ago and it was great.sorry it wasnt a "solved" answer but it about all it could be is the system has just got in a mess and doesnt know whats what.the registry can be a pain like that :-(

Hi Gabe :-)

0
 
intheCommented:
id advise uninstall delphi first from add remove programs then reinstall.
how did you install before?
did you have  a previous version of delphi installed?
have you installed update packs in the wrong order?
0
 
chengjianCommented:
if it's the problem of ur displaycard d/l a patch from borland, or do not use hardware optimize(perhaps something similar, in control panel/system)
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
intheCommented:
but the display problem doesnt cause that required dlls are missing error..it causes delphi to lock up on booting the splashscreen..
0
 
senadAuthor Commented:
Previous version was Delphi 3 Pro...
I uninsytalled it with Add-Remove programmes....deleted
remaining directories and then installed D4.
No error msg whatsoever...Setup completed nice...
Anyway....what updates pack?For what??

0
 
intheCommented:
glad you have it sorted :-)

for the update pack information see here:
http://www.borland.com/devsupport/delphi/downloads/

get update 2 then update 3 etc
they just fix the  odd minor "bug" etc..
Regards Barry

0
 
senadAuthor Commented:
Sorry,you got me wrong...
I still can not install D4!
(It wont launch Delphi 32)...
But ...I am beggining to see the light although
I still do not know what is wrong.
It has something to do with ODBC since after
removing it I got screwed for Office compatibility.
Can not call App. within App. no more...
Access command buttons are screwed...
****!
So let me know if you have a clue...
0
 
intheCommented:
heck sorry i misunderstood ;-)
i would reinstall the office updates(if you have them)
i dunno where they are on the web but i got mine on a
magazine coverdisc.

well it's possible the registry is screwed up.
i had this before and i think i ran norton utilities on it to clean it up which worked ok for me,
so if you can get hold of one of the various registry checking tools and run it that would be a good idea.
doesnt sound good if that dont fix it apart from reinstalling eevrything which im sure you dont want to do:-(
so i hope others have more ideas

0
 
GabeinOZCommented:
Well I don't have any suggestions but just to back up inthe's (hey Barry) comment and advise you to format and start over.  I've been using D4 C/S with paradox and access for almost a year now and I have found that Delphi is really picky about being installed on a "dirty" machine.  I'm guessing this may not be something you want to do, but any developer should be ready to do so at the drop of a hat considering we push our machines to their limits and over.  

The reason inthe suggested the updates is because if you install them in the wrong order you get dll compatibility problems so you have to go D4...update pack1...upd 2...upd3..in that order.  As Barry said you can find these on Borlands site but thats a side issue.

Hope you get it rocking Senad....D4 is a nice little tool once you get it going ;)

Gabe
0
 
senadAuthor Commented:
I would gladly update,but I cant seem to have basics running.However you gave me an idea....
I will format the disk,install D4 CS first,and then
install updates one buy one (without running the prog. for
the first time).
Maybe that will work...
So Barry...you can have the points since I think I will not
get a "solution solved" answer...
Thanx all !
0
 
senadAuthor Commented:
We shall give it a try ...
I am very disgusted in Office 2000 and D4 CS...
These things are supposed to work without problem....
Grrrrr.....

Aloha !
0
All Courses

From novice to tech pro — start learning today.