Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Redhat 6.0 Anonymous FTP HELP!!!

Posted on 1999-08-19
6
Medium Priority
?
294 Views
Last Modified: 2010-03-18
Recently we upgraded our server from Redhat 5.2 to Redhat 6.0.  Anonymous FTP worked up until the upgrade. Now, you can still log in as Anonymous, but cannot write anything to the Upload directory. Note: This also worked fine before. I think I have all the rights and FTP* files correct, but still it doesn't work. What could I be doing wrong?
0
Comment
Question by:JohnSanderbeck
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 7

Expert Comment

by:HalldorG
ID: 1586226
shadow passwords?
correct librarys on /home/ftp/lib?
0
 

Author Comment

by:JohnSanderbeck
ID: 1586227
Yes, I turned Shadow Passwords on. I did not have them enabled in the 5.2 Installation.

The correct libraries should be in there from the 5.2 install, unless I require additional ones.  Here is what I have in there (also I have my FTP home pointing to /usr3/ftphome for the larger partition):

ld-2.0.7.so
ld-2.1.1.so
ld-linux.so.2
libc-2.0.7.so
libc-2.1.1.so
libc.so.6
libnsl-2.0.7.so
libnsl-2.1.1.so
libnsl.so.1
libnss_files-2.0.7.so
libnss_files-2.1.1.so
libnss_files.so.1
libnss_files.so.2

Another thing I noticed is even logged in as a regular user, I cannot see what is in the BIN directory. I get no file listing even though tar, gzip, etc...  are in there.
Files are public readable and executable though...
0
 
LVL 1

Expert Comment

by:pogga
ID: 1586228
Run control-panel. That seems to be pretty good for setting up anonymous ftp, atleast I had no problems.

There is a section in it which deals specifically with permission settings for anonymous users.  Also make sure within the system that the ftp process can write to the upload directory, ie that root doesn't have exclusive write access.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 2

Expert Comment

by:wqclatre
ID: 1953437
I also had some trouble with the wu-ftpd that followd RedHat 6.0. Anyway, They have discoverd many bugs Wu-ftpd lately so If I was you I should install proftpd instead.
I think it's easy to install and configruate.

ftp://updates.redhat.com/powertools/6.0/i386/proftpd-1.2.0pre3-6.i386.rpm

All you have to do is to edit /etc/inetd.conf and replace
ftp    stream  tcp     nowait  root    /usr/sbin/tcpd  in.ftpd -l -a

With:
ftp     stream  tcp     nowait  root    /usr/sbin/tcpd  in.proftpd

And then edit /etc/proftpd.conf



0
 
LVL 2

Expert Comment

by:wqclatre
ID: 2016925
Read:
http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html

-----------cut--------------

Make very sure that you have the latest
         version of wu-ftpd (2.5.0), set your path-filter to the one mentioned above. Make the incoming directory owned by
         something else then ftp (root, or nobody) with another group then ftp (nobody). Something like :

         drwx-wx-wt       root    nobody        incoming

         This will allow ftp to write in the directory, but not read it. Set the upload directive in ftpaccess to something like :

         upload    /home/ftp    /incoming   yes root daemon 0400 nodirs

         One note : files get created as root and changed to the owner mentioned in the upload line. This will fail on some secure
         NFS setups.

-------cut-----------
0
 
LVL 2

Accepted Solution

by:
tmoss earned 140 total points
ID: 2023275
in addition to giving write permission to the file system directory (which I assume you have since it used to work), you need to add a line to /etc/ftpaccess in the following format.

upload <ftp home directory> <writable directory> <yes/no> <user> <group> <mask>

for example, this is how to give permission to write to /home/ftp/incoming, assuming /home/ftp is the ftp user's home directory (and it should be under Red Hat)

upload  /home/ftp  /incoming  yes  nobody  nobody  0666

(note, this should be all one line though it may be wrapped here)

you can add "nodirs" to the end as the previous post notes which disallows the creation of directories.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question